automatic version update by autodist [release 4.8-1mamba;Mon Jun 10 2013]
This commit is contained in:
parent
3d6518f452
commit
e9e0e9f374
@ -1,2 +1,7 @@
|
||||
# strace
|
||||
|
||||
Strace is a system call trace, i.e. a debugging tool which prints out a trace of all the system calls made by a another process/program.
|
||||
The program to be traced need not be recompiled for this, so you can use it on binaries for which you don't have source.
|
||||
System calls and signals are events that happen at the user/kernel interface.
|
||||
A close examination of this boundary is very useful for bug isolation, sanity checking and attempting to capture race conditions.
|
||||
|
||||
|
14
strace-4.7-os-release-detect-openmamba.patch
Normal file
14
strace-4.7-os-release-detect-openmamba.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- strace-4.7.orig/strace.c 2012-04-16 18:22:19.000000000 +0200
|
||||
+++ strace-4.7/strace.c 2012-11-05 16:53:18.494816999 +0100
|
||||
@@ -1432,6 +1432,11 @@
|
||||
break;
|
||||
while (*p >= '0' && *p <= '9')
|
||||
p++;
|
||||
+ if (*p != '.') {
|
||||
+ rel = (rel << 8);
|
||||
+ if (rel >= KERNEL_VERSION(1,0,0))
|
||||
+ break;
|
||||
+ }
|
||||
if (*p != '.')
|
||||
error_msg_and_die("Bad OS release string: '%s'", u.release);
|
||||
p++;
|
95
strace.spec
Normal file
95
strace.spec
Normal file
@ -0,0 +1,95 @@
|
||||
Name: strace
|
||||
Version: 4.8
|
||||
Release: 1mamba
|
||||
Summary: A debugging tool which prints out all the system calls made by a process/program
|
||||
Group: Development/Tools
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Aleph0 <aleph0@openmamba.org>
|
||||
URL: http://sourceforge.net/projects/strace/
|
||||
Source: http://downloads.sourceforge.net/strace/strace-%{version}.tar.xz
|
||||
Patch0: strace-4.7-os-release-detect-openmamba.patch
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
License: GPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Strace is a system call trace, i.e. a debugging tool which prints out a trace of all the system calls made by a another process/program.
|
||||
The program to be traced need not be recompiled for this, so you can use it on binaries for which you don't have source.
|
||||
System calls and signals are events that happen at the user/kernel interface.
|
||||
A close examination of this boundary is very useful for bug isolation, sanity checking and attempting to capture race conditions.
|
||||
|
||||
%package graph
|
||||
Summary: A script that processes strace output files
|
||||
Group: Development/Tools
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description graph
|
||||
Strace is a system call trace, i.e. a debugging tool which prints out a trace of all the system calls made by a another process/program.
|
||||
The program to be traced need not be recompiled for this, so you can use it on binaries for which you don't have source.
|
||||
System calls and signals are events that happen at the user/kernel interface.
|
||||
A close examination of this boundary is very useful for bug isolation, sanity checking and attempting to capture race conditions.
|
||||
This package contains strace-graph, a script that processes strace output files.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/strace
|
||||
%{_bindir}/strace-log-merge
|
||||
%{_mandir}/man1/strace.*
|
||||
%doc AUTHORS COPYING CREDITS
|
||||
#ChangeLog NEWS README README-linux
|
||||
|
||||
%files graph
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/strace-graph
|
||||
|
||||
%changelog
|
||||
* Mon Jun 10 2013 Automatic Build System <autodist@mambasoft.it> 4.8-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Nov 05 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 4.7-2mamba
|
||||
- added a patch to fix OS release detection in openmamba by parsing uname output
|
||||
|
||||
* Wed Oct 31 2012 Automatic Build System <autodist@mambasoft.it> 4.7-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu May 12 2011 Automatic Build System <autodist@mambasoft.it> 4.6-1mamba
|
||||
- update to 4.6
|
||||
|
||||
* Wed Dec 01 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.5.20-2mamba
|
||||
- added strace-graph package to put apart perl dependency
|
||||
|
||||
* Tue Apr 20 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.5.20-1mamba
|
||||
- update to 4.5.20
|
||||
|
||||
* Sun Oct 25 2009 Automatic Build System <autodist@mambasoft.it> 4.5.19-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Aug 29 2008 Aleph0 <aleph0@openmamba.org> 4.5.18-1mamba
|
||||
- update to 4.5.18
|
||||
|
||||
* Wed Jun 28 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 4.5.14-1qilnx
|
||||
- update to version 4.5.14 by autospec
|
||||
|
||||
* Thu Nov 10 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 4.5.12-1qilnx
|
||||
- update to version 4.5.12 by autospec
|
||||
|
||||
* Mon Mar 14 2005 Davide Madrisan <davide.madrisan@qilinux.it> 4.5.9-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user