automatic version update by autodist [release 2.5-1mamba;Thu Jan 16 2014]

This commit is contained in:
Automatic Build System 2024-01-05 18:06:44 +01:00
parent 3d0347552e
commit 71b4dcec48
4 changed files with 110 additions and 0 deletions

View File

@ -1,2 +1,15 @@
# sshfs # sshfs
SSHFS is a filesystem client based on the SSH File Transfer Protocol.
Since most SSH servers already support this protocol it is very easy to set up: i.e. on the server side there's nothing to do.
On the client side mounting the filesystem is as easy as logging into the server with ssh.
The idea of sshfs was taken from the SSHFS filesystem distributed with LUFS, which I found very useful.
There were some limitations of that codebase, so I rewrote it.
Features of this implementation are:
* Based on FUSE (the best userspace filesystem framework for linux ;-)
* Multithreading: more than one request can be on it's way to the server
* Allowing large reads (max 64k)
* Caching directory contents

9
sshfs-1.8-cflags.patch Normal file
View File

@ -0,0 +1,9 @@
--- Makefile.am.orig 2007-06-01 18:37:39.000000000 +0200
+++ Makefile.am 2007-06-01 18:39:03.000000000 +0200
@@ -25,5 +25,5 @@
rm -f "$(DESTDIR)$(libdir)/sshnodelay.so"
sshnodelay.so:
- $(CC) -Wall -W -s --shared -fPIC $(sshnodelay_libs) sshnodelay.c -o sshnodelay.so
+ $(CC) $(CFLAGS) -Wall -W --shared -fPIC $(sshnodelay_libs) sshnodelay.c -o sshnodelay.so
endif

9
sshfs-help2man Normal file
View File

@ -0,0 +1,9 @@
#!/bin/sh
PATH=.:$PATH
if [ "$1" == "--version" ]; then
sshfs $@ 2>&1 | grep SSHFS | tr [:upper:] [:lower:]
else
sshfs $@ 2>&1
fi

79
sshfs.spec Normal file
View File

@ -0,0 +1,79 @@
Name: sshfs
Version: 2.5
Release: 1mamba
Summary: A filesystem client based on the SSH File Transfer Protocol
Group: System/Kernel and Hardware/Drivers
Vendor: openmamba
Distribution: openmamba
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
URL: http://fuse.sourceforge.net/sshfs.html
Source: http://downloads.sourceforge.net/fuse/sshfs-fuse-%{version}.tar.gz
Source1: %{name}-help2man
Patch: %{name}-1.8-cflags.patch
License: GPL
BuildRequires: libfuse-devel
BuildRequires: libglib-devel
BuildRequires: help2man
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
SSHFS is a filesystem client based on the SSH File Transfer Protocol.
Since most SSH servers already support this protocol it is very easy to set up: i.e. on the server side there's nothing to do.
On the client side mounting the filesystem is as easy as logging into the server with ssh.
The idea of sshfs was taken from the SSHFS filesystem distributed with LUFS, which I found very useful.
There were some limitations of that codebase, so I rewrote it.
Features of this implementation are:
* Based on FUSE (the best userspace filesystem framework for linux ;-)
* Multithreading: more than one request can be on it's way to the server
* Allowing large reads (max 64k)
* Caching directory contents
%prep
%setup -q -n %{name}-fuse-%{version}
%patch
sed -i "s|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|" configure.ac
%build
autoreconf -fi
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
install -m 755 %{S:1} .
install -d %{buildroot}/%{_mandir}/man8
help2man ./%{name}-help2man > %{buildroot}/%{_mandir}/man8/%{name}.8
gzip %{buildroot}/%{_mandir}/man8/%{name}.8
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_bindir}/%{name}
#%{_libdir}/*.so
%{_mandir}/man1/%{name}.1.gz
%{_mandir}/man8/%{name}.8.gz
%doc AUTHORS COPYING
#ChangeLog FAQ.txt NEWS README
%changelog
* Thu Jan 16 2014 Automatic Build System <autodist@mambasoft.it> 2.5-1mamba
- automatic version update by autodist
* Thu Jan 31 2013 Automatic Build System <autodist@mambasoft.it> 2.4-1mamba
- automatic version update by autodist
* Tue Jan 27 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2-1mamba
- automatic update by autodist
* Fri Jun 01 2007 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 1.8-1mamba
- update to 1.8
* Thu May 03 2007 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 1.7-1mamba
- package created by autospec
- added man page