update to 1.4.4_20140620git [release 1.4.4_20140620git-1mamba;Fri Jun 20 2014]
This commit is contained in:
parent
577437cac7
commit
80eea3d43c
@ -1,2 +1,4 @@
|
|||||||
# srtp
|
# srtp
|
||||||
|
|
||||||
|
This package provides an implementation of the Secure Real-time Transport Protocol (SRTP), the Universal Security Transform (UST), and a supporting cryptographic kernel. These mechanisms are documented in the Internet Drafts in the doc/ subdirectory. The SRTP API is documented in include/srtp.h, and the library is in libsrtp.a (after compilation).
|
||||||
|
|
||||||
|
29
srtp-1.4.4_20140620git-soname.patch
Normal file
29
srtp-1.4.4_20140620git-soname.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
diff -Nru libsrtp-1.4.4_20140620git.orig/Makefile.in libsrtp-1.4.4_20140620git/Makefile.in
|
||||||
|
--- libsrtp-1.4.4_20140620git.orig/Makefile.in 2014-06-20 13:39:30.000000000 +0200
|
||||||
|
+++ libsrtp-1.4.4_20140620git/Makefile.in 2014-06-20 13:47:09.941763395 +0200
|
||||||
|
@@ -116,8 +116,8 @@
|
||||||
|
$(RANLIB) libsrtp.a
|
||||||
|
|
||||||
|
libsrtp.so: $(srtpobj) $(cryptobj) $(gdoi)
|
||||||
|
- $(CC) -shared -Wl,-soname,libsrtp.so $(LDFLAGS) \
|
||||||
|
- -o libsrtp.so $^
|
||||||
|
+ $(CC) -shared -Wl,-soname,$@.0 $(LDFLAGS) \
|
||||||
|
+ -o $@.0.0.0 $^
|
||||||
|
|
||||||
|
# libcryptomath.a contains general-purpose routines that are used to
|
||||||
|
# generate tables and verify cryptoalgorithm implementations - this
|
||||||
|
@@ -215,12 +215,12 @@
|
||||||
|
cp $(srcdir)/crypto/include/*.h $(DESTDIR)$(includedir)/srtp
|
||||||
|
if [ "$(srcdir)" != "." ]; then cp crypto/include/*.h $(DESTDIR)$(includedir)/srtp; fi
|
||||||
|
if [ -f libsrtp.a ]; then cp libsrtp.a $(DESTDIR)$(libdir)/; fi
|
||||||
|
- if [ -f libsrtp.so ]; then cp libsrtp.so $(DESTDIR)$(libdir)/; fi
|
||||||
|
+ if [ -f libsrtp.so.0.0.0 ]; then cp libsrtp.so.0.0.0 $(DESTDIR)$(libdir)/; fi
|
||||||
|
|
||||||
|
uninstall:
|
||||||
|
rm -f $(DESTDIR)$(includedir)/srtp/*.h
|
||||||
|
rm -f $(DESTDIR)$(libdir)/libsrtp.a
|
||||||
|
- rm -f $(DESTDIR)$(libdir)/libsrtp.so
|
||||||
|
+ rm -f $(DESTDIR)$(libdir)/libsrtp.so.0.0.0
|
||||||
|
-rmdir $(DESTDIR)$(includedir)/srtp
|
||||||
|
|
||||||
|
clean:
|
87
srtp.spec
Normal file
87
srtp.spec
Normal file
@ -0,0 +1,87 @@
|
|||||||
|
Name: srtp
|
||||||
|
Version: 1.4.4_20140620git
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: An implementation of the Secure Real-time Transport Protocol (SRTP)
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://srtp.sourceforge.net/srtp.html
|
||||||
|
#Source: http://downloads.sourceforge.net/project/srtp/srtp/%{version}/srtp-%{version}.tar.gz
|
||||||
|
Source: https://github.com/cisco/libsrtp.git/master/libsrtp-%{version}.tar.bz2
|
||||||
|
Patch0: srtp-1.4.4_20140620git-soname.patch
|
||||||
|
License: BSD
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
This package provides an implementation of the Secure Real-time Transport Protocol (SRTP), the Universal Security Transform (UST), and a supporting cryptographic kernel. These mechanisms are documented in the Internet Drafts in the doc/ subdirectory. The SRTP API is documented in include/srtp.h, and the library is in libsrtp.a (after compilation).
|
||||||
|
|
||||||
|
%package -n lib%{name}
|
||||||
|
Group: System/Libraries
|
||||||
|
Summary: An implementation of the Secure Real-time Transport Protocol (SRTP)
|
||||||
|
|
||||||
|
%description -n lib%{name}
|
||||||
|
This package provides an implementation of the Secure Real-time Transport Protocol (SRTP), the Universal Security Transform (UST), and a supporting cryptographic kernel. These mechanisms are documented in the Internet Drafts in the doc/ subdirectory. The SRTP API is documented in include/srtp.h, and the library is in libsrtp.a (after compilation).
|
||||||
|
This package contains shared library for %{name}.
|
||||||
|
|
||||||
|
%package -n lib%{name}-devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: An implementation of the Secure Real-time Transport Protocol (SRTP)
|
||||||
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n lib%{name}-devel
|
||||||
|
This package contains libraries and header files for developing applications that use %{name}.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n libsrtp-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure
|
||||||
|
|
||||||
|
%make all libsrtp.so
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
ln -s libsrtp.so.0.0.0 %{buildroot}%{_libdir}/libsrtp.so.0
|
||||||
|
ln -s libsrtp.so.0.0.0 %{buildroot}%{_libdir}/libsrtp.so
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -n lib%{name} -p /sbin/ldconfig
|
||||||
|
%postun -n lib%{name} -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files -n lib%{name}
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libsrtp.so.*
|
||||||
|
%doc LICENSE
|
||||||
|
|
||||||
|
%files -n lib%{name}-devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/srtp
|
||||||
|
%{_includedir}/srtp/*.h
|
||||||
|
%{_libdir}/libsrtp.a
|
||||||
|
%{_libdir}/libsrtp.so
|
||||||
|
%doc CHANGES README TODO
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Jun 20 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.4_20140620git-1mamba
|
||||||
|
- update to 1.4.4_20140620git
|
||||||
|
|
||||||
|
* Fri Jun 20 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.4_20140620cvs-1mamba
|
||||||
|
- update to 1.4.4_20140620cvs
|
||||||
|
|
||||||
|
* Fri Jun 20 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.4-1mamba
|
||||||
|
- update to 1.4.4
|
||||||
|
|
||||||
|
* Fri Jun 20 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.2-1mamba
|
||||||
|
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user