rebuilt with xz support [release 4.2-2mamba;Sat May 21 2011]
This commit is contained in:
parent
702e4e7ca2
commit
d354d404dc
@ -1,2 +1,4 @@
|
|||||||
# squashfs
|
# squashfs
|
||||||
|
|
||||||
|
Squashfs is a compressed read-only filesystem for Linux. Squashfs is intended for general read-only filesystem use, for archival use (i.e. in cases where a .tar.gz file may be used), and in constrained block device/memory systems (e.g. embedded systems) where low overhead is needed. The filesystem is currently stable, and has been tested on PowerPC, i586, Sparc and ARM architectures.
|
||||||
|
|
||||||
|
2210
squashfs-4.0-lzma.patch
Normal file
2210
squashfs-4.0-lzma.patch
Normal file
File diff suppressed because it is too large
Load Diff
22
squashfs-4.2-Makefile_config.patch
Normal file
22
squashfs-4.2-Makefile_config.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- squashfs4.2.orig/squashfs-tools/Makefile 2011-02-28 21:04:15.000000000 +0100
|
||||||
|
+++ squashfs4.2/build/squashfs-tools/Makefile 2011-03-02 14:21:00.776818880 +0100
|
||||||
|
@@ -37,7 +37,7 @@
|
||||||
|
# LZO_SUPPORT line below. If needed, uncomment and set LZO_DIR to the
|
||||||
|
# installation prefix.
|
||||||
|
#
|
||||||
|
-#LZO_SUPPORT = 1
|
||||||
|
+LZO_SUPPORT = 1
|
||||||
|
#LZO_DIR = /usr/local
|
||||||
|
|
||||||
|
########### Building LZMA support #############
|
||||||
|
@@ -58,8 +58,8 @@
|
||||||
|
# and uncomment the LZMA_SUPPORT line below.
|
||||||
|
#
|
||||||
|
#LZMA_XZ_SUPPORT = 1
|
||||||
|
-#LZMA_SUPPORT = 1
|
||||||
|
-#LZMA_DIR = ../../../../LZMA/lzma465
|
||||||
|
+LZMA_SUPPORT = 1
|
||||||
|
+LZMA_DIR = ../..
|
||||||
|
|
||||||
|
######## Specifying default compression ########
|
||||||
|
#
|
12
squashfs-4.2-Makefile_xz.patch
Normal file
12
squashfs-4.2-Makefile_xz.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Nru squashfs4.2.orig//squashfs-tools/Makefile squashfs4.2/squashfs-tools/Makefile
|
||||||
|
--- squashfs4.2.orig//squashfs-tools/Makefile 2011-05-21 16:12:54.535364586 +0200
|
||||||
|
+++ squashfs4.2/squashfs-tools/Makefile 2011-05-21 16:13:24.419027728 +0200
|
||||||
|
@@ -26,7 +26,7 @@
|
||||||
|
# To build using XZ Utils liblzma - install the library and uncomment
|
||||||
|
# the XZ_SUPPORT line below.
|
||||||
|
#
|
||||||
|
-#XZ_SUPPORT = 1
|
||||||
|
+XZ_SUPPORT = 1
|
||||||
|
|
||||||
|
|
||||||
|
############ Building LZO support ##############
|
75
squashfs.spec
Normal file
75
squashfs.spec
Normal file
@ -0,0 +1,75 @@
|
|||||||
|
Name: squashfs
|
||||||
|
Version: 4.2
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: Tools for squashsh, a compressed read-only filesystem for Linux
|
||||||
|
Group: System/Tools
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://squashfs.sourceforge.net/
|
||||||
|
Source: http://heanet.dl.sourceforge.net/sourceforge/squashfs/squashfs%{version}.tar.gz
|
||||||
|
Source1: http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2
|
||||||
|
Patch0: %{name}-4.0-lzma.patch
|
||||||
|
Patch1: %{name}-4.2-Makefile_config.patch
|
||||||
|
Patch2: %{name}-4.2-Makefile_xz.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Squashfs is a compressed read-only filesystem for Linux. Squashfs is intended for general read-only filesystem use, for archival use (i.e. in cases where a .tar.gz file may be used), and in constrained block device/memory systems (e.g. embedded systems) where low overhead is needed. The filesystem is currently stable, and has been tested on PowerPC, i586, Sparc and ARM architectures.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{name}%{version} -a1
|
||||||
|
#%patch0 -p0
|
||||||
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
mkdir build
|
||||||
|
mv squashfs-tools build
|
||||||
|
cd build/squashfs-tools
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
cd build/squashfs-tools
|
||||||
|
install -D -m 0755 mksquashfs %{buildroot}%{_bindir}/mksquashfs
|
||||||
|
install -D -m 0755 unsquashfs %{buildroot}%{_bindir}/unsquashfs
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/mksquashfs
|
||||||
|
%{_bindir}/unsquashfs
|
||||||
|
%doc CHANGES COPYING README
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat May 21 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2-2mamba
|
||||||
|
- rebuilt with xz support
|
||||||
|
|
||||||
|
* Wed Mar 02 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2-1mamba
|
||||||
|
- update to 4.2
|
||||||
|
|
||||||
|
* Mon Feb 08 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0-2mamba
|
||||||
|
- added patch for lzma support and rebuilt using lzma sdk
|
||||||
|
|
||||||
|
* Tue Apr 07 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0-1mamba
|
||||||
|
- update to 4.0
|
||||||
|
|
||||||
|
* Sun Sep 14 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4-1mamba
|
||||||
|
- update to 3.4
|
||||||
|
|
||||||
|
* Fri Jul 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.3-2mamba
|
||||||
|
- applied patch to fix hang problem while creating livegames dvd
|
||||||
|
|
||||||
|
* Tue Jan 15 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.3-1mamba
|
||||||
|
- update to 3.3
|
||||||
|
|
||||||
|
* Fri Jun 30 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0-1qilnx
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user