update to 18.0.0.20240215git.ffdb454 [release 18.0.0.20240215git.ffdb454-1mamba;Sun Mar 17 2024]

This commit is contained in:
Silvan Calarco 2024-03-19 19:54:51 +01:00
parent 388953a147
commit efbdaf58d1
2 changed files with 7 additions and 77 deletions

View File

@ -1,73 +0,0 @@
From 98fadafeae0204defedd89f015f7fb88f2888b2f Mon Sep 17 00:00:00 2001
From: Tulio Magno Quites Machado Filho <tuliom@redhat.com>
Date: Fri, 17 Mar 2023 14:27:10 -0300
Subject: [PATCH] Fix standalone builds with LLVM_LINK_LLVM_DYLIB=ON
Move the LLVM components to LINK_COMPONENTS because the DEPENDS list has
the same semantics as add_dependencies(). In this
case it doesn't include the LLVM components when calling the linker.
---
lib/SPIRV/CMakeLists.txt | 47 ++++++++++++----------------------------
1 file changed, 14 insertions(+), 33 deletions(-)
diff --git a/lib/SPIRV/CMakeLists.txt b/lib/SPIRV/CMakeLists.txt
index bbef00528..2810c6b2c 100644
--- a/lib/SPIRV/CMakeLists.txt
+++ b/lib/SPIRV/CMakeLists.txt
@@ -38,42 +38,23 @@ set(SRC_LIST
libSPIRV/SPIRVType.cpp
libSPIRV/SPIRVValue.cpp
)
-if(LLVM_LINK_LLVM_DYLIB)
- add_llvm_library(LLVMSPIRVLib STATIC DISABLE_LLVM_LINK_LLVM_DYLIB
- ${SRC_LIST}
- DEPENDS
- intrinsics_gen
- LLVMAnalysis
- LLVMBitWriter
- LLVMCodeGen
- LLVMCore
- LLVMDemangle
- LLVMIRReader
- LLVMLinker
- LLVMPasses
- LLVMSupport
- LLVMTargetParser
- LLVMTransformUtils
- )
-else()
- add_llvm_library(LLVMSPIRVLib
- ${SRC_LIST}
- LINK_COMPONENTS
- Analysis
- BitWriter
- CodeGen
- Core
- Demangle
- IRReader
- Linker
- Passes
- Support
- TargetParser
- TransformUtils
+add_llvm_library(LLVMSPIRVLib
+ ${SRC_LIST}
+ LINK_COMPONENTS
+ Analysis
+ BitWriter
+ CodeGen
+ Core
+ Demangle
+ IRReader
+ Linker
+ Passes
+ Support
+ TargetParser
+ TransformUtils
DEPENDS
intrinsics_gen
)
-endif()
target_include_directories(LLVMSPIRVLib
PRIVATE

View File

@ -1,5 +1,6 @@
%define gitver %(echo %version | cut -d. -f5)
Name: spirv-llvm-translator Name: spirv-llvm-translator
Version: 17.0.0 Version: 18.0.0.20240215git.ffdb454
Release: 1mamba Release: 1mamba
Summary: A tool and a library for bi-directional translation between SPIR-V and LLVM IR Summary: A tool and a library for bi-directional translation between SPIR-V and LLVM IR
Group: Development/Tools Group: Development/Tools
@ -7,8 +8,8 @@ Vendor: openmamba
Distribution: openmamba Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it> Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://github.com/KhronosGroup/SPIRV-LLVM-Translator URL: https://github.com/KhronosGroup/SPIRV-LLVM-Translator
Source: https://github.com/KhronosGroup/SPIRV-LLVM-Translator.git/v%{version}/SPIRV-LLVM-Translator-%{version}.tar.bz2 Source: https://github.com/KhronosGroup/SPIRV-LLVM-Translator.git/main@%{gitver}/SPIRV-LLVM-Translator-%{version}.tar.bz2
Patch0: spirv-llvm-translator-16.0.0-llvm-16.patch #Source: https://github.com/KhronosGroup/SPIRV-LLVM-Translator.git/v%{version}/SPIRV-LLVM-Translator-%{version}.tar.bz2
License: NCSA License: NCSA
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
@ -45,7 +46,6 @@ This package contains libraries and header files for developing applications tha
%prep %prep
%setup -q -n SPIRV-LLVM-Translator-%{version} %setup -q -n SPIRV-LLVM-Translator-%{version}
#%patch 0 -p1
%build %build
%cmake -d build \ %cmake -d build \
@ -78,6 +78,9 @@ This package contains libraries and header files for developing applications tha
%doc README.md %doc README.md
%changelog %changelog
* Sun Mar 17 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 18.0.0.20240215git.ffdb454-1mamba
- update to 18.0.0.20240215git.ffdb454
* Tue Oct 24 2023 Automatic Build System <autodist@mambasoft.it> 17.0.0-1mamba * Tue Oct 24 2023 Automatic Build System <autodist@mambasoft.it> 17.0.0-1mamba
- automatic version update by autodist - automatic version update by autodist