update to 16.0.0 [release 16.0.0-1mamba;Wed May 24 2023]
This commit is contained in:
parent
32e35c932f
commit
b32fad5231
73
spirv-llvm-translator-16.0.0-llvm-16.patch
Normal file
73
spirv-llvm-translator-16.0.0-llvm-16.patch
Normal file
@ -0,0 +1,73 @@
|
||||
From 98fadafeae0204defedd89f015f7fb88f2888b2f Mon Sep 17 00:00:00 2001
|
||||
From: Tulio Magno Quites Machado Filho <tuliom@redhat.com>
|
||||
Date: Fri, 17 Mar 2023 14:27:10 -0300
|
||||
Subject: [PATCH] Fix standalone builds with LLVM_LINK_LLVM_DYLIB=ON
|
||||
|
||||
Move the LLVM components to LINK_COMPONENTS because the DEPENDS list has
|
||||
the same semantics as add_dependencies(). In this
|
||||
case it doesn't include the LLVM components when calling the linker.
|
||||
---
|
||||
lib/SPIRV/CMakeLists.txt | 47 ++++++++++++----------------------------
|
||||
1 file changed, 14 insertions(+), 33 deletions(-)
|
||||
|
||||
diff --git a/lib/SPIRV/CMakeLists.txt b/lib/SPIRV/CMakeLists.txt
|
||||
index bbef00528..2810c6b2c 100644
|
||||
--- a/lib/SPIRV/CMakeLists.txt
|
||||
+++ b/lib/SPIRV/CMakeLists.txt
|
||||
@@ -38,42 +38,23 @@ set(SRC_LIST
|
||||
libSPIRV/SPIRVType.cpp
|
||||
libSPIRV/SPIRVValue.cpp
|
||||
)
|
||||
-if(LLVM_LINK_LLVM_DYLIB)
|
||||
- add_llvm_library(LLVMSPIRVLib STATIC DISABLE_LLVM_LINK_LLVM_DYLIB
|
||||
- ${SRC_LIST}
|
||||
- DEPENDS
|
||||
- intrinsics_gen
|
||||
- LLVMAnalysis
|
||||
- LLVMBitWriter
|
||||
- LLVMCodeGen
|
||||
- LLVMCore
|
||||
- LLVMDemangle
|
||||
- LLVMIRReader
|
||||
- LLVMLinker
|
||||
- LLVMPasses
|
||||
- LLVMSupport
|
||||
- LLVMTargetParser
|
||||
- LLVMTransformUtils
|
||||
- )
|
||||
-else()
|
||||
- add_llvm_library(LLVMSPIRVLib
|
||||
- ${SRC_LIST}
|
||||
- LINK_COMPONENTS
|
||||
- Analysis
|
||||
- BitWriter
|
||||
- CodeGen
|
||||
- Core
|
||||
- Demangle
|
||||
- IRReader
|
||||
- Linker
|
||||
- Passes
|
||||
- Support
|
||||
- TargetParser
|
||||
- TransformUtils
|
||||
+add_llvm_library(LLVMSPIRVLib
|
||||
+ ${SRC_LIST}
|
||||
+ LINK_COMPONENTS
|
||||
+ Analysis
|
||||
+ BitWriter
|
||||
+ CodeGen
|
||||
+ Core
|
||||
+ Demangle
|
||||
+ IRReader
|
||||
+ Linker
|
||||
+ Passes
|
||||
+ Support
|
||||
+ TargetParser
|
||||
+ TransformUtils
|
||||
DEPENDS
|
||||
intrinsics_gen
|
||||
)
|
||||
-endif()
|
||||
|
||||
target_include_directories(LLVMSPIRVLib
|
||||
PRIVATE
|
@ -1,5 +1,5 @@
|
||||
Name: spirv-llvm-translator
|
||||
Version: 15.0.0
|
||||
Version: 16.0.0
|
||||
Release: 1mamba
|
||||
Summary: A tool and a library for bi-directional translation between SPIR-V and LLVM IR
|
||||
Group: Development/Tools
|
||||
@ -8,6 +8,7 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://github.com/KhronosGroup/SPIRV-LLVM-Translator
|
||||
Source: https://github.com/KhronosGroup/SPIRV-LLVM-Translator.git/v%{version}/SPIRV-LLVM-Translator-%{version}.tar.bz2
|
||||
Patch0: spirv-llvm-translator-16.0.0-llvm-16.patch
|
||||
License: NCSA
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -44,10 +45,10 @@ This package contains libraries and header files for developing applications tha
|
||||
|
||||
%prep
|
||||
%setup -q -n SPIRV-LLVM-Translator-%{version}
|
||||
%patch 0 -p1
|
||||
|
||||
%build
|
||||
%cmake -d build \
|
||||
-DLLVM_EXTERNAL_LIT=/usr/bin/lit \
|
||||
-DLLVM_EXTERNAL_SPIRV_HEADERS_SOURCE_DIR=%{_includedir}/spirv/
|
||||
|
||||
%make
|
||||
@ -78,5 +79,8 @@ This package contains libraries and header files for developing applications tha
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed May 24 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 16.0.0-1mamba
|
||||
- update to 16.0.0
|
||||
|
||||
* Tue Dec 27 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 15.0.0-1mamba
|
||||
- package created using the webbuild interface
|
||||
|
Loading…
Reference in New Issue
Block a user