rebuilt with libfmt 1.11.1 [release 1.15.0-2mamba;Sun Dec 29 2024]
This commit is contained in:
parent
010d057e5a
commit
2b76e91a37
32
spdlog-1.15.0-libfmt-11.1.1-2.patch
Normal file
32
spdlog-1.15.0-libfmt-11.1.1-2.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
From 276ee5f5c0eb13626bd367b006ace5eae9526d8a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Rui Chen <rui@chenrui.dev>
|
||||||
|
Date: Thu, 26 Dec 2024 02:13:57 -0500
|
||||||
|
Subject: [PATCH] fix: update to_string_view function for fmt 11.1 (#3301)
|
||||||
|
|
||||||
|
Signed-off-by: Rui Chen <rui@chenrui.dev>
|
||||||
|
---
|
||||||
|
include/spdlog/common.h | 7 +++++++
|
||||||
|
1 file changed, 7 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/include/spdlog/common.h b/include/spdlog/common.h
|
||||||
|
index aca483c20..2d73f8300 100644
|
||||||
|
--- a/include/spdlog/common.h
|
||||||
|
+++ b/include/spdlog/common.h
|
||||||
|
@@ -365,10 +365,17 @@ SPDLOG_CONSTEXPR_FUNC spdlog::wstring_view_t to_string_view(spdlog::wstring_view
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifndef SPDLOG_USE_STD_FORMAT
|
||||||
|
+#if FMT_VERSION >= 110100
|
||||||
|
+template <typename T, typename... Args>
|
||||||
|
+inline fmt::basic_string_view<T> to_string_view(fmt::basic_format_arg<T> fmt) {
|
||||||
|
+ return fmt;
|
||||||
|
+}
|
||||||
|
+#else
|
||||||
|
template <typename T, typename... Args>
|
||||||
|
inline fmt::basic_string_view<T> to_string_view(fmt::basic_format_string<T, Args...> fmt) {
|
||||||
|
return fmt;
|
||||||
|
}
|
||||||
|
+#endif
|
||||||
|
#elif __cpp_lib_format >= 202207L
|
||||||
|
template <typename T, typename... Args>
|
||||||
|
SPDLOG_CONSTEXPR_FUNC std::basic_string_view<T> to_string_view(
|
11
spdlog-1.15.0-libfmt-11.1.1.patch
Normal file
11
spdlog-1.15.0-libfmt-11.1.1.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- a/include/spdlog/tweakme.h 2023-01-02 09:57:15.667781832 -0800
|
||||||
|
+++ b/include/spdlog/tweakme.h 2023-01-02 09:57:17.761105926 -0800
|
||||||
|
@@ -78,7 +78,7 @@
|
||||||
|
// In this case spdlog will try to include <fmt/format.h> so set your -I flag
|
||||||
|
// accordingly.
|
||||||
|
//
|
||||||
|
-// #define SPDLOG_FMT_EXTERNAL
|
||||||
|
+#define SPDLOG_FMT_EXTERNAL
|
||||||
|
///////////////////////////////////////////////////////////////////////////////
|
||||||
|
|
||||||
|
///////////////////////////////////////////////////////////////////////////////
|
13
spdlog.spec
13
spdlog.spec
@ -1,6 +1,6 @@
|
|||||||
Name: spdlog
|
Name: spdlog
|
||||||
Version: 1.15.0
|
Version: 1.15.0
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: Fast C++ logging library
|
Summary: Fast C++ logging library
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -8,6 +8,8 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://github.com/gabime/spdlog
|
URL: https://github.com/gabime/spdlog
|
||||||
Source: https://github.com/gabime/spdlog.git/v%{version}/spdlog-%{version}.tar.bz2
|
Source: https://github.com/gabime/spdlog.git/v%{version}/spdlog-%{version}.tar.bz2
|
||||||
|
Patch0: spdlog-1.15.0-libfmt-11.1.1.patch
|
||||||
|
Patch1: spdlog-1.15.0-libfmt-11.1.1-2.patch
|
||||||
License: MIT
|
License: MIT
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -16,7 +18,7 @@ BuildRequires: libgcc
|
|||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: libfmt-devel >= 11.0.2
|
BuildRequires: libfmt-devel >= 11.1.1
|
||||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -40,10 +42,10 @@ Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
Fast C++ logging library.
|
Fast C++ logging library.
|
||||||
This package contains libraries and header files for developing applications that use %{name}.
|
This package contains libraries and header files for developing applications that use %{name}.
|
||||||
|
|
||||||
%debug_package
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch 0 -p1 -b .libfmt-11.1.1
|
||||||
|
%patch 1 -p1 -b .libfmt-11.1.1-2
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -d build \
|
%cmake -d build \
|
||||||
@ -74,6 +76,9 @@ This package contains libraries and header files for developing applications tha
|
|||||||
%doc README.md
|
%doc README.md
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Dec 29 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.15.0-2mamba
|
||||||
|
- rebuilt with libfmt 1.11.1
|
||||||
|
|
||||||
* Sun Nov 10 2024 Automatic Build System <autodist@openmamba.org> 1.15.0-1mamba
|
* Sun Nov 10 2024 Automatic Build System <autodist@openmamba.org> 1.15.0-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user