automatic version update by autodist [release 2.2.0-1mamba;Sat Sep 16 2023]
This commit is contained in:
parent
e0d35dc588
commit
c36cf1c3d5
@ -1,39 +0,0 @@
|
||||
diff --git c/GNUmakefile i/GNUmakefile
|
||||
index 1693f5a..b33a42e 100644
|
||||
--- c/GNUmakefile
|
||||
+++ i/GNUmakefile
|
||||
@@ -112,10 +112,10 @@ C_OTHER_OBJECTS = $(C_OTHER_SOURCES:.c=.o)
|
||||
JAVA_CLASSES = $(JAVA_SOURCES:.java=.class)
|
||||
JAVA_RUNTIME_CLASSES=$(JAVARUNTIME_SOURCES:.java=.class)
|
||||
|
||||
-CFLAGS=-O2 -W -Wall -Wmissing-prototypes -Wmissing-declarations
|
||||
+CFLAGS=-O2 -fPIC -W -Wall -Wmissing-prototypes -Wmissing-declarations
|
||||
CPPFLAGS=-Iinclude
|
||||
|
||||
-all: snowball libstemmer.o stemwords $(C_OTHER_SOURCES) $(C_OTHER_HEADERS) $(C_OTHER_OBJECTS)
|
||||
+all: snowball libstemmer.o libstemmer.so stemwords $(C_OTHER_SOURCES) $(C_OTHER_HEADERS) $(C_OTHER_OBJECTS)
|
||||
|
||||
clean:
|
||||
rm -f $(COMPILER_OBJECTS) $(RUNTIME_OBJECTS) \
|
||||
@@ -158,6 +158,9 @@ libstemmer/libstemmer.o: libstemmer/modules.h $(C_LIB_HEADERS)
|
||||
libstemmer.o: libstemmer/libstemmer.o $(RUNTIME_OBJECTS) $(C_LIB_OBJECTS)
|
||||
$(AR) -cru $@ $^
|
||||
|
||||
+libstemmer.so: libstemmer/libstemmer.o $(RUNTIME_OBJECTS) $(C_LIB_OBJECTS)
|
||||
+ $(CC) $(CFLAGS) -shared $(LDFLAGS) -Wl,-soname,libstemmer.so.0,-version-script,libstemmer/symbol.map -o $@.0.0.0 $^
|
||||
+
|
||||
stemwords: $(STEMWORDS_OBJECTS) libstemmer.o
|
||||
$(CC) -o $@ $^
|
||||
|
||||
diff --git c/libstemmer/symbol.map i/libstemmer/symbol.map
|
||||
new file mode 100644
|
||||
index 0000000..7a3d423
|
||||
--- /dev/null
|
||||
+++ i/libstemmer/symbol.map
|
||||
@@ -0,0 +1,6 @@
|
||||
+SB_STEMMER_0 {
|
||||
+ global:
|
||||
+ sb_stemmer_*;
|
||||
+ local:
|
||||
+ *;
|
||||
+};
|
68
snowball-2.2.0-dynamiclib.patch
Normal file
68
snowball-2.2.0-dynamiclib.patch
Normal file
@ -0,0 +1,68 @@
|
||||
GNUmakefile | 15 +++++++--------
|
||||
libstemmer/symbol.map | 6 ++++++
|
||||
2 files changed, 13 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git c/GNUmakefile i/GNUmakefile
|
||||
index 98eb1fa..86e4855 100644
|
||||
--- c/GNUmakefile
|
||||
+++ i/GNUmakefile
|
||||
@@ -170,20 +170,19 @@ C_OTHER_OBJECTS = $(C_OTHER_SOURCES:.c=.o)
|
||||
JAVA_CLASSES = $(JAVA_SOURCES:.java=.class)
|
||||
JAVA_RUNTIME_CLASSES=$(JAVARUNTIME_SOURCES:.java=.class)
|
||||
|
||||
-CFLAGS=-O2 -W -Wall -Wmissing-prototypes -Wmissing-declarations
|
||||
-CPPFLAGS=
|
||||
+CFLAGS+=-fPIC -W -Wall -Wmissing-prototypes -Wmissing-declarations
|
||||
|
||||
INCLUDES=-Iinclude
|
||||
|
||||
-all: snowball$(EXEEXT) libstemmer.a stemwords$(EXEEXT) $(C_OTHER_SOURCES) $(C_OTHER_HEADERS) $(C_OTHER_OBJECTS)
|
||||
+all: snowball$(EXEEXT) libstemmer.so.0 stemwords$(EXEEXT) $(C_OTHER_SOURCES) $(C_OTHER_HEADERS) $(C_OTHER_OBJECTS)
|
||||
|
||||
algorithms.mk: libstemmer/mkalgorithms.pl libstemmer/modules.txt
|
||||
libstemmer/mkalgorithms.pl algorithms.mk libstemmer/modules.txt
|
||||
|
||||
clean:
|
||||
rm -f $(COMPILER_OBJECTS) $(RUNTIME_OBJECTS) \
|
||||
$(LIBSTEMMER_OBJECTS) $(LIBSTEMMER_UTF8_OBJECTS) $(STEMWORDS_OBJECTS) snowball$(EXEEXT) \
|
||||
- libstemmer.a stemwords$(EXEEXT) \
|
||||
+ libstemmer.so.0 stemwords$(EXEEXT) \
|
||||
libstemmer/modules.h \
|
||||
libstemmer/modules_utf8.h \
|
||||
$(C_LIB_SOURCES) $(C_LIB_HEADERS) $(C_LIB_OBJECTS) \
|
||||
@@ -222,19 +221,19 @@ libstemmer/modules_utf8.h libstemmer/mkinc_utf8.mak: libstemmer/mkmodules.pl lib
|
||||
|
||||
libstemmer/libstemmer.o: libstemmer/modules.h $(C_LIB_HEADERS)
|
||||
|
||||
-libstemmer.a: libstemmer/libstemmer.o $(RUNTIME_OBJECTS) $(C_LIB_OBJECTS)
|
||||
- $(AR) -cru $@ $^
|
||||
+libstemmer.so.0: libstemmer/libstemmer.o $(RUNTIME_OBJECTS) $(C_LIB_OBJECTS)
|
||||
+ $(CC) $(CFLAGS) -shared $(LDFLAGS) -Wl,-soname,$@,-version-script,libstemmer/symbol.map -o $@ $^
|
||||
|
||||
examples/%.o: examples/%.c
|
||||
$(CC) $(CFLAGS) $(INCLUDES) $(CPPFLAGS) -c -o $@ $<
|
||||
|
||||
-stemwords$(EXEEXT): $(STEMWORDS_OBJECTS) libstemmer.a
|
||||
+stemwords$(EXEEXT): $(STEMWORDS_OBJECTS) libstemmer.so.0
|
||||
$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
|
||||
|
||||
tests/%.o: tests/%.c
|
||||
$(CC) $(CFLAGS) $(INCLUDES) $(CPPFLAGS) -c -o $@ $<
|
||||
|
||||
-stemtest$(EXEEXT): $(STEMTEST_OBJECTS) libstemmer.a
|
||||
+stemtest$(EXEEXT): $(STEMTEST_OBJECTS) libstemmer.so.0
|
||||
$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
|
||||
|
||||
csharp_stemwords$(EXEEXT): $(CSHARP_STEMWORDS_SOURCES) $(CSHARP_RUNTIME_SOURCES) $(CSHARP_SOURCES)
|
||||
diff --git c/libstemmer/symbol.map i/libstemmer/symbol.map
|
||||
new file mode 100644
|
||||
index 0000000..7a3d423
|
||||
--- /dev/null
|
||||
+++ i/libstemmer/symbol.map
|
||||
@@ -0,0 +1,6 @@
|
||||
+SB_STEMMER_0 {
|
||||
+ global:
|
||||
+ sb_stemmer_*;
|
||||
+ local:
|
||||
+ *;
|
||||
+};
|
@ -1,5 +1,5 @@
|
||||
Name: snowball
|
||||
Version: 2.1.0
|
||||
Version: 2.2.0
|
||||
Release: 1mamba
|
||||
Summary: Snowball compiler and stemming algorithms
|
||||
Group: System/Libraries
|
||||
@ -8,7 +8,7 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://snowballstem.org/
|
||||
Source: https://github.com/snowballstem/snowball.git/master/snowball-%{version}.tar.bz2
|
||||
Patch0: snowball-0.20170814git-dynlibrary.patch
|
||||
Patch0: snowball-2.2.0-dynamiclib.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -38,7 +38,7 @@ This package contains libraries and header files for developing applications tha
|
||||
%prep
|
||||
%setup -q
|
||||
%define _default_patch_fuzz 2
|
||||
%patch0 -p1
|
||||
%patch 0 -p1 -b .dynamiclib
|
||||
|
||||
%build
|
||||
%make
|
||||
@ -51,8 +51,7 @@ for f in snowball stemwords; do
|
||||
done
|
||||
|
||||
install -D -m0644 include/libstemmer.h %{buildroot}%{_includedir}/libstemmer.h
|
||||
install -D -m0755 libstemmer.so.0.0.0 %{buildroot}%{_libdir}/libstemmer.so.0.0.0
|
||||
ln -s libstemmer.so.0.0.0 %{buildroot}%{_libdir}/libstemmer.so.0
|
||||
install -D -m0755 libstemmer.so.0 %{buildroot}%{_libdir}/libstemmer.so.0
|
||||
ln -s libstemmer.so.0 %{buildroot}%{_libdir}/libstemmer.so
|
||||
|
||||
%clean
|
||||
@ -78,6 +77,9 @@ ln -s libstemmer.so.0 %{buildroot}%{_libdir}/libstemmer.so
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Sep 16 2023 Automatic Build System <autodist@mambasoft.it> 2.2.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Apr 13 2021 Automatic Build System <autodist@mambasoft.it> 2.1.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user