package created using the webbuild interface [release 0.20170814git-1mamba;Mon Aug 14 2017]
This commit is contained in:
parent
ed402be730
commit
70c5dfe6f1
39
snowball-0.20170814git-dynlibrary.patch
Normal file
39
snowball-0.20170814git-dynlibrary.patch
Normal file
@ -0,0 +1,39 @@
|
||||
diff --git c/GNUmakefile i/GNUmakefile
|
||||
index 1693f5a..b33a42e 100644
|
||||
--- c/GNUmakefile
|
||||
+++ i/GNUmakefile
|
||||
@@ -112,10 +112,10 @@ C_OTHER_OBJECTS = $(C_OTHER_SOURCES:.c=.o)
|
||||
JAVA_CLASSES = $(JAVA_SOURCES:.java=.class)
|
||||
JAVA_RUNTIME_CLASSES=$(JAVARUNTIME_SOURCES:.java=.class)
|
||||
|
||||
-CFLAGS=-O2 -W -Wall -Wmissing-prototypes -Wmissing-declarations
|
||||
+CFLAGS=-O2 -fPIC -W -Wall -Wmissing-prototypes -Wmissing-declarations
|
||||
CPPFLAGS=-Iinclude
|
||||
|
||||
-all: snowball libstemmer.o stemwords $(C_OTHER_SOURCES) $(C_OTHER_HEADERS) $(C_OTHER_OBJECTS)
|
||||
+all: snowball libstemmer.o libstemmer.so stemwords $(C_OTHER_SOURCES) $(C_OTHER_HEADERS) $(C_OTHER_OBJECTS)
|
||||
|
||||
clean:
|
||||
rm -f $(COMPILER_OBJECTS) $(RUNTIME_OBJECTS) \
|
||||
@@ -158,6 +158,9 @@ libstemmer/libstemmer.o: libstemmer/modules.h $(C_LIB_HEADERS)
|
||||
libstemmer.o: libstemmer/libstemmer.o $(RUNTIME_OBJECTS) $(C_LIB_OBJECTS)
|
||||
$(AR) -cru $@ $^
|
||||
|
||||
+libstemmer.so: libstemmer/libstemmer.o $(RUNTIME_OBJECTS) $(C_LIB_OBJECTS)
|
||||
+ $(CC) $(CFLAGS) -shared $(LDFLAGS) -Wl,-soname,libstemmer.so.0,-version-script,libstemmer/symbol.map -o $@.0.0.0 $^
|
||||
+
|
||||
stemwords: $(STEMWORDS_OBJECTS) libstemmer.o
|
||||
$(CC) -o $@ $^
|
||||
|
||||
diff --git c/libstemmer/symbol.map i/libstemmer/symbol.map
|
||||
new file mode 100644
|
||||
index 0000000..7a3d423
|
||||
--- /dev/null
|
||||
+++ i/libstemmer/symbol.map
|
||||
@@ -0,0 +1,6 @@
|
||||
+SB_STEMMER_0 {
|
||||
+ global:
|
||||
+ sb_stemmer_*;
|
||||
+ local:
|
||||
+ *;
|
||||
+};
|
85
snowball.spec
Normal file
85
snowball.spec
Normal file
@ -0,0 +1,85 @@
|
||||
Name: snowball
|
||||
Version: 0.20170814git
|
||||
Release: 1mamba
|
||||
Summary: Snowball compiler and stemming algorithms
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://snowballstem.org/
|
||||
## GITSOURCE https://github.com/snowballstem/snowball.git master
|
||||
Source: https://github.com/snowballstem/snowball.git/master/snowball-%{version}.tar.bz2
|
||||
Patch0: snowball-0.20170814git-dynlibrary.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: libstemmer = %{?epoch:%epoch:}%{version}-%{release}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Snowball compiler and stemming algorithms.
|
||||
|
||||
%package -n libstemmer
|
||||
Group: System/Libraries
|
||||
Summary: Shared libraries for %{name}
|
||||
|
||||
%description -n libstemmer
|
||||
This package contains shared libraries for %{name}.
|
||||
|
||||
%package -n libstemmer-devel
|
||||
Group: Development/Libraries
|
||||
Summary: Development files for %{name}
|
||||
Requires: libstemmer = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libstemmer-devel
|
||||
This package contains libraries and header files for developing applications that use %{name}.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
for f in snowball stemwords; do
|
||||
install -D -m0755 $f %{buildroot}%{_bindir}/$f
|
||||
done
|
||||
|
||||
install -D -m0644 include/libstemmer.h %{buildroot}%{_includedir}/libstemmer.h
|
||||
install -D -m0644 libstemmer.so.0.0.0 %{buildroot}%{_libdir}/libstemmer.so.0.0.0
|
||||
ln -s libstemmer.so.0.0.0 %{buildroot}%{_libdir}/libstemmer.so.0
|
||||
ln -s libstemmer.so.0 %{buildroot}%{_libdir}/libstemmer.so
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n libstemmer -p /sbin/ldconfig
|
||||
%postun -n libstemmer -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/snowball
|
||||
%{_bindir}/stemwords
|
||||
|
||||
%files -n libstemmer
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libstemmer.so.*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files -n libstemmer-devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/libstemmer.h
|
||||
%{_libdir}/libstemmer.so
|
||||
%doc README
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 14 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 0.20170814git-1mamba
|
||||
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user