update to 1.2.1 [release 1.2.1-1mamba;Fri Jun 28 2024]
This commit is contained in:
parent
c6d9f2265d
commit
93d78f1e24
69
snappy-1.2.1-thirdparty.patch
Normal file
69
snappy-1.2.1-thirdparty.patch
Normal file
@ -0,0 +1,69 @@
|
|||||||
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -26,7 +26,7 @@
|
||||||
|
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
|
||||||
|
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
|
||||||
|
-cmake_minimum_required(VERSION 3.1)
|
||||||
|
+cmake_minimum_required(VERSION 3.5)
|
||||||
|
project(Snappy VERSION 1.2.1 LANGUAGES C CXX)
|
||||||
|
|
||||||
|
# C++ standard can be overridden when this is used as a sub-project.
|
||||||
|
@@ -319,34 +319,12 @@
|
||||||
|
if(SNAPPY_BUILD_TESTS)
|
||||||
|
enable_testing()
|
||||||
|
|
||||||
|
- # Prevent overriding the parent project's compiler/linker settings on Windows.
|
||||||
|
- set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
|
||||||
|
- set(install_gtest OFF)
|
||||||
|
- set(install_gmock OFF)
|
||||||
|
- set(build_gmock ON)
|
||||||
|
-
|
||||||
|
- # This project is tested using GoogleTest.
|
||||||
|
- add_subdirectory("third_party/googletest")
|
||||||
|
-
|
||||||
|
- # GoogleTest triggers a missing field initializers warning.
|
||||||
|
- if(SNAPPY_HAVE_NO_MISSING_FIELD_INITIALIZERS)
|
||||||
|
- set_property(TARGET gtest
|
||||||
|
- APPEND PROPERTY COMPILE_OPTIONS -Wno-missing-field-initializers)
|
||||||
|
- set_property(TARGET gmock
|
||||||
|
- APPEND PROPERTY COMPILE_OPTIONS -Wno-missing-field-initializers)
|
||||||
|
- endif(SNAPPY_HAVE_NO_MISSING_FIELD_INITIALIZERS)
|
||||||
|
-
|
||||||
|
- if(SNAPPY_HAVE_NO_IMPLICIT_INT_FLOAT_CONVERSION)
|
||||||
|
- set_property(TARGET gtest
|
||||||
|
- APPEND PROPERTY COMPILE_OPTIONS -Wno-implicit-int-float-conversion)
|
||||||
|
- endif(SNAPPY_HAVE_NO_IMPLICIT_INT_FLOAT_CONVERSION)
|
||||||
|
-
|
||||||
|
add_executable(snappy_unittest "")
|
||||||
|
target_sources(snappy_unittest
|
||||||
|
PRIVATE
|
||||||
|
"snappy_unittest.cc"
|
||||||
|
)
|
||||||
|
- target_link_libraries(snappy_unittest snappy_test_support gmock_main gtest)
|
||||||
|
+ target_link_libraries(snappy_unittest snappy_test_support gtest_main gtest)
|
||||||
|
|
||||||
|
add_test(
|
||||||
|
NAME snappy_unittest
|
||||||
|
@@ -361,20 +339,6 @@
|
||||||
|
target_link_libraries(snappy_test_tool snappy_test_support)
|
||||||
|
endif(SNAPPY_BUILD_TESTS)
|
||||||
|
|
||||||
|
-if(SNAPPY_BUILD_BENCHMARKS)
|
||||||
|
- add_executable(snappy_benchmark "")
|
||||||
|
- target_sources(snappy_benchmark
|
||||||
|
- PRIVATE
|
||||||
|
- "snappy_benchmark.cc"
|
||||||
|
- )
|
||||||
|
- target_link_libraries(snappy_benchmark snappy_test_support benchmark_main)
|
||||||
|
-
|
||||||
|
- # This project uses Google benchmark for benchmarking.
|
||||||
|
- set(BENCHMARK_ENABLE_TESTING OFF CACHE BOOL "" FORCE)
|
||||||
|
- set(BENCHMARK_ENABLE_EXCEPTIONS OFF CACHE BOOL "" FORCE)
|
||||||
|
- add_subdirectory("third_party/benchmark")
|
||||||
|
-endif(SNAPPY_BUILD_BENCHMARKS)
|
||||||
|
-
|
||||||
|
if(SNAPPY_FUZZING_BUILD)
|
||||||
|
add_executable(snappy_compress_fuzzer "")
|
||||||
|
target_sources(snappy_compress_fuzzer
|
18
snappy.spec
18
snappy.spec
@ -1,13 +1,14 @@
|
|||||||
Name: snappy
|
Name: snappy
|
||||||
Version: 1.1.7
|
Version: 1.2.1
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A fast compression/decompression library
|
Summary: A fast compression/decompression library
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://code.google.com/p/snappy
|
URL: https://google.github.io/snappy/
|
||||||
Source: https://github.com/google/snappy.git/%{version}/snappy-%{version}.tar.bz2
|
Source: https://github.com/google/snappy.git/%{version}/snappy-%{version}.tar.bz2
|
||||||
|
Patch0: snappy-1.2.1-thirdparty.patch
|
||||||
License: BSD
|
License: BSD
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -16,11 +17,6 @@ BuildRequires: libstdc++6-devel
|
|||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: liblzo-devel
|
BuildRequires: liblzo-devel
|
||||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
# checking for lzf_compress in -llzf... no
|
|
||||||
# checking for fastlz_compress in -lfastlz... no
|
|
||||||
# checking for qlz_compress in -lquicklz... no
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Snappy is a compression/decompression library.
|
Snappy is a compression/decompression library.
|
||||||
@ -48,10 +44,12 @@ This package contains libraries and header files for developing applications tha
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch 0 -p1 -b .thirdparty
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -d build \
|
%cmake -d build \
|
||||||
\
|
\
|
||||||
|
-DCMAKE_CXX_STANDARD=14 \
|
||||||
%ifnarch x86_64
|
%ifnarch x86_64
|
||||||
-DSNAPPY_BUILD_TESTS=off
|
-DSNAPPY_BUILD_TESTS=off
|
||||||
%endif
|
%endif
|
||||||
@ -84,6 +82,12 @@ This package contains libraries and header files for developing applications tha
|
|||||||
%{_libdir}/cmake/Snappy/Snappy*.cmake
|
%{_libdir}/cmake/Snappy/Snappy*.cmake
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 28 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.1-1mamba
|
||||||
|
- update to 1.2.1
|
||||||
|
|
||||||
|
* Sat Sep 17 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.9-1mamba
|
||||||
|
- update to 1.1.9
|
||||||
|
|
||||||
* Sun Aug 19 2018 Automatic Build System <autodist@mambasoft.it> 1.1.7-1mamba
|
* Sun Aug 19 2018 Automatic Build System <autodist@mambasoft.it> 1.1.7-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user