package created using the webbuild interface [release 0.11.2-1mamba;Sat Nov 02 2024]
This commit is contained in:
parent
f56de0f1db
commit
844b84c2a7
@ -1,2 +1,4 @@
|
||||
# snapper
|
||||
|
||||
Manage filesystem snapshots and allow undo of system modifications.
|
||||
|
||||
|
12
snapper-0.11.2-cron-rename.patch
Normal file
12
snapper-0.11.2-cron-rename.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
|
||||
index 1f8176c..b5df671 100644
|
||||
--- a/scripts/Makefile.am
|
||||
+++ b/scripts/Makefile.am
|
||||
@@ -17,6 +17,6 @@ endif
|
||||
EXTRA_DIST = snapper-hourly bash-completion.bash zsh-completion.zsh $(pam_snapper_SCRIPTS)
|
||||
|
||||
install-data-local:
|
||||
- install -D snapper-hourly $(DESTDIR)/etc/cron.hourly/suse.de-snapper
|
||||
+ install -D snapper-hourly $(DESTDIR)/etc/cron.hourly/snapper
|
||||
install -D --mode a+r,u+w bash-completion.bash $(DESTDIR)/usr/share/bash-completion/completions/snapper
|
||||
install -D --mode a+r,u+w zsh-completion.zsh $(DESTDIR)/usr/share/zsh/site-functions/_snapper
|
12
snapper-0.11.2-usr-paths.patch
Normal file
12
snapper-0.11.2-usr-paths.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff --git a/data/org.opensuse.Snapper.service b/data/org.opensuse.Snapper.service
|
||||
index 39d7333..6c49474 100644
|
||||
--- a/data/org.opensuse.Snapper.service
|
||||
+++ b/data/org.opensuse.Snapper.service
|
||||
@@ -1,5 +1,5 @@
|
||||
# DBus service activation config
|
||||
[D-BUS Service]
|
||||
Name=org.opensuse.Snapper
|
||||
-Exec=/usr/sbin/snapperd
|
||||
+Exec=/usr/bin/snapperd
|
||||
User=root
|
||||
|
129
snapper.spec
Normal file
129
snapper.spec
Normal file
@ -0,0 +1,129 @@
|
||||
Name: snapper
|
||||
Version: 0.11.2
|
||||
Release: 1mamba
|
||||
Summary: Manage filesystem snapshots and allow undo of system modifications
|
||||
Group: System/Tools
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://snapper.io/
|
||||
Source: https://github.com/openSUSE/snapper.git/v%{version}/snapper-%{version}.tar.bz2
|
||||
Patch0: snapper-0.11.2-cron-rename.patch
|
||||
Patch1: snapper-0.11.2-usr-paths.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libacl-devel
|
||||
BuildRequires: libboost-devel
|
||||
BuildRequires: libbtrfs-progs-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libjson-c-devel
|
||||
BuildRequires: libmount-devel
|
||||
BuildRequires: libncurses-devel
|
||||
BuildRequires: libpam-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description
|
||||
Manage filesystem snapshots and allow undo of system modifications.
|
||||
|
||||
%package -n lib%{name}
|
||||
Group: System/Libraries
|
||||
Summary: Shared libraries for %{name}
|
||||
|
||||
%description -n lib%{name}
|
||||
This package contains shared libraries for %{name}.
|
||||
|
||||
%package -n lib%{name}-devel
|
||||
Group: Development/Libraries
|
||||
Summary: Development files for %{name}
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n lib%{name}-devel
|
||||
This package contains libraries and header files for developing applications that use %{name}.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch 0 -p1 -b .cron-rename
|
||||
%patch 1 -p1 -F2 -b .usr-paths
|
||||
|
||||
autoreconf -f -i
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--sbindir=%{_bindir} \
|
||||
--with-pam-security=%{_pam_moduledir} \
|
||||
--disable-zypp
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
install -D -m0644 data/sysconfig.snapper %{buildroot}%{_sysconfdir}/sysconfig/snapper
|
||||
|
||||
%find_lang %{name} || touch %{name}.lang
|
||||
|
||||
rm -rf %{buildroot}%{_libdir}/snapper/testsuite
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_sysconfdir}/cron.hourly/snapper
|
||||
%{_sysconfdir}/logrotate.d/snapper
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/snapper
|
||||
%{_bindir}/snapper
|
||||
%{_bindir}/mksubvolume
|
||||
%{_bindir}/snapperd
|
||||
%{_unitdir}/snapper-boot.service
|
||||
%{_unitdir}/snapper-boot.timer
|
||||
%{_unitdir}/snapper-cleanup.service
|
||||
%{_unitdir}/snapper-cleanup.timer
|
||||
%{_unitdir}/snapper-timeline.service
|
||||
%{_unitdir}/snapper-timeline.timer
|
||||
%{_unitdir}/snapperd.service
|
||||
%{_datadir}/bash-completion/completions/snapper
|
||||
%{_datadir}/dbus-1/system-services/org.opensuse.Snapper.service
|
||||
%{_datadir}/dbus-1/system.d/org.opensuse.Snapper.conf
|
||||
%{_prefix}/lib/snapper/installation-helper
|
||||
%{_prefix}/lib/snapper/systemd-helper
|
||||
%dir %{_prefix}/lib/pam_snapper
|
||||
%{_prefix}/lib/pam_snapper/pam_snapper_*.sh
|
||||
%dir %{_datadir}/snapper/config-templates
|
||||
%{_datadir}/snapper/config-templates/default
|
||||
%dir %{_datadir}/snapper/filters
|
||||
%{_datadir}/snapper/filters/*
|
||||
%{_datadir}/zsh/site-functions/_snapper
|
||||
%{_mandir}/man5/snapper-configs.5*
|
||||
%{_mandir}/man8/mksubvolume.8*
|
||||
%{_mandir}/man8/pam_snapper.8*
|
||||
%{_mandir}/man8/snapper.8*
|
||||
%{_mandir}/man8/snapperd.8*
|
||||
%dir %{_docdir}/snapper
|
||||
%{_docdir}/snapper/*
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libsnapper.so.*
|
||||
%{_pam_moduledir}/pam_snapper.so
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/snapper
|
||||
%{_includedir}/snapper/*
|
||||
%{_libdir}/libsnapper.so
|
||||
%doc README.md
|
||||
|
||||
%changelog
|
||||
* Sat Nov 02 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 0.11.2-1mamba
|
||||
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user