automatic update by autodist [release 1.0-1mamba;Fri Oct 23 2009]
This commit is contained in:
parent
d564e77dc4
commit
1ca47ccd52
@ -1,2 +1,9 @@
|
|||||||
# smile
|
# smile
|
||||||
|
|
||||||
|
SMILE means Slideshow Maker In Linux Environnement.
|
||||||
|
SMILE is a slideshow creating tool (developed with qt4), for GNU/Linux,
|
||||||
|
although it also works on Mac OS/X and maybe one day on Microsoft Windows.
|
||||||
|
It allows, from images, to create a video slideshow, that can be played on almost all medias.
|
||||||
|
The numerous features and the simplicity of use make it possible to create dynamic and rich slideshows in just a few clicks,
|
||||||
|
without having to worry about technical issues or complicated settings.
|
||||||
|
|
||||||
|
11
smile-0.8.1-lang.patch
Normal file
11
smile-0.8.1-lang.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- smile/mainfrm.cpp 2008-09-14 16:38:43.000000000 +0200
|
||||||
|
+++ smile/mainfrm.cpp-gil 2008-09-30 22:58:26.000000000 +0200
|
||||||
|
@@ -180,7 +180,7 @@
|
||||||
|
QString wlpack = QLocale::system().name();
|
||||||
|
qDebug() << "LOADING LANGUAGE ... smile_" + wlpack.left(2);
|
||||||
|
QTranslator *qtTranslator = new QTranslator(this);
|
||||||
|
- if (qtTranslator->load("smile_" + wlpack.left(2), qApp->applicationDirPath()) == true )
|
||||||
|
+ if (qtTranslator->load("/usr/share/smile/smile_" + wlpack.left(2), qApp->applicationDirPath()) == true )
|
||||||
|
{
|
||||||
|
qApp->installTranslator(qtTranslator);
|
||||||
|
}
|
11
smile-0.8.6-helpfrm.patch
Normal file
11
smile-0.8.6-helpfrm.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- smile/helpfrm.cpp 2008-10-25 15:50:04.000000000 +0200
|
||||||
|
+++ smile/helpfrm.cpp-gil 2008-10-31 19:00:10.000000000 +0100
|
||||||
|
@@ -32,7 +32,7 @@
|
||||||
|
{
|
||||||
|
if ( wlpack.left(2) == "it" )
|
||||||
|
{
|
||||||
|
- webhelp->load(QUrl(wg_tmp_002 + "/BIB_ManSlide/Help/doc_it.html"));
|
||||||
|
+ webhelp->load(QUrl(wg_tmp_002 + "/BIB_ManSlide/Help/doc_en.html"));
|
||||||
|
}
|
||||||
|
else
|
||||||
|
{
|
195
smile.spec
Normal file
195
smile.spec
Normal file
@ -0,0 +1,195 @@
|
|||||||
|
Name: smile
|
||||||
|
Version: 1.0
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: SMILE - Slideshow Maker In Linux Environement
|
||||||
|
Group: Graphical Desktop/Applications/Publishing
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: gil <puntogil@libero.it>
|
||||||
|
URL: http://smile.tuxfamily.org/
|
||||||
|
Source: http://download.tuxfamily.org/smiletool/smile-%{version}.tar.gz
|
||||||
|
Patch0: smile-0.8.1-lang.patch
|
||||||
|
Patch1: smile-0.8.6-helpfrm.patch
|
||||||
|
License: GPL
|
||||||
|
Requires: mplayer
|
||||||
|
Requires: mencoder
|
||||||
|
Requires: ImageMagick
|
||||||
|
Requires: sox
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: ImageMagick-devel
|
||||||
|
BuildRequires: libfontconfig-devel
|
||||||
|
BuildRequires: libfreetype-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libGL-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libGLU-devel
|
||||||
|
BuildRequires: libICE-devel
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libqt4-devel
|
||||||
|
BuildRequires: libSM-devel
|
||||||
|
BuildRequires: libsqlite-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXext-devel
|
||||||
|
BuildRequires: libXfixes-devel
|
||||||
|
BuildRequires: libXinerama-devel
|
||||||
|
BuildRequires: libXrandr-devel
|
||||||
|
BuildRequires: libXrender-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
BuildRequires: mencoder
|
||||||
|
BuildRequires: mplayer
|
||||||
|
BuildRequires: sox-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
SMILE means Slideshow Maker In Linux Environnement.
|
||||||
|
SMILE is a slideshow creating tool (developed with qt4), for GNU/Linux,
|
||||||
|
although it also works on Mac OS/X and maybe one day on Microsoft Windows.
|
||||||
|
It allows, from images, to create a video slideshow, that can be played on almost all medias.
|
||||||
|
The numerous features and the simplicity of use make it possible to create dynamic and rich slideshows in just a few clicks,
|
||||||
|
without having to worry about technical issues or complicated settings.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
|
||||||
|
%setup -q -n %{name}
|
||||||
|
%patch0 -p1
|
||||||
|
#%patch1 -p1
|
||||||
|
%build
|
||||||
|
export QTDIR=%{_qt4_prefix} QTLIB=%{_qt4_libdir}
|
||||||
|
%{_bindir}/qmake-qt4 -o Makefile smile.pro
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{_datadir}/applications
|
||||||
|
#mkdir -p %{buildroot}%{_datadir}/pixmaps
|
||||||
|
mkdir -p %{buildroot}%{_bindir}
|
||||||
|
mkdir -p %{buildroot}%{_datadir}/%{name}/BIB_ManSlide/Eff_sup
|
||||||
|
mkdir -p %{buildroot}%{_datadir}/%{name}/BIB_ManSlide/Help/images
|
||||||
|
mkdir -p %{buildroot}%{_datadir}/%{name}/BIB_ManSlide/Help/images_en
|
||||||
|
mkdir -p %{buildroot}%{_datadir}/%{name}/BIB_ManSlide/Help/images_fr
|
||||||
|
mkdir -p %{buildroot}%{_datadir}/%{name}/BIB_ManSlide/Luma
|
||||||
|
mkdir -p %{buildroot}%{_datadir}/%{name}/Interface/Origine
|
||||||
|
mkdir -p %{buildroot}%{_datadir}/%{name}/Interface/Theme
|
||||||
|
|
||||||
|
install -m 644 Interface/Theme/*.png %{buildroot}%{_datadir}/%{name}/Interface/Theme
|
||||||
|
install -m 644 Interface/Theme/*.gif %{buildroot}%{_datadir}/%{name}/Interface/Theme
|
||||||
|
|
||||||
|
#install -m 644 Interface/Theme/Origine/*.xcf %{buildroot}%{_datadir}/%{name}/Interface/Origine
|
||||||
|
|
||||||
|
install -m 644 BIB_ManSlide/Eff_sup/*.png %{buildroot}%{_datadir}/%{name}/BIB_ManSlide/Eff_sup
|
||||||
|
install -m 644 BIB_ManSlide/Eff_sup/*.gif %{buildroot}%{_datadir}/%{name}/BIB_ManSlide/Eff_sup
|
||||||
|
install -m 644 BIB_ManSlide/Eff_sup/*.txt %{buildroot}%{_datadir}/%{name}/BIB_ManSlide/Eff_sup
|
||||||
|
|
||||||
|
install -m 644 BIB_ManSlide/Help/images/*.png %{buildroot}%{_datadir}/%{name}/BIB_ManSlide/Help/images
|
||||||
|
install -m 644 BIB_ManSlide/Help/images/*.jpg %{buildroot}%{_datadir}/%{name}/BIB_ManSlide/Help/images
|
||||||
|
|
||||||
|
install -m 644 BIB_ManSlide/Help/images_en/*.png %{buildroot}%{_datadir}/%{name}/BIB_ManSlide/Help/images_en
|
||||||
|
|
||||||
|
install -m 644 BIB_ManSlide/Help/images_fr/*.png %{buildroot}%{_datadir}/%{name}/BIB_ManSlide/Help/images_fr
|
||||||
|
|
||||||
|
install -m 644 BIB_ManSlide/Help/*.html %{buildroot}%{_datadir}/%{name}/BIB_ManSlide/Help
|
||||||
|
install -m 644 BIB_ManSlide/Help/*.txt %{buildroot}%{_datadir}/%{name}/BIB_ManSlide/Help
|
||||||
|
install -m 644 BIB_ManSlide/Help/*.css %{buildroot}%{_datadir}/%{name}/BIB_ManSlide/Help
|
||||||
|
|
||||||
|
install -m 644 BIB_ManSlide/Luma/*.png %{buildroot}%{_datadir}/%{name}/BIB_ManSlide/Luma
|
||||||
|
|
||||||
|
install -m 644 smile_*.qm %{buildroot}%{_datadir}/%{name}
|
||||||
|
install -m 644 interface.qrc %{buildroot}%{_datadir}/%{name}
|
||||||
|
install -m 644 *.ui %{buildroot}%{_datadir}/%{name}
|
||||||
|
install -m 755 %{name} %{buildroot}%{_bindir}
|
||||||
|
|
||||||
|
#install -m 644 Interface/Theme/%{name}.png \
|
||||||
|
#%{buildroot}%{_datadir}/pixmaps/%{name}.png
|
||||||
|
|
||||||
|
|
||||||
|
cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
|
||||||
|
[Desktop Entry]
|
||||||
|
Type=Application
|
||||||
|
Version=1.0
|
||||||
|
Encoding=UTF-8
|
||||||
|
Name=Smile
|
||||||
|
Name[it]=Smile
|
||||||
|
Name[tr]=Smile
|
||||||
|
GenericName=Slideshow creation software
|
||||||
|
GenericName[de]=Slideshow Schaffung Software
|
||||||
|
GenericName[fr]=Logiciel de création de diaporama
|
||||||
|
GenericName[it]=Software per la creazione di slideshow
|
||||||
|
GenericName[tr]=Slayt Programı
|
||||||
|
Icon=/usr/share/smile/Interface/Theme/smile.png
|
||||||
|
Exec=/usr/bin/smile
|
||||||
|
Terminal=false
|
||||||
|
StartupNotify=false
|
||||||
|
Categories=Qt;KDE;Application;Graphics;
|
||||||
|
EOF
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/smile
|
||||||
|
%{_datadir}/applications/%{name}.desktop
|
||||||
|
#%{_datadir}/pixmaps/smile.png
|
||||||
|
%dir %{_datadir}/smile
|
||||||
|
%{_datadir}/smile/smile_*.qm
|
||||||
|
%{_datadir}/smile/*.ui
|
||||||
|
%{_datadir}/smile/interface.qrc
|
||||||
|
%dir %{_datadir}/smile/BIB_ManSlide
|
||||||
|
%{_datadir}/smile/BIB_ManSlide/Eff_sup
|
||||||
|
%{_datadir}/smile/BIB_ManSlide/Help
|
||||||
|
%{_datadir}/smile/BIB_ManSlide/Luma
|
||||||
|
%dir %{_datadir}/smile/Interface
|
||||||
|
%{_datadir}/smile/Interface/Origine
|
||||||
|
%{_datadir}/smile/Interface/Theme
|
||||||
|
%doc copying
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Oct 23 2009 Automatic Build System <autodist@mambasoft.it> 1.0-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Fri Oct 02 2009 Automatic Build System <autodist@mambasoft.it> 0.9.14-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sun Aug 23 2009 Automatic Build System <autodist@mambasoft.it> 0.9.11-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sat Jun 13 2009 Automatic Build System <autodist@mambasoft.it> 0.9.10-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Tue May 19 2009 Automatic Build System <autodist@mambasoft.it> 0.9.9-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Mon May 04 2009 Automatic Build System <autodist@mambasoft.it> 0.9.7-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Thu Apr 23 2009 Automatic Build System <autodist@mambasoft.it> 0.9.3-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sat Apr 11 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.1-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Fri Jan 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.9-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Fri Nov 14 2008 gil <puntogil@libero.it> 0.8.8-1mamba
|
||||||
|
- update to 0.8.8
|
||||||
|
|
||||||
|
* Fri Oct 31 2008 gil <puntogil@libero.it> 0.8.6-1mamba
|
||||||
|
- update to 0.8.6
|
||||||
|
|
||||||
|
* Sat Oct 18 2008 gil <puntogil@libero.it> 0.8.5-1mamba
|
||||||
|
- update to 0.8.5
|
||||||
|
|
||||||
|
* Tue Sep 30 2008 gil <puntogil@libero.it> 0.8.3-1mamba
|
||||||
|
- update to 0.8.3
|
||||||
|
- added lang patch
|
||||||
|
|
||||||
|
* Wed Sep 24 2008 gil <puntogil@libero.it> 0.8.1-1mamba
|
||||||
|
- update to 0.8.1
|
||||||
|
|
||||||
|
* Fri Aug 22 2008 gil <puntogil@libero.it> 0.7.2-1mamba
|
||||||
|
- added desktop file
|
Loading…
Reference in New Issue
Block a user