update to 1.1.1 [release 1.1.1-1mamba;Sun Apr 27 2014]
This commit is contained in:
parent
d57415df94
commit
9d517fcd56
@ -1,2 +1,6 @@
|
|||||||
# smb4k
|
# smb4k
|
||||||
|
|
||||||
|
Smb4K is a SMB/CIFS share browser for KDE.
|
||||||
|
It uses the Samba software suite to access the SMB shares of the local network neighborhood.
|
||||||
|
Its purpose is to provide a program that's easy to use and has as many features as possible.
|
||||||
|
|
||||||
|
12
smb4k-0.10.10-io_charset_locale_fix.patch
Normal file
12
smb4k-0.10.10-io_charset_locale_fix.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Nru smb4k-0.10.10.orig//core/smb4ksambaoptionshandler.cpp smb4k-0.10.10/core/smb4ksambaoptionshandler.cpp
|
||||||
|
--- smb4k-0.10.10.orig//core/smb4ksambaoptionshandler.cpp 2011-03-08 13:05:27.000000000 +0100
|
||||||
|
+++ smb4k-0.10.10/core/smb4ksambaoptionshandler.cpp 2011-03-22 17:59:09.999181054 +0100
|
||||||
|
@@ -1518,7 +1518,7 @@
|
||||||
|
|
||||||
|
args.append( QString( "port=%1," ).arg( port ) );
|
||||||
|
|
||||||
|
- args.append( !charset.isEmpty() ?
|
||||||
|
+ args.append( (!charset.isEmpty() && charset.compare("LOCALE", Qt::CaseInsensitive)) ?
|
||||||
|
QString( "iocharset=%1," ).arg( charset ) :
|
||||||
|
QString() );
|
||||||
|
|
30
smb4k-0.10.74-arm_qreal_double.patch
Normal file
30
smb4k-0.10.74-arm_qreal_double.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
diff -ru smb4k-0.10.74.orig/core/smb4kshare.cpp smb4k-0.10.74/core/smb4kshare.cpp
|
||||||
|
--- smb4k-0.10.74.orig/core/smb4kshare.cpp 2011-09-19 10:38:31.000000000 +0200
|
||||||
|
+++ smb4k-0.10.74/core/smb4kshare.cpp 2012-02-25 15:08:35.072531855 +0100
|
||||||
|
@@ -456,7 +456,7 @@
|
||||||
|
qulonglong factor = 0;
|
||||||
|
|
||||||
|
(void) frexp( m_total * 1024, &exponent );
|
||||||
|
- (void) modf( (exponent - 10) / 10, &tmp_factor );
|
||||||
|
+ (void) modf( (exponent - 10) / 10, (double*)&tmp_factor );
|
||||||
|
factor = tmp_factor;
|
||||||
|
qreal tmp_total = m_total / pow( 1024, factor );
|
||||||
|
total = QString( "%1" ).arg( tmp_total, 0, 'f', 1 );
|
||||||
|
@@ -513,7 +513,7 @@
|
||||||
|
qulonglong factor = 0;
|
||||||
|
|
||||||
|
(void) frexp( m_free * 1024, &exponent );
|
||||||
|
- (void) modf( (exponent - 10) / 10, &tmp_factor );
|
||||||
|
+ (void) modf( (exponent - 10) / 10, (double*)&tmp_factor );
|
||||||
|
factor = tmp_factor;
|
||||||
|
qreal tmp_free = m_free / pow( 1024, factor );
|
||||||
|
free = QString( "%1" ).arg( tmp_free, 0, 'f', 1 );
|
||||||
|
@@ -570,7 +570,7 @@
|
||||||
|
qulonglong factor = 0;
|
||||||
|
|
||||||
|
(void) frexp( m_used * 1024, &exponent );
|
||||||
|
- (void) modf( (exponent - 10) / 10, &tmp_factor );
|
||||||
|
+ (void) modf( (exponent - 10) / 10, (double*)&tmp_factor );
|
||||||
|
factor = tmp_factor;
|
||||||
|
qreal tmp_used = m_used / pow( 1024, factor );
|
||||||
|
used = QString( "%1" ).arg( tmp_used, 0, 'f', 1 );
|
198
smb4k.spec
Normal file
198
smb4k.spec
Normal file
@ -0,0 +1,198 @@
|
|||||||
|
%define kdedir %(echo `kde-config --prefix`)
|
||||||
|
%define qtver %(echo `rpm -q --queryformat '%{VERSION}' libqt`)
|
||||||
|
%define kdever %(echo `rpm -q --queryformat '%{VERSION}' kdelibs`)
|
||||||
|
|
||||||
|
Name: smb4k
|
||||||
|
Version: 1.1.1
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A SMB/CIFS share browser for KDE
|
||||||
|
Group: Graphical Desktop/Applications/Networking
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://sourceforge.net/p/smb4k/home/Home
|
||||||
|
Source: http://downloads.sourceforge.net/project/smb4k/%{version}/smb4k-%{version}.tar.xz
|
||||||
|
Patch0: %{name}-0.10.10-io_charset_locale_fix.patch
|
||||||
|
Patch1: %{name}-0.10.74-arm_qreal_double.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: kdelibs-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libqt4-devel
|
||||||
|
BuildRequires: libsoprano-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libGL-devel
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libjpeg-devel
|
||||||
|
BuildRequires: gettext-devel
|
||||||
|
BuildRequires: libxml2-utils
|
||||||
|
Provides: smb4k4
|
||||||
|
Obsoletes: smb4k4
|
||||||
|
Requires: samba >= 3.0.3-2
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Smb4K is a SMB/CIFS share browser for KDE.
|
||||||
|
It uses the Samba software suite to access the SMB shares of the local network neighborhood.
|
||||||
|
Its purpose is to provide a program that's easy to use and has as many features as possible.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Static libraries and headers for %{name}
|
||||||
|
Provides: smb4k4-devel
|
||||||
|
Obsoletes: smb4k4-devel
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Smb4K is a SMB/CIFS share browser for KDE.
|
||||||
|
It uses the Samba software suite to access the SMB shares of the local network neighborhood.
|
||||||
|
Its purpose is to provide a program that's easy to use and has as many features as possible.
|
||||||
|
This package provides the static libraries and headers needed for development.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
#%patch0 -p1
|
||||||
|
#%patch1 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cmake_kde4 -d build
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall -C build
|
||||||
|
|
||||||
|
install -d %{buildroot}%{_datadir}/
|
||||||
|
mv %{buildroot}/opt/kde/share/polkit-1 %{buildroot}%{_datadir}
|
||||||
|
|
||||||
|
%find_lang smb4k
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files -f smb4k.lang
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_sysconfdir}/dbus-1/system.d/net.sourceforge.smb4k.mounthelper.conf
|
||||||
|
%{_datadir}/dbus-1/system-services/net.sourceforge.smb4k.mounthelper.service
|
||||||
|
%{_datadir}/polkit-1/actions/net.sourceforge.smb4k.mounthelper.policy
|
||||||
|
%{_kde4_bindir}/smb4k*
|
||||||
|
%{_kde4_xdgappsdir}/smb4k.desktop
|
||||||
|
%dir %{_kde4_datadir}/smb4k
|
||||||
|
%{_kde4_datadir}/smb4k/*
|
||||||
|
%dir %{_kde4_datadir}/plasma/plasmoids/smb4k-qml
|
||||||
|
%{_kde4_datadir}/plasma/plasmoids/smb4k-qml/*
|
||||||
|
%{_kde4_libexecdir}/mounthelper
|
||||||
|
%{_kde4_libdir}/libkdeinit4_smb4k.so
|
||||||
|
%{_kde4_libdir}/libsmb4ktooltips.so
|
||||||
|
%{_kde4_servicesdir}/plasma-applet-smb4k-qml.desktop
|
||||||
|
%{_kde4_kcfgdir}/smb4k.kcfg
|
||||||
|
%{_kde4_kconfupdatedir}/*
|
||||||
|
%{_kde4_icondir}/hicolor/*/apps/smb4k.png
|
||||||
|
%{_kde4_icondir}/oxygen/*/apps/smb4k.png
|
||||||
|
%lang(en) %{_kde4_htmldir}/en/*
|
||||||
|
#%lang(et) %{_kde4_htmldir}/et/*
|
||||||
|
#%lang(fr) %{_kde4_htmldir}/fr/*
|
||||||
|
%lang(nl) %{_kde4_htmldir}/nl/*
|
||||||
|
#%lang(pt) %{_kde4_htmldir}/pt/*
|
||||||
|
#%lang(pt_BR) %{_kde4_htmldir}/pt_BR/*
|
||||||
|
%lang(sv) %{_kde4_htmldir}/sv/*
|
||||||
|
%lang(uk) %{_kde4_htmldir}/uk/*
|
||||||
|
%{_kde4_libdir}/libsmb4kcore.so.*
|
||||||
|
%{_kde4_libdir}/kde4/*.so
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_kde4_libdir}/libsmb4kcore.so
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Apr 27 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.1-1mamba
|
||||||
|
- update to 1.1.1
|
||||||
|
|
||||||
|
* Sun Jan 12 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.0-1mamba
|
||||||
|
- update to 1.1.0
|
||||||
|
|
||||||
|
* Fri Jul 19 2013 Automatic Build System <autodist@mambasoft.it> 1.0.80-1mamba
|
||||||
|
- update to 1.0.80
|
||||||
|
|
||||||
|
* Fri May 17 2013 Automatic Build System <autodist@mambasoft.it> 1.0.7-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Mar 06 2013 Automatic Build System <autodist@mambasoft.it> 1.0.6-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Dec 27 2012 Automatic Build System <autodist@mambasoft.it> 1.0.5-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Dec 03 2012 Automatic Build System <autodist@mambasoft.it> 1.0.4-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Oct 03 2011 Automatic Build System <autodist@mambasoft.it> 0.10.74-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Jul 25 2011 Automatic Build System <autodist@mambasoft.it> 0.10.70-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Mar 22 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.10-1mamba
|
||||||
|
- update to 0.10.10
|
||||||
|
|
||||||
|
* Sun Jun 20 2010 Automatic Build System <autodist@mambasoft.it> 0.10.7-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sat Oct 10 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.4-2mamba
|
||||||
|
- rename from smb4k4
|
||||||
|
|
||||||
|
* Fri Oct 09 2009 Automatic Build System <autodist@mambasoft.it> 0.10.4-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Wed Mar 04 2009 Ercole ercolinux Carpanetto <ercole69@gmail.com> 0.10.2-1mamba
|
||||||
|
- update to 0.10.2
|
||||||
|
|
||||||
|
* Thu Dec 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.1-1mamba
|
||||||
|
- update to 0.10.1
|
||||||
|
|
||||||
|
* Thu Oct 02 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.7-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sun Jun 10 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.3-1mamba
|
||||||
|
- update to 0.8.3
|
||||||
|
|
||||||
|
* Tue Apr 10 2007 Davide Madrisan <davide.madrisan@gmail.com> 0.8.1-1mamba
|
||||||
|
- update to version 0.8.1 (this release fixes several security issues)
|
||||||
|
|
||||||
|
* Thu Feb 22 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.0-1qilnx
|
||||||
|
- update to version 0.8.0 by autospec
|
||||||
|
|
||||||
|
* Tue Jun 13 2006 Davide Madrisan <davide.madrisan@qilinux.it> 0.7.0-1qilnx
|
||||||
|
- update to version 0.7.0 by autospec
|
||||||
|
|
||||||
|
* Mon Nov 21 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.6.4-1qilnx
|
||||||
|
- update to version 0.6.4 by autospec
|
||||||
|
- also fixes the security issue CAN-2005-2851 (qibug#77)
|
||||||
|
|
||||||
|
* Thu Sep 08 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.6.3-1qilnx
|
||||||
|
- update to version 0.6.3 by autospec
|
||||||
|
- also fixes a security issue
|
||||||
|
- specfile fixes
|
||||||
|
|
||||||
|
* Thu Jun 30 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.0-1qilnx
|
||||||
|
- update to version 0.6.0 by autospec
|
||||||
|
|
||||||
|
* Tue Apr 19 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.2-1qilnx
|
||||||
|
- update to version 0.5.2 by autospec
|
||||||
|
|
||||||
|
* Thu Mar 17 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.1-1qilnx
|
||||||
|
- update to version 0.5.1 by autospec
|
||||||
|
|
||||||
|
* Wed Dec 01 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.1a-1qilnx
|
||||||
|
- update to version 0.4.1a by autospec
|
||||||
|
|
||||||
|
* Wed Dec 01 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.1-1qilnx
|
||||||
|
- update to version 0.4.1 by autospec
|
||||||
|
|
||||||
|
* Wed May 06 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.0-1qilnx
|
||||||
|
- first build
|
Loading…
Reference in New Issue
Block a user