134 lines
4.3 KiB
RPMSpec
134 lines
4.3 KiB
RPMSpec
Name: slib
|
|
Version: 3b6
|
|
Release: 1mamba
|
|
Summary: platform independent library for scheme
|
|
Group: Development/Tools
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://people.csail.mit.edu/jaffer/SLIB.html
|
|
Source: http://groups.csail.mit.edu/mac/ftpdir/scm/slib-%{version}.zip
|
|
Patch0: slib-3b4-texinfo-5.patch
|
|
License: MIT
|
|
## AUTOBUILDREQ-BEGIN
|
|
## AUTOBUILDREQ-END
|
|
Requires(post): umb-scheme
|
|
Requires(post): %{__install_info}
|
|
Requires(post): libguile-tools
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
"SLIB" is a portable library for the programming language Scheme.
|
|
It provides a platform independent framework for using "packages" of Scheme procedures and syntax.
|
|
As distributed, SLIB contains useful packages for all Scheme implementations.
|
|
Its catalog can be transparently extended to accomodate packages specific to a site, implementation, user, or directory.
|
|
|
|
%prep
|
|
%setup -q -n %{name}
|
|
%patch0 -p1
|
|
|
|
touch collectx.scm
|
|
|
|
# Path fix
|
|
sed -r -i 's,/usr/(local/)?lib/slib,/usr/share/slib,g' *.init
|
|
|
|
# Add missing headers and definitions
|
|
sed -i "1s,^,#!/bin/sh\nexport SCHEME_LIBRARY_PATH=/usr/share/slib/\nVERSION=$pkgver\n,;s,\${S48_VICINITY},/usr/share/scheme48/,g" slib.sh
|
|
|
|
#sed -i "s|/usr/lib/slib|%{_datadir}/slib|" *
|
|
#sed -i "s|/usr/lib/umb-scheme|%{_datadir}/umb-scheme|" *
|
|
|
|
%build
|
|
:<< __OLD
|
|
./configure \
|
|
--prefix=%{_prefix} \
|
|
--libdir=%{_datadir} \
|
|
--mandir=%{_mandir}
|
|
|
|
#% make
|
|
#gzip -9nf slib.info
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
#% makeinstall
|
|
|
|
install -d %{buildroot}%{_bindir} %{buildroot}%{_datadir}/{guile/site,slib}
|
|
install -m644 *.scm *.init *.xyz *.txt *.dat *.ps %{buildroot}%{_datadir}/slib/
|
|
install -Dm755 slib.sh %{buildroot}%{_bindir}/slib
|
|
ln -s %{_datadir}/slib %{buildroot}%{_datadir}/guile/site/
|
|
install -Dm644 slib.info %{buildroot}%{_infodir}/slib.info
|
|
install -Dm644 slib.1 %{buildroot}%{_mandir}/man1/slib.1
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post
|
|
if [ $1 -ge 1 ]; then
|
|
# Rebuild catalogs for as many implementations as possible.
|
|
# FIXME: make catalogs has errors; making it silent
|
|
%install_info %{name}.info
|
|
# creates /usr/share/guile/site/2.0/slibcat
|
|
#mkdir -p %{_datadir}/guile/1.8
|
|
guile -c "(use-modules (ice-9 slib)) (require 'new-catalog)" &>/dev/null || true
|
|
fi
|
|
exit 0
|
|
|
|
%preun
|
|
%install_info %{name}.info
|
|
exit 0
|
|
|
|
%files
|
|
%defattr(-, root, root)
|
|
%{_bindir}/slib
|
|
%dir %{_datadir}/slib
|
|
%{_datadir}/slib/*
|
|
%{_datadir}/guile/site/slib
|
|
%{_infodir}/slib.info*
|
|
%{_mandir}/man1/slib.1*
|
|
%doc COPYING
|
|
#%doc ANNOUNCE README FAQ ChangeLog
|
|
|
|
%changelog
|
|
* Sat Jan 30 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3b6-1mamba
|
|
- update to 3b6
|
|
|
|
* Fri Jan 30 2015 Automatic Build System <autodist@mambasoft.it> 3b5-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed Oct 30 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3b4-3mamba
|
|
- revert to guile1 for gnucash to work
|
|
|
|
* Wed Jun 19 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3b4-2mamba
|
|
- add symlink in guile site directory
|
|
- run guile use-modules to create slibcat catalog
|
|
|
|
* Fri Jun 14 2013 Automatic Build System <autodist@mambasoft.it> 3b4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Feb 06 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3b3-2mamba
|
|
- post script: fix path to cd into
|
|
|
|
* Sat Aug 04 2012 Automatic Build System <autodist@mambasoft.it> 3b3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Sep 16 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 3b2-2mamba
|
|
- fixed prefix variable in make install
|
|
- fixed installation of info files as reported by autospec
|
|
- fixed installation patch for man pages
|
|
|
|
* Wed Aug 13 2009 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 3b2-1mamba
|
|
- update to 3b2
|
|
- added a simlink to /usr/share/slib/mklibcat.scm as mklibcat to avoid a bug in gnucash
|
|
|
|
* Mon Dec 03 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 3a4-2mamba
|
|
- pre-require umb-scheme needed for making catalog
|
|
|
|
* Tue Nov 06 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 3a4-1mamba
|
|
- update to 3a4
|
|
|
|
* Tue Jun 07 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 3a1-2qilnx
|
|
- rebuild and moved from devel-contrib repository to devel repository
|
|
|
|
* Tue Oct 26 2004 <> %{version}-%{release}
|
|
- First Build
|