rebuilt with libtk 8.6 and python-Pillow-devel [release 0.6.17-3mamba;Fri Sep 26 2014]
This commit is contained in:
parent
8082f833d9
commit
858a55f46d
22
skencil-0.6.17-libtcl-8.6.patch
Normal file
22
skencil-0.6.17-libtcl-8.6.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- skencil-0.6.17/Pax/paxmodule.c.orig 2014-09-26 22:52:15.875429070 +0200
|
||||||
|
+++ skencil-0.6.17/Pax/paxmodule.c 2014-09-26 22:51:29.252433084 +0200
|
||||||
|
@@ -9,7 +9,7 @@
|
||||||
|
8.4 and earlier versions. Once Tcl releases before 8.4 don't need to
|
||||||
|
be supported anymore, this should go. */
|
||||||
|
#define USE_COMPAT_CONST
|
||||||
|
-
|
||||||
|
+#define USE_INTERP_RESULT
|
||||||
|
#include <tcl.h>
|
||||||
|
#include <tk.h>
|
||||||
|
|
||||||
|
--- skencil-0.6.17/Pax/paxtkinter.c.orig 2014-09-26 22:55:23.146412948 +0200
|
||||||
|
+++ skencil-0.6.17/Pax/paxtkinter.c 2014-09-26 22:55:59.533409815 +0200
|
||||||
|
@@ -108,7 +108,7 @@
|
||||||
|
8.4 and earlier versions. Once Tcl releases before 8.4 don't need to
|
||||||
|
be supported anymore, this should go. */
|
||||||
|
#define USE_COMPAT_CONST
|
||||||
|
-
|
||||||
|
+#define USE_INTERP_RESULT 1
|
||||||
|
#include <tcl.h>
|
||||||
|
#include <tk.h>
|
||||||
|
|
20
skencil.spec
20
skencil.spec
@ -1,6 +1,6 @@
|
|||||||
Name: skencil
|
Name: skencil
|
||||||
Version: 0.6.17
|
Version: 0.6.17
|
||||||
Release: 2mamba
|
Release: 3mamba
|
||||||
Summary: An interactive vector drawing appliction
|
Summary: An interactive vector drawing appliction
|
||||||
Group: Graphical Desktop/Applications/Graphics
|
Group: Graphical Desktop/Applications/Graphics
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -8,22 +8,26 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.skencil.org
|
URL: http://www.skencil.org
|
||||||
Source: http://kent.dl.sourceforge.net/sourceforge/sketch/skencil-%{version}.tar.gz
|
Source: http://kent.dl.sourceforge.net/sourceforge/sketch/skencil-%{version}.tar.gz
|
||||||
|
Patch0: skencil-0.6.17-libtcl-8.6.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libtcl
|
|
||||||
BuildRequires: libtk
|
|
||||||
BuildRequires: libX11-devel
|
BuildRequires: libX11-devel
|
||||||
BuildRequires: libXext-devel
|
BuildRequires: libXext-devel
|
||||||
|
BuildRequires: libtcl-devel
|
||||||
|
BuildRequires: libtk-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: python-Imaging >= 1.1.6
|
BuildRequires: python-Pillow
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Skencil is a Free Software interactive vector drawing appliction. Known to run on GNU/Linux and other UNIX-compatible systems, it is a flexible and powerful tool for illustrations, diagrams and other purposes.
|
Skencil is a Free Software interactive vector drawing appliction. Known to run on GNU/Linux and other UNIX-compatible systems, it is a flexible and powerful tool for illustrations, diagrams and other purposes.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
TKVER=`pkg-config --modversion tk | cut -d. -f1-2`
|
||||||
|
sed -i "s|8\.4|${TKVER}|" setup.py
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./setup.py configure
|
./setup.py configure
|
||||||
@ -33,7 +37,8 @@ BLDSHARED='gcc -shared' ./setup.py build
|
|||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%{__python} setup.py install \
|
%{__python} setup.py install \
|
||||||
--dest-dir="%{buildroot}" \
|
--dest-dir="%{buildroot}" \
|
||||||
--prefix=%{_prefix}
|
--prefix=%{_prefix} \
|
||||||
|
--tk-flags="`pkg-config --libs tk`"
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
@ -48,9 +53,12 @@ BLDSHARED='gcc -shared' ./setup.py build
|
|||||||
%{_bindir}/skshow
|
%{_bindir}/skshow
|
||||||
%dir %{_libdir}/skencil-%{version}
|
%dir %{_libdir}/skencil-%{version}
|
||||||
%{_libdir}/skencil-%{version}/*
|
%{_libdir}/skencil-%{version}/*
|
||||||
%doc BUGS COPYING CREDITS NEWS README TODO
|
%doc COPYING CREDITS BUGS NEWS README TODO
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 26 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.17-3mamba
|
||||||
|
- rebuilt with libtk 8.6 and python-Pillow-devel
|
||||||
|
|
||||||
* Wed Dec 10 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.17-2mamba
|
* Wed Dec 10 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.17-2mamba
|
||||||
- specfile updated
|
- specfile updated
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user