update to 2.0.0.20200531git.43b2621 [release 2.0.0.20200531git.43b2621-1mamba;Mon Mar 13 2023]
This commit is contained in:
parent
883b961924
commit
f01a3755c6
12
silicon-2.0.0.20200531git.43b2621-gcc-12.2.0.patch
Normal file
12
silicon-2.0.0.20200531git.43b2621-gcc-12.2.0.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up silicon-2.0.0-20150413/Libs/SiliconLib/scatwidget.cpp.omv~ silicon-2.0.0-20150413/Libs/SiliconLib/scatwidget.cpp
|
||||||
|
--- silicon-2.0.0-20150413/Libs/SiliconLib/scatwidget.cpp.omv~ 2019-05-12 03:23:54.071826382 +0200
|
||||||
|
+++ silicon-2.0.0-20150413/Libs/SiliconLib/scatwidget.cpp 2019-05-12 03:24:07.800688792 +0200
|
||||||
|
@@ -87,7 +87,7 @@ void SpecListWidget::paintEvent( QPaintE
|
||||||
|
{
|
||||||
|
QListWidget::paintEvent( event );
|
||||||
|
|
||||||
|
- if( this->currentItem() <= 0 )
|
||||||
|
+ if( this->currentItem() == nullptr )
|
||||||
|
{
|
||||||
|
toolbar->hide();
|
||||||
|
return ;
|
@ -0,0 +1,20 @@
|
|||||||
|
--- silicon-2.0.0.20200531git.43b2621/Libs/SiliconLib/sgraphictimer.cpp.orig 2023-03-13 19:55:23.420080714 +0100
|
||||||
|
+++ silicon-2.0.0.20200531git.43b2621/Libs/SiliconLib/sgraphictimer.cpp 2023-03-13 19:55:39.410966405 +0100
|
||||||
|
@@ -5,6 +5,7 @@
|
||||||
|
|
||||||
|
#include <QRect>
|
||||||
|
#include <QPainter>
|
||||||
|
+#include <QPainterPath>
|
||||||
|
#include <QTimer>
|
||||||
|
#include <QPointF>
|
||||||
|
#include <QFont>
|
||||||
|
--- silicon-2.0.0.20200531git.43b2621/SPlugins/SingleInnerDialog/dialogwidget.cpp.orig 2023-03-13 19:54:28.830476741 +0100
|
||||||
|
+++ silicon-2.0.0.20200531git.43b2621/SPlugins/SingleInnerDialog/dialogwidget.cpp 2023-03-13 19:54:46.746345746 +0100
|
||||||
|
@@ -4,6 +4,7 @@
|
||||||
|
#include "dialogwidget.h"
|
||||||
|
|
||||||
|
#include <QPainter>
|
||||||
|
+#include <QPainterPath>
|
||||||
|
#include <QRect>
|
||||||
|
#include <QHBoxLayout>
|
||||||
|
#include <QLinearGradient>
|
74
silicon.spec
74
silicon.spec
@ -1,43 +1,76 @@
|
|||||||
|
%define gittag %(echo %version | cut -d. -f5)
|
||||||
Name: silicon
|
Name: silicon
|
||||||
Version: 1.8.1
|
Version: 2.0.0.20200531git.43b2621
|
||||||
Release: 2mamba
|
Release: 1mamba
|
||||||
Summary: Silicon Empire is set of tools to Burn, Copy, Backup, Manage and more, your optical discs like CDs, DVDs and Blu-Rays
|
Summary: Silicon Empire is set of tools to Burn, Copy, Backup, Manage and more, your optical discs like CDs, DVDs and Blu-Rays
|
||||||
Group: Graphical Desktop/Applications/Utilities
|
Group: Graphical Desktop/Applications/Utilities
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Ercole 'ercolinux' Carpanetto <ercole69@gmail.com>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://getsilicon.org/
|
URL: https://github.com/realbardia/silicon
|
||||||
Source: http://getsilicon.org/download/silicon-%{version}-src.tar.gz
|
Source: https://github.com/realbardia/silicon.git/master@%{gittag}/silicon-%{version}.tar.bz2
|
||||||
|
#Source: http://getsilicon.org/download/silicon-%{version}-src.tar.gz
|
||||||
Patch0: silicon-1.8.1-gcc-5.3.patch
|
Patch0: silicon-1.8.1-gcc-5.3.patch
|
||||||
|
Patch1: silicon-2.0.0.20200531git.43b2621-gcc-12.2.0.patch
|
||||||
|
Patch2: silicon-2.0.0.20200531git.43b2621-missing_QPainterPath_include.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libphonon-devel
|
BuildRequires: libglvnd-devel
|
||||||
BuildRequires: libqt4-devel
|
|
||||||
BuildRequires: libQtDeclarative
|
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libtag-devel
|
BuildRequires: libtag-devel
|
||||||
|
BuildRequires: qt5-qtbase-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libtag-devel >= 1.9.1
|
BuildRequires: libtag-devel >= 1.9.1
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Silicon Empire is set of tools to Burn, Copy, Backup, Manage and … your optical discs like CDs, DVDs and Blu-Rays. When you start working with silicon Empire Just feels everything done easily and quickly with high quality. You Burn, Copy, Mount and … your discs in few clicks and short time
|
Silicon Empire is set of tools to Burn, Copy, Backup, Manage and … your optical discs like CDs, DVDs and Blu-Rays. When you start working with silicon Empire Just feels everything done easily and quickly with high quality. You Burn, Copy, Mount and … your discs in few clicks and short time
|
||||||
|
|
||||||
|
%global __provides_exclude_from ^%{_libdir}/%{name}/.*$
|
||||||
|
|
||||||
|
# Don't clean build at the end
|
||||||
|
%global __spec_rmbuild_cmd /bin/true
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}-src
|
%setup -q
|
||||||
%patch0 -p1
|
#-D -T
|
||||||
|
#:<< _EOF
|
||||||
|
#%patch0 -p1
|
||||||
|
%patch1 -p1 -b .gcc-12.2.0
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -d build
|
#:<< _EOF
|
||||||
%make
|
%_qt5_qmake
|
||||||
|
|
||||||
|
%make -j1
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall -C build
|
|
||||||
|
install -d -m0755 %{buildroot}%{_libdir}
|
||||||
|
|
||||||
|
cp -Rp ../build/lib/* %{buildroot}%{_libdir}
|
||||||
|
cp -Rp ../build/bin %{buildroot}%{_prefix}
|
||||||
|
cp -Rp ../build/share %{buildroot}%{_prefix}
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}/%{_datadir}/pixmaps/
|
||||||
|
mv %{buildroot}/usr/share/silicon/icons/silicon.png %{buildroot}/%{_datadir}/pixmaps/
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}/%{_datadir}/applications
|
||||||
|
cp Silicon/files/Silicon.desktop %{buildroot}/%{_datadir}/applications/silicon.desktop
|
||||||
|
|
||||||
|
#rm -f %{buildroot}%{_libdir}/%{name}/plugins/libSingleInnerDialogQML.so
|
||||||
|
#rm -f %{buildroot}%{_libdir}/%{name}/plugins/libHal*
|
||||||
|
|
||||||
|
#rm -f %{buildroot}%{_libdir}/%{name}/plugins/libmpg321*
|
||||||
|
|
||||||
|
rm -f %{buildroot}%{_libdir}/libsdatabase.so
|
||||||
|
rm -f %{buildroot}%{_libdir}/libsidi.so
|
||||||
|
rm -f %{buildroot}%{_libdir}/libsilicon.so
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
@ -46,9 +79,13 @@ Silicon Empire is set of tools to Burn, Copy, Backup, Manage and … your optica
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/silicon
|
%{_bindir}/silicon
|
||||||
%{_bindir}/silicon_rootmount
|
%{_bindir}/silicon_rootmount
|
||||||
%{_libdir}/*.so
|
%{_libdir}/libsdatabase.so.*
|
||||||
%{_libdir}/silicon/apps/*.so
|
%{_libdir}/libsidi.so.*
|
||||||
%{_libdir}/silicon/plugins/*.so
|
%{_libdir}/libsilicon.so.*
|
||||||
|
%dir %{_libdir}/silicon
|
||||||
|
%dir %{_libdir}/silicon/apps
|
||||||
|
%{_libdir}/silicon/apps/lib*.so*
|
||||||
|
%{_libdir}/silicon/plugins/lib*.so*
|
||||||
%{_datadir}/applications/silicon.desktop
|
%{_datadir}/applications/silicon.desktop
|
||||||
%{_datadir}/pixmaps/silicon.png
|
%{_datadir}/pixmaps/silicon.png
|
||||||
%{_datadir}/silicon/languages/*.qm
|
%{_datadir}/silicon/languages/*.qm
|
||||||
@ -57,6 +94,9 @@ Silicon Empire is set of tools to Burn, Copy, Backup, Manage and … your optica
|
|||||||
%doc COPYING COPYING.LESSER
|
%doc COPYING COPYING.LESSER
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 13 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.0.20200531git.43b2621-1mamba
|
||||||
|
- update to 2.0.0.20200531git.43b2621
|
||||||
|
|
||||||
* Tue Dec 29 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.1-2mamba
|
* Tue Dec 29 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.1-2mamba
|
||||||
- mass rebuild with libtag 1.9.1
|
- mass rebuild with libtag 1.9.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user