automatic version update by autodist [release 3.10.2-1mamba;Wed Jan 08 2014]
This commit is contained in:
parent
500c4fed56
commit
8dcd42b9ca
@ -1,2 +1,7 @@
|
||||
# seahorse
|
||||
|
||||
Seahorse is a graphical interface for managing and using encryption keys.
|
||||
Currently it supports PGP keys (using GPG/GPGME) and SSH keys. Its goal is to provide an easy to use Key Management Tool, along with an easy to use interface for encryption operations.
|
||||
|
||||
Seahorse is integrated into the GNOME Desktop Environment and allows users to perform operations from their regular applications, like nautilus or gedit.
|
||||
|
||||
|
26
seahorse-2.32.0-libnotify-0.7.patch
Normal file
26
seahorse-2.32.0-libnotify-0.7.patch
Normal file
@ -0,0 +1,26 @@
|
||||
--- libseahorse/seahorse-notification.c
|
||||
+++ libseahorse/seahorse-notification.c
|
||||
@@ -37,6 +37,9 @@
|
||||
|
||||
#ifdef HAVE_LIBNOTIFY
|
||||
#include <libnotify/notify.h>
|
||||
+#ifndef NOTIFY_CHECK_VERSION
|
||||
+#define NOTIFY_CHECK_VERSION(x,y,z) 0
|
||||
+#endif
|
||||
#endif
|
||||
|
||||
/* -----------------------------------------------------------------------------
|
||||
@@ -231,7 +234,12 @@
|
||||
heading = format_key_text (snotif->heading);
|
||||
message = format_key_text (snotif->message);
|
||||
|
||||
- notif = notify_notification_new (heading, message, snotif->icon, attachto);
|
||||
+ notif = notify_notification_new (heading, message, snotif->icon
|
||||
+#if NOTIFY_CHECK_VERSION (0, 7, 0)
|
||||
+ );
|
||||
+#else
|
||||
+ , attachto);
|
||||
+#endif
|
||||
|
||||
g_free (heading);
|
||||
g_free (message);
|
14
seahorse-3.4.1-compile.patch
Normal file
14
seahorse-3.4.1-compile.patch
Normal file
@ -0,0 +1,14 @@
|
||||
seahorse-gpgme-keyring.c: In function ‘seahorse_gpgme_keyring_finalize’:
|
||||
seahorse-gpgme-keyring.c:862:1: error: size of array ‘_GStaticAssertCompileTimeAssertion_12’ is negative
|
||||
|
||||
--- origsrc/seahorse-3.4.1/pgp/seahorse-gpgme-keyring.c 2012-01-27 07:50:26.000000000 -0600
|
||||
+++ src/seahorse-3.4.1/pgp/seahorse-gpgme-keyring.c 2012-05-06 04:54:05.214835400 -0500
|
||||
@@ -859,7 +859,7 @@ seahorse_gpgme_keyring_finalize (GObject
|
||||
{
|
||||
SeahorseGpgmeKeyring *self = SEAHORSE_GPGME_KEYRING (object);
|
||||
|
||||
- g_clear_object (self->pv->actions);
|
||||
+ g_clear_object (&self->pv->actions);
|
||||
g_hash_table_destroy (self->pv->keys);
|
||||
|
||||
/* All monitoring and scheduling should be done */
|
190
seahorse.spec
Normal file
190
seahorse.spec
Normal file
@ -0,0 +1,190 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: seahorse
|
||||
Version: 3.10.2
|
||||
Release: 1mamba
|
||||
Summary: A GNOME based graphical interface for managing and using encryption keys
|
||||
Group: Graphical Desktop/Applications/Security
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://live.gnome.org
|
||||
Source: http://ftp.gnome.org/pub/gnome/sources/seahorse/%{majver}/seahorse-%{version}.tar.xz
|
||||
Patch0: %{name}-2.32.0-libnotify-0.7.patch
|
||||
Patch1: %{name}-3.4.1-compile.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libassuan-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libavahi-devel
|
||||
BuildRequires: libavahi-glib-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcr-devel
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgpg-error-devel
|
||||
BuildRequires: libgpgme-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libicu-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libopenldap-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libsasl-devel
|
||||
BuildRequires: libsecret-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libsoup-devel
|
||||
BuildRequires: libsqlite-devel
|
||||
BuildRequires: libssp-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: p11-kit-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libgcr-devel >= %{majver}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Seahorse is a graphical interface for managing and using encryption keys.
|
||||
Currently it supports PGP keys (using GPG/GPGME) and SSH keys. Its goal is to provide an easy to use Key Management Tool, along with an easy to use interface for encryption operations.
|
||||
|
||||
Seahorse is integrated into the GNOME Desktop Environment and allows users to perform operations from their regular applications, like nautilus or gedit.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Development files for %{name}.
|
||||
|
||||
%package apidocs
|
||||
Group: Documentation
|
||||
Summary: %{name} API documentation
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: gtk-doc
|
||||
|
||||
%description apidocs
|
||||
This package includes the %{name} API documentation.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-gtk-doc \
|
||||
--disable-scrollkeeper
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post
|
||||
/sbin/ldconfig
|
||||
if [ $1 -ge 1 ]; then
|
||||
glib-compile-schemas %{_datadir}/glib-2.0/schemas 2>/dev/null
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%postun
|
||||
/sbin/ldconfig
|
||||
if [ $1 -eq 0 ]; then
|
||||
glib-compile-schemas %{_datadir}/glib-2.0/schemas 2>/dev/null
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/seahorse
|
||||
%dir %{_libdir}/seahorse
|
||||
%{_libdir}/seahorse/*
|
||||
%dir %{_datadir}/seahorse
|
||||
%dir %{_datadir}/seahorse/ui
|
||||
%{_datadir}/seahorse/ui/seahorse*
|
||||
%{_datadir}/applications/seahorse.desktop
|
||||
%{_datadir}/dbus-1/services/org.gnome.seahorse.Application.service
|
||||
%{_datadir}/gnome-shell/search-providers/seahorse-search-provider.ini
|
||||
%{_datadir}/GConf/gsettings/org.gnome.seahorse.convert
|
||||
%{_datadir}/GConf/gsettings/org.gnome.seahorse.manager.convert
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.seahorse.gschema.xml
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.seahorse.manager.gschema.xml
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.seahorse.window.gschema.xml
|
||||
#%dir %{_datadir}/omf/seahorse
|
||||
#%{_datadir}/omf/seahorse/*
|
||||
%{_datadir}/seahorse/icons/hicolor/*/apps/*.png
|
||||
%{_datadir}/seahorse/icons/hicolor/*/status/*.png
|
||||
%{_datadir}/icons/hicolor/*/apps/seahorse*.png
|
||||
%dir %{_datadir}/help/*/seahorse
|
||||
%{_datadir}/help/*/seahorse/*
|
||||
%{_mandir}/man1/seahorse*.1*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
#%files devel
|
||||
#%defattr(-,root,root)
|
||||
#%dir %{_includedir}/libcryptui
|
||||
#%{_includedir}/libcryptui/*
|
||||
#%{_libdir}/libcryptui.a
|
||||
#%{_libdir}/libcryptui.la
|
||||
#%{_libdir}/libcryptui.so
|
||||
#%{_libdir}/pkgconfig/cryptui-*.pc
|
||||
#%{_datadir}/gir-1.0/CryptUI-*.gir
|
||||
#%{_libdir}/girepository-1.0/CryptUI-*.typelib
|
||||
#%doc ChangeLog ChangeLog.pre-0.6 ChangeLog.pre-1.0 ChangeLog.pre-auto NEWS README THANKS TODO
|
||||
|
||||
#%files apidocs
|
||||
#%defattr(-,root,root)
|
||||
#%dir %{_datadir}/gtk-doc/html/libcryptui
|
||||
#%{_datadir}/gtk-doc/html/libcryptui/*
|
||||
#%dir %{_datadir}/gtk-doc/html/libseahorse
|
||||
#%{_datadir}/gtk-doc/html/libseahorse/*
|
||||
|
||||
%changelog
|
||||
* Wed Jan 08 2014 Automatic Build System <autodist@mambasoft.it> 3.10.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Oct 30 2013 Automatic Build System <autodist@mambasoft.it> 3.10.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue May 14 2013 Automatic Build System <autodist@mambasoft.it> 3.8.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Apr 16 2013 Automatic Build System <autodist@mambasoft.it> 3.8.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Apr 15 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.8.0-2mamba
|
||||
- rebuilt with libgcr 3.8.0
|
||||
|
||||
* Thu Mar 28 2013 Automatic Build System <autodist@mambasoft.it> 3.8.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Dec 07 2012 Automatic Build System <autodist@mambasoft.it> 3.6.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Oct 16 2012 Automatic Build System <autodist@mambasoft.it> 3.6.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Oct 08 2012 Automatic Build System <autodist@mambasoft.it> 3.6.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Jul 01 2012 Automatic Build System <autodist@mambasoft.it> 3.4.1-1mamba
|
||||
- update to 3.4.1
|
||||
|
||||
* Fri Oct 28 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.32.0-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user