provide required symlink /usr/share/seafile/seafile-server/seahub
patch setup script to fix preparation of avatars directory [release 3.1.12-2mamba;Thu Jan 22 2015]
This commit is contained in:
parent
b61311d262
commit
5b8989a322
12
seafile-3.1.12-setup-fix-avatars.patch
Normal file
12
seafile-3.1.12-setup-fix-avatars.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
--- seafile-3.1.12/scripts/setup-seafile-mysql.py.orig 2015-01-01 21:57:52.000000000 +0100
|
||||||
|
+++ seafile-3.1.12/scripts/setup-seafile-mysql.py 2015-01-22 21:26:27.425379254 +0100
|
||||||
|
@@ -1081,8 +1081,7 @@
|
||||||
|
if not os.path.exists(seahub_data_dir):
|
||||||
|
os.mkdir(seahub_data_dir)
|
||||||
|
|
||||||
|
- shutil.move(orig_avatar_dir, dest_avatar_dir)
|
||||||
|
- os.symlink('../../../seahub-data/avatars', orig_avatar_dir)
|
||||||
|
+ shutil.copytree(orig_avatar_dir, dest_avatar_dir)
|
||||||
|
except Exception, e:
|
||||||
|
Utils.error('Failed to prepare seahub avatars dir: %s' % e)
|
||||||
|
|
11
seafile.spec
11
seafile.spec
@ -2,7 +2,7 @@
|
|||||||
%define seafile_userid 65435
|
%define seafile_userid 65435
|
||||||
Name: seafile
|
Name: seafile
|
||||||
Version: 3.1.12
|
Version: 3.1.12
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: A next-generation open source cloud storage system with advanced support for file syncing
|
Summary: A next-generation open source cloud storage system with advanced support for file syncing
|
||||||
Group: Applications/Web
|
Group: Applications/Web
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -15,6 +15,7 @@ Source1: seafile-seafile.service
|
|||||||
Source2: seafile-seahub.service
|
Source2: seafile-seahub.service
|
||||||
Source3: seafile-client.service
|
Source3: seafile-client.service
|
||||||
Patch0: seafile-3.1.12-delay-start-after-mysql.patch
|
Patch0: seafile-3.1.12-delay-start-after-mysql.patch
|
||||||
|
Patch1: seafile-3.1.12-setup-fix-avatars.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -104,6 +105,7 @@ This package contains python bindings to %{name}.
|
|||||||
%setup -q
|
%setup -q
|
||||||
#-D -T
|
#-D -T
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#:<< ___EOF
|
#:<< ___EOF
|
||||||
@ -139,6 +141,8 @@ for f in ccnet-init ccnet-server; do
|
|||||||
ln -s %{_bindir}/$f %{buildroot}%{_datadir}/seafile/seafile-server/seafile/bin/$f
|
ln -s %{_bindir}/$f %{buildroot}%{_datadir}/seafile/seafile-server/seafile/bin/$f
|
||||||
done
|
done
|
||||||
|
|
||||||
|
ln -s ../seahub %{buildroot}%{_datadir}/seafile/seafile-server/seahub
|
||||||
|
|
||||||
install -d -m0755 %{buildroot}%{_datadir}/seafile/seafile-server/runtime
|
install -d -m0755 %{buildroot}%{_datadir}/seafile/seafile-server/runtime
|
||||||
cp scripts/seahub.conf %{buildroot}%{_datadir}/seafile/seafile-server/runtime/
|
cp scripts/seahub.conf %{buildroot}%{_datadir}/seafile/seafile-server/runtime/
|
||||||
|
|
||||||
@ -210,6 +214,7 @@ fi
|
|||||||
%{_datadir}/seafile/seafile-server/seafile/bin/*
|
%{_datadir}/seafile/seafile-server/seafile/bin/*
|
||||||
%dir %{_datadir}/seafile/seafile-server/seafile/%{_lib}
|
%dir %{_datadir}/seafile/seafile-server/seafile/%{_lib}
|
||||||
#%{_datadir}/seafile/seafile-server/*
|
#%{_datadir}/seafile/seafile-server/*
|
||||||
|
%{_datadir}/seafile/seafile-server/seahub
|
||||||
%dir %{_datadir}/seafile/seafile-server/upgrade
|
%dir %{_datadir}/seafile/seafile-server/upgrade
|
||||||
%{_datadir}/seafile/seafile-server/upgrade/*
|
%{_datadir}/seafile/seafile-server/upgrade/*
|
||||||
%{_unitdir}/seafile.service
|
%{_unitdir}/seafile.service
|
||||||
@ -238,6 +243,10 @@ fi
|
|||||||
%{python_sitearch}/seaserv/*.py*
|
%{python_sitearch}/seaserv/*.py*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 22 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.12-2mamba
|
||||||
|
- provide required symlink /usr/share/seafile/seafile-server/seahub
|
||||||
|
- patch setup script to fix preparation of avatars directory
|
||||||
|
|
||||||
* Thu Jan 01 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.12-1mamba
|
* Thu Jan 01 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.12-1mamba
|
||||||
- update to 3.1.12
|
- update to 3.1.12
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user