automatic version update by autodist [release 9.0.6-1mamba;Tue Jun 25 2024]
This commit is contained in:
parent
e74730369c
commit
2746e2103b
@ -1,19 +0,0 @@
|
||||
--- seafile-3.1.12/scripts/seafile.sh.orig 2015-01-01 22:17:54.549863094 +0100
|
||||
+++ seafile-3.1.12/scripts/seafile.sh 2015-01-01 22:18:16.363850459 +0100
|
||||
@@ -98,14 +98,14 @@
|
||||
validate_already_running;
|
||||
validate_ccnet_conf_dir;
|
||||
read_seafile_data_dir;
|
||||
+
|
||||
+ sleep 3
|
||||
test_config;
|
||||
|
||||
echo "Starting seafile server, please wait ..."
|
||||
|
||||
LD_LIBRARY_PATH=$SEAFILE_LD_LIBRARY_PATH ${seaf_controller} -c "${default_ccnet_conf_dir}" -d "${seafile_data_dir}"
|
||||
|
||||
- sleep 3
|
||||
-
|
||||
# check if seafile server started successfully
|
||||
if ! pgrep -f "seafile-controller -c ${default_ccnet_conf_dir}" 2>/dev/null 1>&2; then
|
||||
echo "Failed to start seafile server"
|
@ -1,12 +0,0 @@
|
||||
--- seafile-3.1.12/scripts/setup-seafile-mysql.py.orig 2015-01-01 21:57:52.000000000 +0100
|
||||
+++ seafile-3.1.12/scripts/setup-seafile-mysql.py 2015-01-22 21:26:27.425379254 +0100
|
||||
@@ -1081,8 +1081,7 @@
|
||||
if not os.path.exists(seahub_data_dir):
|
||||
os.mkdir(seahub_data_dir)
|
||||
|
||||
- shutil.move(orig_avatar_dir, dest_avatar_dir)
|
||||
- os.symlink('../../../seahub-data/avatars', orig_avatar_dir)
|
||||
+ shutil.copytree(orig_avatar_dir, dest_avatar_dir)
|
||||
except Exception, e:
|
||||
Utils.error('Failed to prepare seahub avatars dir: %s' % e)
|
||||
|
@ -1,30 +0,0 @@
|
||||
--- seafile-5.0.5/controller/seafile-controller.c.orig 2016-04-08 18:41:39.000000000 +0200
|
||||
+++ seafile-5.0.5/controller/seafile-controller.c 2016-04-17 14:06:00.685984507 +0200
|
||||
@@ -320,7 +320,8 @@
|
||||
g_setenv ("SEAFILE_CENTRAL_CONF_DIR", ctl->central_config_dir, TRUE);
|
||||
|
||||
char *seahub_dir = g_build_filename (installpath, "seahub", NULL);
|
||||
- char *seafdav_conf = g_build_filename (topdir, "conf", "seafdav.conf", NULL);
|
||||
+ char *seafdav_conf = g_build_filename (ctl->central_config_dir, "seafdav.conf", NULL);
|
||||
+
|
||||
g_setenv ("SEAHUB_DIR", seahub_dir, TRUE);
|
||||
g_setenv ("SEAFDAV_CONF", seafdav_conf, TRUE);
|
||||
|
||||
@@ -575,7 +576,7 @@
|
||||
static void
|
||||
init_pidfile_path (SeafileController *ctl)
|
||||
{
|
||||
- char *pid_dir = g_build_filename (topdir, "pids", NULL);
|
||||
+ char *pid_dir = g_build_filename (ctl->seafile_dir, "pids", NULL);
|
||||
if (!g_file_test(pid_dir, G_FILE_TEST_EXISTS)) {
|
||||
if (g_mkdir(pid_dir, 0777) < 0) {
|
||||
seaf_warning("failed to create pid dir %s: %s", pid_dir, strerror(errno));
|
||||
@@ -788,7 +789,7 @@
|
||||
GKeyFile *key_file = NULL;
|
||||
GError *error = NULL;
|
||||
|
||||
- seafdav_conf = g_build_filename(topdir, "conf", "seafdav.conf", NULL);
|
||||
+ seafdav_conf = g_build_filename (ctl->central_config_dir, "seafdav.conf", NULL);
|
||||
if (!g_file_test(seafdav_conf, G_FILE_TEST_EXISTS)) {
|
||||
goto out;
|
||||
}
|
22
seafile-9.0.6-gcc-14.1.patch
Normal file
22
seafile-9.0.6-gcc-14.1.patch
Normal file
@ -0,0 +1,22 @@
|
||||
From 34e743ffb6d8d01ea7d2669037f70fec53e4e54a Mon Sep 17 00:00:00 2001
|
||||
From: Joffrey <j-off@live.fr>
|
||||
Date: Thu, 23 May 2024 13:52:58 +0200
|
||||
Subject: [PATCH] GCC 14.1: Fix incompatible pointer type
|
||||
|
||||
---
|
||||
daemon/repo-mgr.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/daemon/repo-mgr.c b/daemon/repo-mgr.c
|
||||
index 8be4f04b6..f970abf01 100644
|
||||
--- a/daemon/repo-mgr.c
|
||||
+++ b/daemon/repo-mgr.c
|
||||
@@ -4885,7 +4885,7 @@ check_case_conflict (const char *path1, const char *path2, char **conflict_path)
|
||||
// Since file creation is asynchronous, the file may not have been created locally at the time of checking for case conflicts,
|
||||
// so an additional check for the name of the file being created is required.
|
||||
static gboolean
|
||||
-is_adding_files_case_conflict (GList **adding_files, const char *name, const char **conflict_path)
|
||||
+is_adding_files_case_conflict (GList **adding_files, const char *name, char **conflict_path)
|
||||
{
|
||||
GList *ptr;
|
||||
SeafStat st;
|
24
seafile.spec
24
seafile.spec
@ -4,7 +4,7 @@
|
||||
%define maj2_version %(echo %version | cut -d. -f1-2)
|
||||
%define MAJver %(echo %version | cut -d. -f1)
|
||||
Name: seafile
|
||||
Version: 9.0.5
|
||||
Version: 9.0.6
|
||||
Release: 1mamba
|
||||
Summary: A next-generation open source cloud storage system with advanced support for file syncing
|
||||
Group: Applications/Web
|
||||
@ -14,9 +14,7 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.seafile.com/en/home/
|
||||
Source: https://github.com/haiwen/seafile.git/v%{version}/seafile-%{version}.tar.bz2
|
||||
Source3: seafile-client.service
|
||||
Patch0: seafile-3.1.12-delay-start-after-mysql.patch
|
||||
Patch1: seafile-3.1.12-setup-fix-avatars.patch
|
||||
Patch2: seafile-5.0.5-instance_dir.patch
|
||||
Patch0: seafile-9.0.6-gcc-14.1.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -26,7 +24,7 @@ BuildRequires: libevent-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libjansson-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpython310-devel
|
||||
BuildRequires: libpython311-devel
|
||||
BuildRequires: libsearpc-devel
|
||||
BuildRequires: libsqlite-devel
|
||||
BuildRequires: libuuid-devel
|
||||
@ -79,16 +77,15 @@ This package contains python bindings to %{name}.
|
||||
%setup -q
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
#%patch2 -p1
|
||||
%patch 0 -p1 -b .gcc-14.1
|
||||
|
||||
./autogen.sh
|
||||
|
||||
%build
|
||||
#:<< ___EOF
|
||||
%configure \
|
||||
--enable-console \
|
||||
PYTHON=%{__python310}
|
||||
PYTHON=%{__python3}
|
||||
|
||||
# --enable-breakpad
|
||||
|
||||
@ -130,11 +127,14 @@ install -D -m0644 %{SOURCE3} %{buildroot}%{_unitdir}/seafile-client.service
|
||||
|
||||
%files -n python-%{name}
|
||||
%defattr(-,root,root)
|
||||
%dir %{python310_sitearch}/seafile
|
||||
%{python310_sitearch}/seafile/*.py*
|
||||
%{python310_sitearch}/seafile/__pycache__/*.py*
|
||||
%dir %{python3_sitearch}/seafile
|
||||
%{python3_sitearch}/seafile/*.py*
|
||||
%{python3_sitearch}/seafile/__pycache__/*.py*
|
||||
|
||||
%changelog
|
||||
* Tue Jun 25 2024 Automatic Build System <autodist@openmamba.org> 9.0.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Feb 28 2024 Automatic Build System <autodist@openmamba.org> 9.0.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user