rebuilt with qt6 [release 9.0.5-2mamba;Sat Mar 30 2024]
This commit is contained in:
parent
98dcf69850
commit
93c5f5dc6a
@ -1,13 +0,0 @@
|
|||||||
--- seafile-client-4.4.2/src/seafile-applet.cpp.orig 2016-03-08 13:28:23.124439314 +0100
|
|
||||||
+++ seafile-client-4.4.2/src/seafile-applet.cpp 2016-03-08 13:28:36.250436044 +0100
|
|
||||||
@@ -410,10 +410,6 @@
|
|
||||||
configurator_->installCustomUrlHandler();
|
|
||||||
#endif
|
|
||||||
|
|
||||||
- if (settings_mgr_->isCheckLatestVersionEnabled()) {
|
|
||||||
- checkLatestVersionInfo();
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
OpenLocalHelper::instance()->checkPendingOpenLocalRequest();
|
|
||||||
|
|
||||||
QTimer::singleShot(kIntervalForUpdateRepoProperty,
|
|
@ -1,20 +0,0 @@
|
|||||||
--- seafile-client-6.0.7/src/utils/utils.cpp.orig 2017-07-12 17:02:33.804293399 +0200
|
|
||||||
+++ seafile-client-6.0.7/src/utils/utils.cpp 2017-07-12 17:03:05.801440950 +0200
|
|
||||||
@@ -468,7 +468,7 @@
|
|
||||||
} else if (json_is_string(value)) {
|
|
||||||
v = QString::fromUtf8(json_string_value(value));
|
|
||||||
} else if (json_is_integer(value)) {
|
|
||||||
- v = json_integer_value(value);
|
|
||||||
+ v = QVariant::fromValue(json_integer_value(value));
|
|
||||||
} else if (json_is_real(value)) {
|
|
||||||
v = json_real_value(value);
|
|
||||||
} else if (json_is_boolean(value)) {
|
|
||||||
@@ -510,7 +510,7 @@
|
|
||||||
} else if (json_is_string(value)) {
|
|
||||||
v = QString::fromUtf8(json_string_value(value));
|
|
||||||
} else if (json_is_integer(value)) {
|
|
||||||
- v = json_integer_value(value);
|
|
||||||
+ v = QVariant::fromValue(json_integer_value(value));
|
|
||||||
} else if (json_is_real(value)) {
|
|
||||||
v = json_real_value(value);
|
|
||||||
} else if (json_is_boolean(value)) {
|
|
21
seafile-client-9.0.5-qt6-6.6.3.patch
Normal file
21
seafile-client-9.0.5-qt6-6.6.3.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
|
index fd16f046..5c195178 100644
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -133,14 +133,14 @@ ENDIF()
|
||||||
|
####################
|
||||||
|
###### BEGIN: QT configuration
|
||||||
|
####################
|
||||||
|
-FIND_PROGRAM(qmake_executable NAMES qmake qmake.exe)
|
||||||
|
+FIND_PROGRAM(qmake_executable NAMES qmake-qt6)
|
||||||
|
EXECUTE_PROCESS(COMMAND
|
||||||
|
bash -c "${qmake_executable} --version | grep -iE '^using qt version [0-9.]+' | awk '{print $4}'"
|
||||||
|
OUTPUT_VARIABLE DETECTED_QT_VERSION
|
||||||
|
OUTPUT_STRIP_TRAILING_WHITESPACE)
|
||||||
|
MESSAGE("Qt version: ${DETECTED_QT_VERSION}")
|
||||||
|
EXECUTE_PROCESS(COMMAND
|
||||||
|
- bash -c "qmake --version|grep -iE '^using qt version [0-9]'|awk '{print $4}'|grep -iE '^[0-9]'|awk -F . '{print $1}'"
|
||||||
|
+ bash -c "${qmake_executable} --version|grep -iE '^using qt version [0-9]'|awk '{print $4}'|grep -iE '^[0-9]'|awk -F . '{print $1}'"
|
||||||
|
OUTPUT_VARIABLE QT_VERSION_MAJOR
|
||||||
|
OUTPUT_STRIP_TRAILING_WHITESPACE)
|
||||||
|
MESSAGE("QT_VERSION_MAJOR: ${QT_VERSION_MAJOR}")
|
@ -1,7 +1,7 @@
|
|||||||
%define majver %(echo %version | cut -d. -f1-2)
|
%define majver %(echo %version | cut -d. -f1-2)
|
||||||
Name: seafile-client
|
Name: seafile-client
|
||||||
Version: 9.0.5
|
Version: 9.0.5
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: Seafile desktop client
|
Summary: Seafile desktop client
|
||||||
Group: Graphical Desktop/Applications/Archiving
|
Group: Graphical Desktop/Applications/Archiving
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -9,14 +9,14 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://www.seafile.com/en/home/
|
URL: https://www.seafile.com/en/home/
|
||||||
Source: https://github.com/haiwen/seafile-client.git/v%{version}/seafile-client-%{version}.tar.bz2
|
Source: https://github.com/haiwen/seafile-client.git/v%{version}/seafile-client-%{version}.tar.bz2
|
||||||
Patch0: seafile-client-4.4.2-disable-latest-version-check.patch
|
Patch1: seafile-client-9.0.5-qt6-6.6.3.patch
|
||||||
Patch1: seafile-client-6.0.7-qt5-5.7.1.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libevent-devel
|
BuildRequires: libevent-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libglib-devel
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libglvnd-devel
|
||||||
BuildRequires: libjansson-devel
|
BuildRequires: libjansson-devel
|
||||||
BuildRequires: libopenssl-devel
|
BuildRequires: libopenssl-devel
|
||||||
BuildRequires: libseafile-devel
|
BuildRequires: libseafile-devel
|
||||||
@ -24,7 +24,8 @@ BuildRequires: libsearpc-devel
|
|||||||
BuildRequires: libsqlite-devel
|
BuildRequires: libsqlite-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
BuildRequires: qt5-qtbase-devel
|
BuildRequires: qt6-qt5compat-devel
|
||||||
|
BuildRequires: qt6-qtbase-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
Requires: seafile >= %majver
|
Requires: seafile >= %majver
|
||||||
@ -36,16 +37,11 @@ Seafile desktop client.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1
|
|
||||||
%patch 1 -p1
|
%patch 1 -p1
|
||||||
sed -i "s| qmake | qmake-qt5 |" CMakeLists.txt
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake
|
%cmake
|
||||||
|
|
||||||
#\
|
|
||||||
# -DCMAKE_CXX_FLAGS="-fuse-ld=gold"
|
|
||||||
|
|
||||||
%cmake_build
|
%cmake_build
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -66,6 +62,9 @@ sed -i "s| qmake | qmake-qt5 |" CMakeLists.txt
|
|||||||
#%doc README.md
|
#%doc README.md
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Mar 30 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 9.0.5-2mamba
|
||||||
|
- rebuilt with qt6
|
||||||
|
|
||||||
* Wed Feb 28 2024 Automatic Build System <autodist@openmamba.org> 9.0.5-1mamba
|
* Wed Feb 28 2024 Automatic Build System <autodist@openmamba.org> 9.0.5-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user