update to 6.0.7 [release 6.0.7-1mamba;Wed Jul 12 2017]

This commit is contained in:
Silvan Calarco 2024-01-05 17:43:32 +01:00
parent 068563d3e2
commit 099bf8f41e
2 changed files with 31 additions and 4 deletions

View File

@ -0,0 +1,20 @@
--- seafile-client-6.0.7/src/utils/utils.cpp.orig 2017-07-12 17:02:33.804293399 +0200
+++ seafile-client-6.0.7/src/utils/utils.cpp 2017-07-12 17:03:05.801440950 +0200
@@ -468,7 +468,7 @@
} else if (json_is_string(value)) {
v = QString::fromUtf8(json_string_value(value));
} else if (json_is_integer(value)) {
- v = json_integer_value(value);
+ v = QVariant::fromValue(json_integer_value(value));
} else if (json_is_real(value)) {
v = json_real_value(value);
} else if (json_is_boolean(value)) {
@@ -510,7 +510,7 @@
} else if (json_is_string(value)) {
v = QString::fromUtf8(json_string_value(value));
} else if (json_is_integer(value)) {
- v = json_integer_value(value);
+ v = QVariant::fromValue(json_integer_value(value));
} else if (json_is_real(value)) {
v = json_real_value(value);
} else if (json_is_boolean(value)) {

View File

@ -1,5 +1,6 @@
%define majver %(echo %version | cut -d. -f1-2)
Name: seafile-client
Version: 5.0.7
Version: 6.0.7
Release: 1mamba
Summary: Seafile desktop client
Group: Graphical Desktop/Applications/Archiving
@ -10,6 +11,7 @@ URL: http://seafile.com
## GITSOURCE https://github.com/haiwen/seafile-client.git v3.1.5
Source: https://github.com/haiwen/seafile-client.git/v%{version}/seafile-client-%{version}.tar.bz2
Patch0: seafile-client-4.4.2-disable-latest-version-check.patch
Patch1: seafile-client-6.0.7-qt5-5.7.1.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -19,7 +21,7 @@ BuildRequires: libgcc
BuildRequires: libglib-devel
BuildRequires: libjansson-devel
BuildRequires: libopenssl-devel
BuildRequires: libqt4-devel
BuildRequires: libqt5-devel
BuildRequires: libseafile-devel
BuildRequires: libsearpc-devel
BuildRequires: libsqlite-devel
@ -27,7 +29,7 @@ BuildRequires: libstdc++6-devel
BuildRequires: libuuid-devel
## AUTOBUILDREQ-END
BuildRequires: cmake
Requires: seafile >= 4.4.6
Requires: seafile >= %majver
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
@ -37,7 +39,9 @@ Seafile desktop client.
%prep
%setup -q
%patch0 -p1
#%patch0 -p1
%patch1 -p1
sed -i "s| qmake | qmake-qt5 |" CMakeLists.txt
%build
%cmake
@ -61,6 +65,9 @@ Seafile desktop client.
#%doc README.md
%changelog
* Wed Jul 12 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 6.0.7-1mamba
- update to 6.0.7
* Fri Apr 08 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 5.0.7-1mamba
- update to 5.0.7