automatic rebuild by autodist [release 0.9.3-2mamba;Tue Aug 27 2013]
This commit is contained in:
parent
ad10931439
commit
25b132520d
@ -1,2 +1,4 @@
|
|||||||
# scythia
|
# scythia
|
||||||
|
|
||||||
|
Scythia is a simple and portable Ftp client.
|
||||||
|
|
||||||
|
43
scythia-0.9.2-fix.patch
Normal file
43
scythia-0.9.2-fix.patch
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
diff -ruN -F'^f' scythia.orig/compil scythia/compil
|
||||||
|
--- scythia.orig/compil 2007-07-05 13:15:26.000000000 +0200
|
||||||
|
+++ scythia/compil 2007-08-26 10:23:41.000000000 +0200
|
||||||
|
@@ -21,13 +21,13 @@ for fichier in *.html; do
|
||||||
|
echo "################# COMPIL ##################"
|
||||||
|
cd ../../
|
||||||
|
if [ "$1" == "debug" ] ; then
|
||||||
|
- qmake-qt4 "CONFIG+=debug_and_release" scythia.pro
|
||||||
|
+ qmake4 "CONFIG+=debug_and_release" scythia.pro
|
||||||
|
else
|
||||||
|
- qmake-qt4 scythia.pro
|
||||||
|
+ qmake4 scythia.pro
|
||||||
|
fi
|
||||||
|
|
||||||
|
-lupdate-qt4 scythia.pro
|
||||||
|
-lrelease-qt4 scythia.pro
|
||||||
|
+lupdate4 scythia.pro
|
||||||
|
+lrelease4 scythia.pro
|
||||||
|
make clean
|
||||||
|
-make $1
|
||||||
|
+make "$@"
|
||||||
|
|
||||||
|
diff -ruN -F'^f' scythia.orig/src/scythia.cpp scythia/src/scythia.cpp
|
||||||
|
--- scythia.orig/src/scythia.cpp 2007-07-05 19:08:41.000000000 +0200
|
||||||
|
+++ scythia/src/scythia.cpp 2007-08-26 10:24:09.000000000 +0200
|
||||||
|
@@ -32,7 +32,7 @@
|
||||||
|
|
||||||
|
// Create the tray icon
|
||||||
|
trayIcon = new QSystemTrayIcon(this);
|
||||||
|
- trayIcon->setIcon(QIcon(":pixmaps/network.png"));
|
||||||
|
+ trayIcon->setIcon(QIcon(":pixmaps/scythia.png"));
|
||||||
|
trayIcon->setToolTip("Scythia");
|
||||||
|
trayIcon->setContextMenu(menu);
|
||||||
|
|
||||||
|
@@ -117,6 +117,8 @@
|
||||||
|
listProgs = QString(conf.readAll());
|
||||||
|
conf.close();
|
||||||
|
}
|
||||||
|
+ else
|
||||||
|
+ listProgs = QString("xdg-open\nxdg-open\nxdg-open\nxdg-open\nxdg-open\nxdg-open\n");
|
||||||
|
|
||||||
|
connect(ftpList, SIGNAL(buttonClicked(QTreeWidgetItem *)),
|
||||||
|
SLOT(slotFtpSelection(QTreeWidgetItem *)));
|
23
scythia-desktop
Normal file
23
scythia-desktop
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
[Desktop Entry]
|
||||||
|
Comment=A simple FTP client
|
||||||
|
Comment[fr]=Un client FTP relativement simple
|
||||||
|
Comment[it]=Un client FTP relativamente semplice
|
||||||
|
Encoding=UTF-8
|
||||||
|
Exec=scythia
|
||||||
|
GenericName=
|
||||||
|
GenericName[fr]=
|
||||||
|
GenericName[it]=Client FTP
|
||||||
|
Icon=scythia
|
||||||
|
MimeType=
|
||||||
|
Name=Scythia - FTP Client
|
||||||
|
Name[fr]=Scythia - Client FTP
|
||||||
|
Name[it]=Scythia
|
||||||
|
Path=
|
||||||
|
StartupNotify=true
|
||||||
|
Terminal=false
|
||||||
|
TerminalOptions=
|
||||||
|
Type=Application
|
||||||
|
X-DCOP-ServiceType=
|
||||||
|
X-KDE-SubstituteUID=false
|
||||||
|
X-KDE-Username=
|
||||||
|
Categories=Application;Network;
|
96
scythia.spec
Normal file
96
scythia.spec
Normal file
@ -0,0 +1,96 @@
|
|||||||
|
Name: scythia
|
||||||
|
Version: 0.9.3
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: A simple and portable Ftp client
|
||||||
|
Group: Graphical Desktop/Applications/Networking
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
|
||||||
|
URL: http://scythia.free.fr
|
||||||
|
Source: http://scythia.free.fr/wp-content/scythia_%{version}-2-src.tar.gz
|
||||||
|
Source1: %{name}-desktop
|
||||||
|
Patch0: %{name}-0.9.2-fix.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libfontconfig-devel
|
||||||
|
BuildRequires: libfreetype-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libICE-devel
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libqt4-devel
|
||||||
|
BuildRequires: libSM-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXext-devel
|
||||||
|
BuildRequires: libXfixes-devel
|
||||||
|
BuildRequires: libXinerama-devel
|
||||||
|
BuildRequires: libXrandr-devel
|
||||||
|
BuildRequires: libXrender-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Scythia is a simple and portable Ftp client.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{name}
|
||||||
|
%patch0 -p1
|
||||||
|
#rm -f translations/*.qm
|
||||||
|
cp -f src/pixmaps/%{name}_logo.png src/pixmaps/%{name}.png
|
||||||
|
chmod a-x AUTHORS COPYING
|
||||||
|
|
||||||
|
%build
|
||||||
|
#./compil \
|
||||||
|
# CXX=%{_target_platform}-g++ \
|
||||||
|
# CXXFLAGS="%{optflags} \$(DEFINES)"
|
||||||
|
%{_bindir}/qmake-qt4 scythia.pro
|
||||||
|
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall INSTALL_ROOT=%{buildroot} INSTALL="install -p"
|
||||||
|
|
||||||
|
rm %{buildroot}%{_docdir}/scythia/html/aide_8h-source.html
|
||||||
|
rm %{buildroot}%{_datadir}/applnk -rf
|
||||||
|
|
||||||
|
#install -d %{buildroot}%{_datadir}/%{name}/lang
|
||||||
|
#install -D -m 644 translations/*.qm \
|
||||||
|
# %{buildroot}%{_datadir}/%{name}/lang
|
||||||
|
|
||||||
|
install -D -m 644 %{S:1} \
|
||||||
|
%{buildroot}%{_datadir}/applications/%{name}.desktop
|
||||||
|
install -D -m 644 src/pixmaps/%{name}.png \
|
||||||
|
%{buildroot}%{_datadir}/pixmaps/%{name}.png
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/%{name}
|
||||||
|
%dir %{_datadir}/%{name}
|
||||||
|
%{_datadir}/%{name}/lang/*.qm
|
||||||
|
%{_datadir}/applications/%{name}.desktop
|
||||||
|
%{_datadir}/icons/hicolor/128x128/apps/%{name}.png
|
||||||
|
%{_datadir}/pixmaps/%{name}.xpm
|
||||||
|
%{_datadir}/pixmaps/%{name}.png
|
||||||
|
%dir %{_docdir}/scythia/html
|
||||||
|
%doc %{_docdir}/scythia/html/*.html
|
||||||
|
%doc %{_docdir}/scythia/html/*.png
|
||||||
|
%doc %{_docdir}/scythia/html/*.css
|
||||||
|
%doc %{_docdir}/scythia/html/tab_*.gif
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Aug 27 2013 Automatic Build System <autodist@mambasoft.it> 0.9.3-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Fri Sep 19 2008 gil <puntogil@libero.it> 0.9.3-1mamba
|
||||||
|
- update to 0.9.3
|
||||||
|
|
||||||
|
* Sat Aug 25 2007 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 0.9.2-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user