remove build of qt3 and qt4 immodules [release 1.4.18-3mamba;Tue Feb 13 2024]
This commit is contained in:
parent
08068753c7
commit
967fc50e2c
@ -1,19 +0,0 @@
|
|||||||
commit 88fbabed7dc236642021f8263f1b25bf67c6806e
|
|
||||||
Author: Tz-Huan Huang <tzhuan@gmail.com>
|
|
||||||
Date: Fri Oct 24 13:12:32 2014 +0800
|
|
||||||
|
|
||||||
Disable subdir-objects
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 3d89eb1..f3901ba 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -78,7 +78,7 @@ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [The gettext domain])
|
|
||||||
###########################################################
|
|
||||||
|
|
||||||
# Init automake stuff
|
|
||||||
-AM_INIT_AUTOMAKE([subdir-objects])
|
|
||||||
+AM_INIT_AUTOMAKE([])
|
|
||||||
AM_CONFIG_HEADER([config.h])
|
|
||||||
|
|
||||||
# Init libtool
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -Nru scim-1.4.9.orig/src/ltdl.cpp scim-1.4.9/src/ltdl.cpp
|
|
||||||
--- scim-1.4.9.orig/src/ltdl.cpp 2008-11-02 07:42:40.000000000 +0100
|
|
||||||
+++ scim-1.4.9/src/ltdl.cpp 2009-06-15 02:09:57.000000000 +0200
|
|
||||||
@@ -3373,7 +3373,7 @@
|
|
||||||
assert (filename);
|
|
||||||
|
|
||||||
len = LT_STRLEN (filename);
|
|
||||||
- ext = strrchr (filename, '.');
|
|
||||||
+ ext = strrchr ((char*)filename, '.');
|
|
||||||
|
|
||||||
/* If FILENAME already bears a suitable extension, there is no need
|
|
||||||
to try appending additional extensions. */
|
|
45
scim.spec
45
scim.spec
@ -2,51 +2,37 @@
|
|||||||
%define apiver %{majver}.0
|
%define apiver %{majver}.0
|
||||||
Name: scim
|
Name: scim
|
||||||
Version: 1.4.18
|
Version: 1.4.18
|
||||||
Release: 2mamba
|
Release: 3mamba
|
||||||
Summary: A user friendly, full featured input method user interface and more
|
Summary: A user friendly, full featured input method user interface and more
|
||||||
Group: System/Tools
|
Group: System/Tools
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.scim-im.org/
|
URL: https://adaptationsny.com/
|
||||||
Source: https://github.com/scim-im/scim.git/%{version}/scim-%{version}.tar.bz2
|
Source: https://github.com/scim-im/scim.git/%{version}/scim-%{version}.tar.bz2
|
||||||
#Source: http://downloads.sourceforge.net/project/scim/scim/%{version}/scim-%{version}.tar.gz
|
|
||||||
Source1: scim-xprofile
|
Source1: scim-xprofile
|
||||||
Source2: scim-sysconfig
|
Source2: scim-sysconfig
|
||||||
Patch0: %{name}-1.4.9-gcc44.patch
|
|
||||||
Patch1: scim-1.4.14-libgtk-3.20.0.patch
|
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: ldconfig
|
|
||||||
BuildRequires: libX11-devel
|
BuildRequires: libX11-devel
|
||||||
BuildRequires: libXau-devel
|
BuildRequires: libat-spi2-core-devel
|
||||||
BuildRequires: libXdmcp-devel
|
|
||||||
BuildRequires: libatk-devel
|
|
||||||
BuildRequires: libbzip2-devel
|
|
||||||
BuildRequires: libcairo-devel
|
BuildRequires: libcairo-devel
|
||||||
BuildRequires: libexpat-devel
|
|
||||||
BuildRequires: libfontconfig-devel
|
BuildRequires: libfontconfig-devel
|
||||||
BuildRequires: libfreetype-devel
|
BuildRequires: libfreetype-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libgdk-pixbuf-devel
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
BuildRequires: libglib-devel
|
BuildRequires: libglib-devel
|
||||||
BuildRequires: libgraphite2-devel
|
|
||||||
BuildRequires: libgtk-devel
|
|
||||||
BuildRequires: libgtk2-devel
|
BuildRequires: libgtk2-devel
|
||||||
|
BuildRequires: libgtk3-devel
|
||||||
BuildRequires: libharfbuzz-devel
|
BuildRequires: libharfbuzz-devel
|
||||||
BuildRequires: libltdl-devel
|
BuildRequires: libltdl-devel
|
||||||
BuildRequires: libpango-devel
|
BuildRequires: libpango-devel
|
||||||
BuildRequires: libpng-devel
|
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libxcb-devel
|
|
||||||
BuildRequires: libz-devel
|
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
%ifnarch aarch64
|
%ifnarch aarch64
|
||||||
BuildRequires: libqt4-devel
|
BuildRequires: libqt4-devel
|
||||||
BuildRequires: libqt3-devel
|
|
||||||
%endif
|
%endif
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The Smart Common Input Method (SCIM) platform project provides not only a user friendly, full featured input method user interface for POSIX-style operating systems (including Linux, FreeBSD and other Unix), but also a development platform to make input method development easier.
|
The Smart Common Input Method (SCIM) platform project provides not only a user friendly, full featured input method user interface for POSIX-style operating systems (including Linux, FreeBSD and other Unix), but also a development platform to make input method development easier.
|
||||||
@ -71,12 +57,13 @@ This package contains static libraries and header files need for development.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1
|
|
||||||
#%patch1 -p1
|
|
||||||
./bootstrap
|
./bootstrap
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-static \
|
%configure \
|
||||||
|
--disable-static \
|
||||||
|
--disable-qt3-immodule \
|
||||||
|
--disable-qt4-immodule \
|
||||||
%ifarch arm
|
%ifarch arm
|
||||||
CXXFLAGS="-DQ_NO_PACKED_POINTERS"
|
CXXFLAGS="-DQ_NO_PACKED_POINTERS"
|
||||||
%endif
|
%endif
|
||||||
@ -129,18 +116,9 @@ exit 0
|
|||||||
%{_libdir}/libscim-gtkutils-1.0.so.*
|
%{_libdir}/libscim-gtkutils-1.0.so.*
|
||||||
%{_libdir}/libscim-x11utils-1.0.so.*
|
%{_libdir}/libscim-x11utils-1.0.so.*
|
||||||
%dir %{_libdir}/scim-1.0/%{apiver}
|
%dir %{_libdir}/scim-1.0/%{apiver}
|
||||||
%{_libdir}/scim-1.0/%{apiver}/*/*.la
|
|
||||||
%{_libdir}/scim-1.0/%{apiver}/*/*.so
|
%{_libdir}/scim-1.0/%{apiver}/*/*.so
|
||||||
%{_libdir}/gtk-2.0/*/immodules/im-scim.la
|
|
||||||
%{_libdir}/gtk-2.0/*/immodules/im-scim.so
|
%{_libdir}/gtk-2.0/*/immodules/im-scim.so
|
||||||
%{_libdir}/gtk-3.0/*/immodules/im-scim.la
|
|
||||||
%{_libdir}/gtk-3.0/*/immodules/im-scim.so
|
%{_libdir}/gtk-3.0/*/immodules/im-scim.so
|
||||||
%ifnarch aarch64
|
|
||||||
%{_libdir}/qt3/lib/qt3/plugins/inputmethods/im-scim.la
|
|
||||||
%{_libdir}/qt3/lib/qt3/plugins/inputmethods/im-scim.so
|
|
||||||
%{_libdir}/qt4/plugins/inputmethods/im-scim.la
|
|
||||||
%{_libdir}/qt4/plugins/inputmethods/im-scim.so
|
|
||||||
%endif
|
|
||||||
%{_libdir}/scim-1.0/scim-helper-launcher
|
%{_libdir}/scim-1.0/scim-helper-launcher
|
||||||
%{_libdir}/scim-1.0/scim-helper-manager
|
%{_libdir}/scim-1.0/scim-helper-manager
|
||||||
%{_libdir}/scim-1.0/scim-launcher
|
%{_libdir}/scim-1.0/scim-launcher
|
||||||
@ -151,19 +129,18 @@ exit 0
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{_includedir}/scim-1.0/gtk
|
%dir %{_includedir}/scim-1.0/gtk
|
||||||
%{_includedir}/scim-1.0/gtk/*.h
|
%{_includedir}/scim-1.0/gtk/*.h
|
||||||
%dir %{_includedir}/scim-1.0/gtk
|
|
||||||
%{_includedir}/scim-1.0/*.h
|
%{_includedir}/scim-1.0/*.h
|
||||||
%{_includedir}/scim-1.0/x11/*.h
|
%{_includedir}/scim-1.0/x11/*.h
|
||||||
%{_libdir}/libscim-1.0.la
|
|
||||||
%{_libdir}/libscim-1.0.so
|
%{_libdir}/libscim-1.0.so
|
||||||
%{_libdir}/libscim-gtkutils-1.0.la
|
|
||||||
%{_libdir}/libscim-gtkutils-1.0.so
|
%{_libdir}/libscim-gtkutils-1.0.so
|
||||||
%{_libdir}/libscim-x11utils-1.0.la
|
|
||||||
%{_libdir}/libscim-x11utils-1.0.so
|
%{_libdir}/libscim-x11utils-1.0.so
|
||||||
%{_libdir}/pkgconfig/*.pc
|
%{_libdir}/pkgconfig/*.pc
|
||||||
%doc ChangeLog README THANKS TODO
|
%doc ChangeLog README THANKS TODO
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 13 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.18-3mamba
|
||||||
|
- remove build of qt3 and qt4 immodules
|
||||||
|
|
||||||
* Wed Dec 09 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.18-2mamba
|
* Wed Dec 09 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.18-2mamba
|
||||||
- rebuilt with debug package
|
- rebuilt with debug package
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user