automatic version update by autodist [release 1.4.14-1mamba;Sat Jun 23 2012]
This commit is contained in:
parent
c6d4e07a3d
commit
63eedac88a
@ -1,2 +1,4 @@
|
||||
# scim
|
||||
|
||||
The Smart Common Input Method (SCIM) platform project provides not only a user friendly, full featured input method user interface for POSIX-style operating systems (including Linux, FreeBSD and other Unix), but also a development platform to make input method development easier.
|
||||
|
||||
|
12
scim-1.4.9-gcc44.patch
Normal file
12
scim-1.4.9-gcc44.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru scim-1.4.9.orig/src/ltdl.cpp scim-1.4.9/src/ltdl.cpp
|
||||
--- scim-1.4.9.orig/src/ltdl.cpp 2008-11-02 07:42:40.000000000 +0100
|
||||
+++ scim-1.4.9/src/ltdl.cpp 2009-06-15 02:09:57.000000000 +0200
|
||||
@@ -3373,7 +3373,7 @@
|
||||
assert (filename);
|
||||
|
||||
len = LT_STRLEN (filename);
|
||||
- ext = strrchr (filename, '.');
|
||||
+ ext = strrchr ((char*)filename, '.');
|
||||
|
||||
/* If FILENAME already bears a suitable extension, there is no need
|
||||
to try appending additional extensions. */
|
4
scim-sysconfig
Normal file
4
scim-sysconfig
Normal file
@ -0,0 +1,4 @@
|
||||
#
|
||||
# Configuration file for scim
|
||||
#
|
||||
SCIM_ENABLE=0
|
8
scim-xprofile
Normal file
8
scim-xprofile
Normal file
@ -0,0 +1,8 @@
|
||||
[ -r /etc/sysconfig/scim ] && . /etc/sysconfig/scim
|
||||
|
||||
if [ "$SCIM_ENABLE" = "1" ]; then
|
||||
#export XMODIFIERS=@im=SCIM
|
||||
export GTK_IM_MODULE="scim"
|
||||
export QT_IM_MODULE=scim
|
||||
scim -d
|
||||
fi
|
184
scim.spec
Normal file
184
scim.spec
Normal file
@ -0,0 +1,184 @@
|
||||
%define majver %(echo %version | cut -d. -f 1-2)
|
||||
%define apiver %{majver}.0
|
||||
Name: scim
|
||||
Version: 1.4.14
|
||||
Release: 1mamba
|
||||
Summary: A user friendly, full featured input method user interface and more
|
||||
Group: System/Tools
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.scim-im.org/
|
||||
Source: http://downloads.sourceforge.net/project/scim/scim/%{version}/scim-%{version}.tar.gz
|
||||
Source1: scim-xprofile
|
||||
Source2: scim-sysconfig
|
||||
Patch0: %{name}-1.4.9-gcc44.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: bash
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libglitz-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libxcb-util-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libqt3-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
The Smart Common Input Method (SCIM) platform project provides not only a user friendly, full featured input method user interface for POSIX-style operating systems (including Linux, FreeBSD and other Unix), but also a development platform to make input method development easier.
|
||||
|
||||
%package -n libscim
|
||||
Summary: SCIM (Smart Common Input Method) libraries
|
||||
Group: System/Libraries
|
||||
|
||||
%description -n libscim
|
||||
The Smart Common Input Method (SCIM) platform project provides not only a user friendly, full featured input method user interface for POSIX-style operating systems (including Linux, FreeBSD and other Unix), but also a development platform to make input method development easier.
|
||||
|
||||
%package -n libscim-devel
|
||||
Summary: Devel package for libscim
|
||||
Group: Development/Libraries
|
||||
Requires: libscim = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libscim-devel
|
||||
The Smart Common Input Method (SCIM) platform project provides not only a user friendly, full featured input method user interface for POSIX-style operating systems (including Linux, FreeBSD and other Unix), but also a development platform to make input method development easier.
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
install -D -m0755 %{SOURCE1} %{buildroot}%{_sysconfdir}/xprofile.d/scim.sh
|
||||
install -D -m0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/sysconfig/scim
|
||||
%find_lang %{name}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n libscim
|
||||
if [ $1 -ge 1 ]; then
|
||||
gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
|
||||
fi
|
||||
/sbin/ldconfig
|
||||
exit 0
|
||||
|
||||
%postun -n libscim
|
||||
if [ $1 -eq 0 ]; then
|
||||
gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
|
||||
fi
|
||||
/sbin/ldconfig
|
||||
exit 0
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%config(noreplace) %{_sysconfdir}/scim/config
|
||||
%config(noreplace) %{_sysconfdir}/scim/global
|
||||
%{_sysconfdir}/xprofile.d/scim.sh
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/scim
|
||||
%{_bindir}/scim
|
||||
%{_bindir}/scim-config-agent
|
||||
%{_bindir}/scim-im-agent
|
||||
%{_bindir}/scim-setup
|
||||
%dir %{_datadir}/scim
|
||||
%{_datadir}/applications/scim-setup.desktop
|
||||
%{_datadir}/control-center-2.0/capplets/scim-setup.desktop
|
||||
%{_datadir}/pixmaps/scim-setup.png
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files -n libscim
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libscim-1.0.so.*
|
||||
%{_libdir}/libscim-gtkutils-1.0.so.*
|
||||
%{_libdir}/libscim-x11utils-1.0.so.*
|
||||
%dir %{_libdir}/scim-1.0/%{apiver}
|
||||
%{_libdir}/scim-1.0/%{apiver}/*/*.a
|
||||
%{_libdir}/scim-1.0/%{apiver}/*/*.la
|
||||
%{_libdir}/scim-1.0/%{apiver}/*/*.so
|
||||
%{_libdir}/gtk-2.0/*/immodules/im-scim.a
|
||||
%{_libdir}/gtk-2.0/*/immodules/im-scim.la
|
||||
%{_libdir}/gtk-2.0/*/immodules/im-scim.so
|
||||
%{_libdir}/gtk-3.0/*/immodules/im-scim.a
|
||||
%{_libdir}/gtk-3.0/*/immodules/im-scim.la
|
||||
%{_libdir}/gtk-3.0/*/immodules/im-scim.so
|
||||
%{_libdir}/qt3/lib/qt3/plugins/inputmethods/im-scim.a
|
||||
%{_libdir}/qt3/lib/qt3/plugins/inputmethods/im-scim.la
|
||||
%{_libdir}/qt3/lib/qt3/plugins/inputmethods/im-scim.so
|
||||
%{_libdir}/qt4/plugins/inputmethods/im-scim.a
|
||||
%{_libdir}/qt4/plugins/inputmethods/im-scim.la
|
||||
%{_libdir}/qt4/plugins/inputmethods/im-scim.so
|
||||
%{_libdir}/scim-1.0/scim-helper-launcher
|
||||
%{_libdir}/scim-1.0/scim-helper-manager
|
||||
%{_libdir}/scim-1.0/scim-launcher
|
||||
%{_libdir}/scim-1.0/scim-panel-gtk
|
||||
%{_datadir}/scim/icons/*.png
|
||||
|
||||
%files -n libscim-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/scim-1.0/gtk
|
||||
%{_includedir}/scim-1.0/gtk/*.h
|
||||
%dir %{_includedir}/scim-1.0/gtk
|
||||
%{_includedir}/scim-1.0/*.h
|
||||
%{_includedir}/scim-1.0/x11/*.h
|
||||
%{_libdir}/libscim-1.0.a
|
||||
%{_libdir}/libscim-1.0.la
|
||||
%{_libdir}/libscim-1.0.so
|
||||
%{_libdir}/libscim-gtkutils-1.0.a
|
||||
%{_libdir}/libscim-gtkutils-1.0.la
|
||||
%{_libdir}/libscim-gtkutils-1.0.so
|
||||
%{_libdir}/libscim-x11utils-1.0.a
|
||||
%{_libdir}/libscim-x11utils-1.0.la
|
||||
%{_libdir}/libscim-x11utils-1.0.so
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%doc ChangeLog README THANKS TODO
|
||||
|
||||
%changelog
|
||||
* Sat Jun 23 2012 Automatic Build System <autodist@mambasoft.it> 1.4.14-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jun 14 2012 Automatic Build System <autodist@mambasoft.it> 1.4.13-1mamba
|
||||
- update to 1.4.13
|
||||
|
||||
* Tue Jul 19 2011 Automatic Build System <autodist@mambasoft.it> 1.4.10-1mamba
|
||||
- update to 1.4.10
|
||||
|
||||
* Thu Nov 11 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.9-3mamba
|
||||
- rebuilt with libpng 1.4
|
||||
|
||||
* Mon Jun 15 2009 Automatic Build System <autodist@mambasoft.it> 1.4.9-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Sun Apr 19 2009 Automatic Build System <autodist@mambasoft.it> 1.4.9-1mamba
|
||||
- automatic update to 1.4.9 by autodist
|
||||
|
||||
* Sun Jan 25 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.8-1mamba
|
||||
- automatic update to 1.4.8 by autodist
|
||||
|
||||
* Thu Dec 27 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.7-2mamba
|
||||
- fixed ldconfig execution in post scripts
|
||||
- icons moved to the libscim package
|
||||
|
||||
* Thu Dec 27 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.7-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user