update to 6.1.1 [release 6.1.1-1mamba;Sat Oct 21 2023]
This commit is contained in:
parent
fcd68fee17
commit
be0db841f9
@ -1,15 +1,17 @@
|
||||
--- modules/scicos/Makefile.in.orig 2018-02-22 20:48:50.382685100 +0100
|
||||
+++ modules/scicos/Makefile.in 2018-02-21 23:01:04.547956702 +0100
|
||||
@@ -794,10 +794,10 @@
|
||||
@@ -794,12 +794,12 @@
|
||||
NMEDIT = @NMEDIT@
|
||||
OBJDUMP = @OBJDUMP@
|
||||
OBJEXT = @OBJEXT@
|
||||
-OCAMLC = @OCAMLC@
|
||||
+OCAMLC = ocamlfind @OCAMLC@ -package num
|
||||
OCAMLCFLAGS = @OCAMLCFLAGS@
|
||||
OCAMLDEP = @OCAMLDEP@
|
||||
OCAMLLEX = @OCAMLLEX@
|
||||
-OCAMLOPT = @OCAMLOPT@
|
||||
+OCAMLOPT = ocamlfind @OCAMLOPT@ -package num
|
||||
OCAMLOPTFLAGS = @OCAMLOPTFLAGS@
|
||||
OCAMLYACC = @OCAMLYACC@
|
||||
OPENMPI_CC = @OPENMPI_CC@
|
||||
OPENMPI_CFLAGS = @OPENMPI_CFLAGS@
|
51
scilab-6.1.1-pause_to_scipause.patch
Normal file
51
scilab-6.1.1-pause_to_scipause.patch
Normal file
@ -0,0 +1,51 @@
|
||||
--- a/scilab/modules/core/src/cpp/pause.cpp
|
||||
+++ b/scilab/modules/core/src/cpp/pause.cpp
|
||||
@@ -11,15 +11,15 @@
|
||||
*
|
||||
*/
|
||||
|
||||
-#include "configvariable.hxx"
|
||||
-#include "threadmanagement.hxx"
|
||||
-#include "runner.hxx"
|
||||
-
|
||||
extern "C" {
|
||||
#include "pause.h"
|
||||
}
|
||||
|
||||
-void pause(void)
|
||||
+#include "configvariable.hxx"
|
||||
+#include "threadmanagement.hxx"
|
||||
+#include "runner.hxx"
|
||||
+
|
||||
+void scipause(void)
|
||||
{
|
||||
ConfigVariable::IncreasePauseLevel();
|
||||
|
||||
@@ -43,4 +43,4 @@
|
||||
|
||||
//return from console so change mode to initial
|
||||
ConfigVariable::setPromptMode(iOldMode);
|
||||
-}
|
||||
\ No newline at end of file
|
||||
+}
|
||||
--- a/scilab/modules/core/includes/pause.h
|
||||
+++ b/scilab/modules/core/includes/pause.h
|
||||
@@ -15,6 +15,6 @@
|
||||
#define __PAUSE_H__
|
||||
|
||||
#include "dynlib_core.h"
|
||||
-CORE_IMPEXP void pause(void);
|
||||
+CORE_IMPEXP void scipause(void);
|
||||
|
||||
#endif /* !__PAUSE_H__ */
|
||||
--- a/scilab/modules/core/sci_gateway/cpp/sci_pause.cpp
|
||||
+++ b/scilab/modules/core/sci_gateway/cpp/sci_pause.cpp
|
||||
@@ -47,7 +47,7 @@
|
||||
ConfigVariable::macroFirstLine_begin(2);
|
||||
|
||||
// do pause
|
||||
- pause();
|
||||
+ scipause();
|
||||
|
||||
return types::Function::OK;
|
||||
}
|
102
scilab.spec
102
scilab.spec
@ -1,5 +1,5 @@
|
||||
Name: scilab
|
||||
Version: 6.1.0
|
||||
Version: 6.1.1
|
||||
Release: 1mamba
|
||||
Summary: A scientific software package for numerical computations
|
||||
Group: Graphical Desktop/Applications/Scientific
|
||||
@ -15,103 +15,81 @@ Patch1: scilab-6.1.0-strict-jar.patch
|
||||
Patch2: scilab-6.1.0-libhdf5-1.8.10.patch
|
||||
Patch3: scilab-6.1.0-hdf5_18_api.patch
|
||||
Patch4: scilab-6.1.0-matio-fix-uint32_t-type.patch
|
||||
Patch5: scilab-6.1.0-ocaml-num.patch
|
||||
Patch5: scilab-6.1.1-ocaml-num.patch
|
||||
Patch6: scilab-6.1.0-ocaml.patch
|
||||
Patch7: scilab-6.1.0-fix-core-link.patch
|
||||
Patch8: scilab-6.1.1-pause_to_scipause.patch
|
||||
License: CeCILL, GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: gcc-fortran
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: java-openjdk8-runtime
|
||||
BuildRequires: libarpack-devel
|
||||
BuildRequires: libbrotli-devel
|
||||
BuildRequires: libcares-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libe2fs-devel
|
||||
BuildRequires: libevent-devel
|
||||
BuildRequires: libfftw-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgomp-devel
|
||||
BuildRequires: libgsasl-devel
|
||||
BuildRequires: libgss-devel
|
||||
BuildRequires: libhdf5-devel
|
||||
BuildRequires: libhwloc-devel
|
||||
BuildRequires: libicu-devel
|
||||
BuildRequires: libidn-devel
|
||||
BuildRequires: libidn2-devel
|
||||
BuildRequires: libkrb5-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libmatio-devel
|
||||
BuildRequires: libmpi-devel
|
||||
BuildRequires: libncurses-devel
|
||||
BuildRequires: libnghttp2-devel
|
||||
BuildRequires: libntlm-devel
|
||||
BuildRequires: libopenblas-devel
|
||||
BuildRequires: libopenldap-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libpsl-devel
|
||||
BuildRequires: libquadmath-devel
|
||||
BuildRequires: librtmp-devel
|
||||
BuildRequires: libsasl2-devel
|
||||
BuildRequires: libssh2-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libsuitesparse-devel
|
||||
BuildRequires: libtcl-devel
|
||||
BuildRequires: libtk-devel
|
||||
BuildRequires: libudev-devel
|
||||
BuildRequires: libunistring-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: libzstd-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libmpi-devel >= 4.1.5
|
||||
BuildRequires: ocaml
|
||||
BuildRequires: ocaml-num
|
||||
BuildRequires: libarpack-devel
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: ImageMagick
|
||||
# java stuff
|
||||
BuildRequires: java-openjdk8
|
||||
BuildRequires: apache-ant
|
||||
BuildRequires: apache-batik
|
||||
BuildRequires: java-graphx
|
||||
BuildRequires: apache-fop
|
||||
BuildRequires: java-openjdk8
|
||||
BuildRequires: java-flexdock
|
||||
BuildRequires: java-graphx
|
||||
BuildRequires: java-jogl
|
||||
BuildRequires: jgoodies-looks
|
||||
BuildRequires: java-skinlf
|
||||
BuildRequires: javahelp2
|
||||
BuildRequires: java-jeuclid
|
||||
BuildRequires: java-jlatexmath
|
||||
BuildRequires: java-lucene
|
||||
BuildRequires: java-rosetta
|
||||
BuildRequires: apache-batik
|
||||
BuildRequires: java-jeuclid
|
||||
BuildRequires: apache-fop
|
||||
BuildRequires: jakarta-commons-io
|
||||
BuildRequires: java-excalibur-avalon-framework-api
|
||||
BuildRequires: jakarta-commons-logging
|
||||
BuildRequires: java-skinlf
|
||||
BuildRequires: java-xmlgraphics-commons
|
||||
BuildRequires: java-jlatexmath
|
||||
BuildRequires: java-junit48
|
||||
Requires: docbook-xsl
|
||||
#BuildRequires: jakarta-commons-io
|
||||
#BuildRequires: java-excalibur-avalon-framework-api
|
||||
#BuildRequires: jakarta-commons-logging
|
||||
#BuildRequires: java-junit48
|
||||
BuildRequires: javahelp2
|
||||
BuildRequires: jgoodies-looks
|
||||
Requires: antlr
|
||||
Requires: apache-batik
|
||||
Requires: apache-fop
|
||||
Requires: jakarta-commons-beanutils
|
||||
Requires: jakarta-commons-io
|
||||
Requires: jakarta-commons-logging
|
||||
Requires: java-xmlgraphics-commons
|
||||
Requires: docbook-xsl
|
||||
#Requires: jakarta-commons-beanutils
|
||||
#Requires: jakarta-commons-io
|
||||
#Requires: jakarta-commons-logging
|
||||
Requires: java-checkstyle
|
||||
Requires: java-excalibur-avalon-framework
|
||||
#Requires: java-excalibur-avalon-framework
|
||||
Requires: java-flexdock
|
||||
Requires: java-graphx
|
||||
Requires: java-jeuclid
|
||||
Requires: java-jlatexmath
|
||||
Requires: java-junit48
|
||||
Requires: java-openjdk8
|
||||
#Requires: java-junit48
|
||||
#Requires: java-openjdk8
|
||||
Requires: java-qdox
|
||||
Requires: java-rosetta
|
||||
Requires: java-saxon9
|
||||
Requires: java-skinlf
|
||||
Requires: java-testng
|
||||
Requires: java-xmlgraphics-commons
|
||||
Requires: javahelp2
|
||||
Requires: jgoodies-looks
|
||||
Requires: ocaml
|
||||
@ -142,27 +120,27 @@ Obsoletes: scilab-devel < 6.1.0
|
||||
Scilab - A scientific software package for numerical computations.
|
||||
This package contains development files for with Scilab.
|
||||
|
||||
#% debug_package
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
%patch0 -p2
|
||||
#%patch1 -p0
|
||||
%patch3 -p1
|
||||
#%patch2 -p1
|
||||
%patch4 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch 0 -p2
|
||||
%patch 3 -p1
|
||||
#%patch 4 -p1
|
||||
%patch 5 -p0
|
||||
%patch 6 -p1
|
||||
#%patch 7 -p1
|
||||
%patch 8 -p2
|
||||
|
||||
autoreconf -f -i
|
||||
#autoreconf -f -i
|
||||
|
||||
%patch5 -p0
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
%configure \
|
||||
--enable-debug \
|
||||
--with-gcc \
|
||||
--with-gfortran \
|
||||
--with-mpi \
|
||||
@ -180,7 +158,9 @@ autoreconf -f -i
|
||||
CFLAGS="%{optflags} -fcommon" \
|
||||
CXXFLAGS="%{optflags} -fcommon"
|
||||
|
||||
%make
|
||||
%make -j1 \
|
||||
OCAMLCFLAGS="" OCAMLOPTFLAGS=""
|
||||
|
||||
make doc
|
||||
|
||||
%install
|
||||
@ -197,6 +177,7 @@ make DESTDIR=%{buildroot} install-data install-html
|
||||
%post
|
||||
/sbin/ldconfig
|
||||
touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
:
|
||||
|
||||
%postun
|
||||
/sbin/ldconfig
|
||||
@ -204,6 +185,7 @@ if [ $1 -eq 0 ] ; then
|
||||
touch --no-create %{_datadir}/icons/hicolor &>/dev/null
|
||||
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
fi
|
||||
:
|
||||
|
||||
%posttrans
|
||||
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
@ -238,7 +220,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{_datadir}/icons/hicolor/*/apps/*.png
|
||||
%{_datadir}/icons/hicolor/*/mimetypes/*.png
|
||||
#%{_datadir}/pixmaps/scilab.png
|
||||
#%doc license.txt
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
@ -246,7 +227,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{_libdir}/scilab/libjavasci2.so.*
|
||||
%{_libdir}/scilab/libsci*.so.*
|
||||
%{_libdir}/scilab/*.so
|
||||
%{_libdir}/scilab/*.la
|
||||
%doc COPYING COPYING-BSD
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
@ -255,6 +236,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{_libdir}/pkgconfig/scilab.pc
|
||||
|
||||
%changelog
|
||||
* Sat Oct 21 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 6.1.1-1mamba
|
||||
- update to 6.1.1
|
||||
|
||||
* Sun Apr 11 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 6.1.0-1mamba
|
||||
- update to 6.1.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user