provide user/group saned [release 1.3.1-2mamba;Thu Jun 06 2024]
This commit is contained in:
parent
9d2ac9ab84
commit
9ebe8e4206
@ -1,49 +0,0 @@
|
||||
--- sane-backends-1.0.22/backend/v4l.h.deconflict-v4l 2010-12-01 15:49:58.000000000 -0800
|
||||
+++ sane-backends-1.0.22/backend/v4l.h 2011-04-01 21:44:18.797102300 -0700
|
||||
@@ -29,6 +29,8 @@
|
||||
#ifndef v4l_h
|
||||
#define v4l_h
|
||||
|
||||
+#include <libv4l1-videodev.h>
|
||||
+
|
||||
/* Kernel interface */
|
||||
/* Only the stuff we need. For more features, more defines are needed */
|
||||
|
||||
@@ -46,7 +48,7 @@
|
||||
#define VID_TYPE_MPEG_ENCODER 2048 /* Can encode MPEG streams */
|
||||
#define VID_TYPE_MJPEG_DECODER 4096 /* Can decode MJPEG streams */
|
||||
#define VID_TYPE_MJPEG_ENCODER 8192 /* Can encode MJPEG streams */
|
||||
-
|
||||
+#if 0
|
||||
struct video_capability
|
||||
{
|
||||
char name[32];
|
||||
@@ -58,7 +60,6 @@
|
||||
int minwidth; /* Supported width */
|
||||
int minheight; /* And height */
|
||||
};
|
||||
-
|
||||
struct video_picture
|
||||
{
|
||||
__u16 brightness;
|
||||
@@ -102,9 +103,10 @@
|
||||
/* bitmap is 1024x625, a '1' bit represents a clipped pixel */
|
||||
#define VIDEO_CLIPMAP_SIZE (128 * 625)
|
||||
};
|
||||
-
|
||||
+#endif
|
||||
#define VIDEO_MAX_FRAME 32
|
||||
|
||||
+#if 0
|
||||
struct video_mbuf
|
||||
{
|
||||
int size; /* Total memory to map */
|
||||
@@ -132,7 +134,7 @@
|
||||
#define VIDEO_TYPE_CAMERA 2
|
||||
__u16 norm; /* Norm set by channel */
|
||||
};
|
||||
-
|
||||
+#endif
|
||||
#define VIDIOCGCAP _IOR('v',1,struct video_capability) /* Get capabilities */
|
||||
#define VIDIOCGCHAN _IOWR('v',2,struct video_channel) /* Get channel info (sources) */
|
||||
#define VIDIOCSCHAN _IOW('v',3,struct video_channel) /* Set channel */
|
@ -1,19 +0,0 @@
|
||||
diff -Nru sane-backends-1.0.23.orig/configure.in sane-backends-1.0.23/configure.in
|
||||
--- sane-backends-1.0.23.orig/configure.in 2012-08-19 22:31:34.000000000 +0200
|
||||
+++ sane-backends-1.0.23/configure.in 2012-09-29 12:07:23.264203400 +0200
|
||||
@@ -206,15 +206,6 @@
|
||||
|
||||
AC_CHECK_HEADERS(winsock2.h, SOCKET_LIB="-lws2_32")
|
||||
|
||||
-AC_CHECK_HEADER(resmgr.h,[
|
||||
- AC_CHECK_LIB(
|
||||
- resmgr,
|
||||
- rsm_open_device,[
|
||||
- AC_DEFINE(HAVE_RESMGR,1,[define if you have the resmgr library])
|
||||
- RESMGR_LIBS="-lresmgr"
|
||||
- ]
|
||||
- )
|
||||
-])
|
||||
AC_SUBST(RESMGR_LIBS)
|
||||
|
||||
dnl ***********************************************************************
|
@ -1,12 +0,0 @@
|
||||
--- backends-1.0.31/acinclude.m4.orig 2020-12-13 12:54:11.199330339 +0100
|
||||
+++ backends-1.0.31/acinclude.m4 2020-12-13 12:54:16.499425763 +0100
|
||||
@@ -73,9 +73,6 @@
|
||||
if test "${ac_cv_header_unistd_h}" != "yes" ; then
|
||||
MISSING_HEADERS="${MISSING_HEADERS}\"unistd.h\" "
|
||||
fi
|
||||
- if test "${ac_cv_header_stdc}" != "yes" ; then
|
||||
- MISSING_HEADERS="${MISSING_HEADERS}\"ANSI C headers\" "
|
||||
- fi
|
||||
if test "${MISSING_HEADERS}" != "" ; then
|
||||
echo "*** The following essential header files couldn't be found:"
|
||||
echo "*** ${MISSING_HEADERS}"
|
@ -4,8 +4,8 @@
|
||||
%define saned_gid 65442
|
||||
|
||||
Name: sane-backends
|
||||
Version: 1.3.0
|
||||
Release: 1mamba
|
||||
Version: 1.3.1
|
||||
Release: 2mamba
|
||||
Summary: SANE provides standardized access to any raster image scanner hardware
|
||||
Group: System/Kernel and Hardware
|
||||
Vendor: openmamba
|
||||
@ -13,19 +13,10 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.sane-project.org
|
||||
Source: https://gitlab.com/sane-project/backends.git/%{version}/backends-%{version}.tar.bz2
|
||||
#Source: https://alioth.debian.org/frs/download.php/file/4146/sane-backends-%{version}.tar.gz
|
||||
#Source: http://alioth.debian.org/frs/download.php/3752/sane-backends-%{version}.tar.gz.1
|
||||
#Source1: http://alioth.debian.org/frs/download.php/3752/sane-backends-%{version}.tar.gz.2
|
||||
#Source2: http://alioth.debian.org/frs/download.php/3752/sane-backends-%{version}.tar.gz.3
|
||||
#download the 3 sources above and then do a cat sane-backends-%{version}.tar.gz.[1-3] > sane-backends-%{version}.tar.gz
|
||||
#Source: sane-backends-%{version}.tar.gz
|
||||
Source3: sane-libusbscanner
|
||||
Source4: saned.socket
|
||||
Source5: saned@.service
|
||||
Patch1: libsane-backends-1.0.23-disable_resmgr.patch
|
||||
Patch2: libsane-backends-1.0.22-deconflict_v4l_headers.patch
|
||||
Patch3: sane-backends-1.0.23-use_lp_group.patch
|
||||
Patch4: libsane-backends-1.0.24-autoconf-2.70.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -53,6 +44,8 @@ BuildRequires: pkgconfig >= 0.15.0
|
||||
Requires(pre): uucp
|
||||
Requires: sane = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: libsane-backends
|
||||
Provides: user(saned)
|
||||
Provides: group(saned)
|
||||
Obsoletes: libsane-backends <= 1.0.31
|
||||
Obsoletes: sane-backends-extras <= 1.0.22.4-2mamba
|
||||
%systemd_requires
|
||||
@ -113,7 +106,6 @@ Of course, the savings get even bigger as more and more drivers and/or applicati
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
%patch 3 -p1
|
||||
#%patch4 -p1
|
||||
sed -i "s|m4_esyscmd_s.*|[%{version}],|" configure.ac
|
||||
#sed -i "/AC_HEADER_STDC/d" configure.ac
|
||||
#autoreconf -f -i
|
||||
@ -126,18 +118,12 @@ sed -i "s|m4_esyscmd_s.*|[%{version}],|" configure.ac
|
||||
--enable-avahi \
|
||||
--with-group=saned
|
||||
|
||||
# USB_LIBS="-lusb -lresmgr"
|
||||
# FIXME: workaround to fix missing link library resmgr as of 1.0.21
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall DESTDIR=%{buildroot}
|
||||
|
||||
#install -d %{buildroot}%{_datadir}
|
||||
#mv %{buildroot}%{_prefix}/doc %{buildroot}%{_datadir}
|
||||
|
||||
# add drivers to sane configuration
|
||||
echo "\
|
||||
hpaio
|
||||
@ -197,7 +183,6 @@ fi
|
||||
:
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files -n sane -f sane-backends.lang
|
||||
@ -229,7 +214,6 @@ fi
|
||||
%dir %{_libdir}/sane
|
||||
%{_libdir}/sane/libsane-*.so*
|
||||
%dir %{_datadir}/sane
|
||||
#%dir %attr(0775,root,uucp) %{_localstatedir}/lock/sane
|
||||
%doc AUTHORS COPYING LICENSE
|
||||
|
||||
%files devel
|
||||
@ -244,6 +228,12 @@ fi
|
||||
#%doc ChangeLog NEWS PROBLEMS PROJECTS README.linux
|
||||
|
||||
%changelog
|
||||
* Thu Jun 06 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.1-2mamba
|
||||
- provide user/group saned
|
||||
|
||||
* Fri May 24 2024 Automatic Build System <autodist@openmamba.org> 1.3.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Feb 13 2024 Automatic Build System <autodist@openmamba.org> 1.3.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user