automatic rebuild by autodist [release 2.7.10-4mamba;Mon Jul 15 2013]
This commit is contained in:
parent
eac0c2ec1a
commit
0bbf70c90c
@ -1,2 +1,5 @@
|
||||
# rxvt
|
||||
|
||||
rxvt is a colour vt102 terminal emulator intended as an xterm replacement for users who do not require features such as Tektronix 4014 emulation and toolkit-style configurability.
|
||||
As a result, rxvt uses much less swap space.
|
||||
|
||||
|
11
rxvt-2.7.10-configure_wtmp.patch
Normal file
11
rxvt-2.7.10-configure_wtmp.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- rxvt-2.7.10/configure 2003-03-26 07:07:26.000000000 +0100
|
||||
+++ rxvt-2.7.10/configure.fix 2007-10-10 17:36:09.000000000 +0200
|
||||
@@ -13966,7 +13966,7 @@
|
||||
main()
|
||||
{
|
||||
char **w, *wtmplist[] = {
|
||||
- "/var/log/wtmpx", "/var/adm/wtmpx", NULL };
|
||||
+ "/var/log/wtmpx", "/var/adm/wtmpx", "/var/log/wtmp", NULL };
|
||||
FILE *a, *f=fopen("conftestval", "w");
|
||||
if (!f) exit(1);
|
||||
#ifdef WTMPX_FILE
|
41
rxvt-2.7.10-security.patch
Normal file
41
rxvt-2.7.10-security.patch
Normal file
@ -0,0 +1,41 @@
|
||||
--- src/command.c
|
||||
+++ src/command.c
|
||||
@@ -2878,7 +2878,7 @@
|
||||
unsigned char buf[256];
|
||||
|
||||
va_start(arg_ptr, fmt);
|
||||
- vsprintf((char *)buf, fmt, arg_ptr);
|
||||
+ vsnprintf((char *)buf, sizeof(buf), fmt, arg_ptr);
|
||||
va_end(arg_ptr);
|
||||
rxvt_tt_write(r, buf, (unsigned int)STRLEN(buf));
|
||||
}
|
||||
--- src/main.c
|
||||
+++ src/main.c
|
||||
@@ -291,10 +291,14 @@
|
||||
break;
|
||||
}
|
||||
# else
|
||||
+# error Warning, no seteuid/setegid avaliable
|
||||
switch (mode) {
|
||||
case IGNORE:
|
||||
- setuid(getuid());
|
||||
- setgid(getgid());
|
||||
+ if (setgid(getgid()) < 0)
|
||||
+ exit(1);
|
||||
+ if (setuid(getuid()) < 0)
|
||||
+ exit(1);
|
||||
+
|
||||
/* FALLTHROUGH */
|
||||
case SAVE:
|
||||
/* FALLTHROUGH */
|
||||
--- src/xdefaults.c
|
||||
+++ src/xdefaults.c
|
||||
@@ -810,7 +810,7 @@
|
||||
ptr = ".";
|
||||
|
||||
for (i = 0; i < (sizeof(xnames) / sizeof(xnames[0])); i++) {
|
||||
- sprintf(fname, "%-.*s/%s", sizeof(fname) - STRLEN(xnames[i]) - 2,
|
||||
+ snprintf(fname, sizeof(fname), "%-.*s/%s", sizeof(fname) - STRLEN(xnames[i]) - 2,
|
||||
ptr, xnames[i]);
|
||||
if ((rdb1 = XrmGetFileDatabase(fname)) != NULL) {
|
||||
XrmMergeDatabases(rdb1, &database);
|
78
rxvt.spec
Normal file
78
rxvt.spec
Normal file
@ -0,0 +1,78 @@
|
||||
Name: rxvt
|
||||
Release: 4mamba
|
||||
Version: 2.7.10
|
||||
Summary: A colour vt102 terminal emulator for the X Window System
|
||||
Group: Graphical Desktop/Applications/Utilities
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Aleph0 <aleph0@openmamba.org>
|
||||
URL: http://sourceforge.net/projects/rxvt/
|
||||
Source0: http://downloads.sourceforge.net/sourceforge/rxvt/%{name}-%{version}.tar.gz
|
||||
Source1: rxvt_desktopfile
|
||||
Patch0: %{name}-2.7.10-security.patch
|
||||
Patch1: %{name}-2.7.10-configure_wtmp.patch
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXpm-devel
|
||||
BuildRequires: libXt-devel
|
||||
BuildRequires: xorg-proto-devel
|
||||
License: GPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
rxvt is a colour vt102 terminal emulator intended as an xterm replacement for users who do not require features such as Tektronix 4014 emulation and toolkit-style configurability.
|
||||
As a result, rxvt uses much less swap space.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p0 -b .security
|
||||
%patch1 -p1 -b .wtmp
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--x-includes=%{_includedir} \
|
||||
--x-libraries=%{_libdir} \
|
||||
--enable-everything \
|
||||
--enable-languages \
|
||||
--enable-xim \
|
||||
--enable-xgetdefault \
|
||||
--enable-ttygid \
|
||||
--enable-256-color \
|
||||
--with-term=rxvt \
|
||||
--enable-ttygid \
|
||||
--enable-xpm-background
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
install -p -D -m644 %{S:1} %{buildroot}%{_datadir}/applications/%{name}.desktop
|
||||
|
||||
rm -f %{buildroot}%{_bindir}/rxvt-%{version}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/rclock
|
||||
%{_bindir}/rxvt
|
||||
%{_datadir}/applications/%{name}.desktop
|
||||
%{_mandir}/man1/*
|
||||
#%doc ChangeLog README.configure
|
||||
#%doc doc/BUGS doc/FAQ doc/README.* doc/TODO doc/*.html doc/rxvtRef.txt doc/xterm.seq
|
||||
#%doc doc/menu/*
|
||||
|
||||
%changelog
|
||||
* Mon Jul 15 2013 Automatic Build System <autodist@mambasoft.it> 2.7.10-4mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Thu May 21 2009 Automatic Build System <autodist@mambasoft.it> 2.7.10-3mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Tue Oct 09 2007 Aleph0 <aleph0@openmamba.org> 2.7.10-2mamba
|
||||
- rebuilt against xorg
|
||||
|
||||
* Fri Sep 03 2004 Davide Madrisan <davide.madrisan@qilinux.it> 2.7.10-1qilnx
|
||||
- package creation
|
13
rxvt_desktopfile
Normal file
13
rxvt_desktopfile
Normal file
@ -0,0 +1,13 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Name=rxvt
|
||||
GenericName=VT102 emulator
|
||||
GenericName[it]=Emulatore VT102
|
||||
Comment=a VT102 emulator for the X window system
|
||||
Comment[it]=Emulatore VT102 per il sistema X window
|
||||
Exec=rxvt
|
||||
Icon=konsole.png
|
||||
Terminal=false
|
||||
Type=Application
|
||||
Categories=Application;System;
|
||||
StartupNotify=false
|
Loading…
Reference in New Issue
Block a user