automatic version update by autodist [release 1.77.0-1mamba;Tue Mar 26 2024]
This commit is contained in:
parent
057d8130de
commit
a15b092fdc
@ -1,33 +0,0 @@
|
|||||||
--- src/llvm/cmake/config-ix.cmake 2017-12-14 22:25:15.988551420 +0100
|
|
||||||
+++ src/llvm/cmake/config-ix.cmake.no_llvm_ocaml_bindings 2017-12-14 22:35:08.087110357 +0100
|
|
||||||
@@ -564,29 +564,6 @@
|
|
||||||
# Keep the version requirements in sync with bindings/ocaml/README.txt.
|
|
||||||
include(FindOCaml)
|
|
||||||
include(AddOCaml)
|
|
||||||
-if(WIN32)
|
|
||||||
- message(STATUS "OCaml bindings disabled.")
|
|
||||||
-else()
|
|
||||||
- find_package(OCaml)
|
|
||||||
- if( NOT OCAML_FOUND )
|
|
||||||
- message(STATUS "OCaml bindings disabled.")
|
|
||||||
- else()
|
|
||||||
- if( OCAML_VERSION VERSION_LESS "4.00.0" )
|
|
||||||
- message(STATUS "OCaml bindings disabled, need OCaml >=4.00.0.")
|
|
||||||
- else()
|
|
||||||
- find_ocamlfind_package(ctypes VERSION 0.4 OPTIONAL)
|
|
||||||
- if( HAVE_OCAML_CTYPES )
|
|
||||||
- message(STATUS "OCaml bindings enabled.")
|
|
||||||
- find_ocamlfind_package(oUnit VERSION 2 OPTIONAL)
|
|
||||||
- set(LLVM_BINDINGS "${LLVM_BINDINGS} ocaml")
|
|
||||||
-
|
|
||||||
- set(LLVM_OCAML_INSTALL_PATH "${OCAML_STDLIB_PATH}" CACHE STRING
|
|
||||||
- "Install directory for LLVM OCaml packages")
|
|
||||||
- else()
|
|
||||||
- message(STATUS "OCaml bindings disabled, need ctypes >=0.4.")
|
|
||||||
- endif()
|
|
||||||
- endif()
|
|
||||||
- endif()
|
|
||||||
-endif()
|
|
||||||
+message(STATUS "OCaml bindings disabled.")
|
|
||||||
|
|
||||||
string(REPLACE " " ";" LLVM_BINDINGS_LIST "${LLVM_BINDINGS}")
|
|
21
rustc.spec
21
rustc.spec
@ -1,6 +1,6 @@
|
|||||||
%define stage1 1
|
%define stage1 1
|
||||||
Name: rustc
|
Name: rustc
|
||||||
Version: 1.76.0
|
Version: 1.77.0
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: The Rust programming language, designed to be a safe, concurrent, practical language
|
Summary: The Rust programming language, designed to be a safe, concurrent, practical language
|
||||||
Group: Applications/Development
|
Group: Applications/Development
|
||||||
@ -9,21 +9,20 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://www.rust-lang.org
|
URL: https://www.rust-lang.org
|
||||||
Source: https://static.rust-lang.org/dist/rustc-%{version}-src.tar.gz
|
Source: https://static.rust-lang.org/dist/rustc-%{version}-src.tar.gz
|
||||||
Patch0: rustc-1.25.0-disable-llvm-ocaml-binding.patch
|
|
||||||
License: MIT
|
License: MIT
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libcurl-devel
|
BuildRequires: libcurl-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libgit2-devel
|
|
||||||
BuildRequires: libopenssl-devel
|
BuildRequires: libopenssl-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
BuildRequires: libgit2-devel >= 1.8.0
|
||||||
%if "%{stage1}" != "1"
|
%if "%{stage1}" != "1"
|
||||||
BuildRequires: rustc
|
BuildRequires: rustc
|
||||||
%endif
|
%endif
|
||||||
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The Rust programming language, designed to be a safe, concurrent, practical language.
|
The Rust programming language, designed to be a safe, concurrent, practical language.
|
||||||
@ -48,7 +47,6 @@ This package contains the documentation for %{name}.
|
|||||||
%setup -q -n %{name}-%{version}-src
|
%setup -q -n %{name}-%{version}-src
|
||||||
#-D -T
|
#-D -T
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
#%patch0 -p0
|
|
||||||
|
|
||||||
cat <<EOF > config.toml
|
cat <<EOF > config.toml
|
||||||
# see config.toml.example for more possible options
|
# see config.toml.example for more possible options
|
||||||
@ -95,8 +93,8 @@ rpath = false
|
|||||||
EOF
|
EOF
|
||||||
|
|
||||||
%build
|
%build
|
||||||
:<< _EOF
|
#:<< _EOF
|
||||||
./x.py build %{_smp_mflags}
|
#./x.py build %{_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
@ -140,14 +138,10 @@ cd -
|
|||||||
|
|
||||||
%files -n lib%{name}
|
%files -n lib%{name}
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
#%{_libdir}/libLLVM-11-rust-%{version}-stable.so*
|
|
||||||
%{_libdir}/rustlib/src/rust/Cargo.lock
|
%{_libdir}/rustlib/src/rust/Cargo.lock
|
||||||
#%{_libdir}/libchalk_derive-*.so
|
|
||||||
#%{_libdir}/libserde_derive-*.so
|
|
||||||
%{_libdir}/librustc*.so
|
%{_libdir}/librustc*.so
|
||||||
%{_libdir}/libstd-*.so
|
%{_libdir}/libstd-*.so
|
||||||
%{_libdir}/libtest-*.so
|
#%{_libdir}/libtest-*.so
|
||||||
#%{_libdir}/libtracing_attributes-*.so
|
|
||||||
%dir %{_libdir}/rustlib
|
%dir %{_libdir}/rustlib
|
||||||
%{_libdir}/rustlib/components
|
%{_libdir}/rustlib/components
|
||||||
%{_libdir}/rustlib/rust-installer-version
|
%{_libdir}/rustlib/rust-installer-version
|
||||||
@ -192,6 +186,9 @@ cd -
|
|||||||
#%doc README.md
|
#%doc README.md
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 26 2024 Automatic Build System <autodist@openmamba.org> 1.77.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Sat Feb 10 2024 Automatic Build System <autodist@openmamba.org> 1.76.0-1mamba
|
* Sat Feb 10 2024 Automatic Build System <autodist@openmamba.org> 1.76.0-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user