legacy package [release 2.5.3-2mamba;Wed Jul 01 2020]
This commit is contained in:
parent
4ed8e8bb3b
commit
c4bf45f488
@ -1,2 +1,6 @@
|
|||||||
# ruby25
|
# ruby25
|
||||||
|
|
||||||
|
Ruby is the interpreted scripting language for quick and easy object-oriented programming.
|
||||||
|
It has many features to process text files and to do system management tasks.
|
||||||
|
It is simple, straight-forward, extensible, and portable.
|
||||||
|
|
||||||
|
15
ruby-2.3.4-api_break_rb_thread_fd_close.patch
Normal file
15
ruby-2.3.4-api_break_rb_thread_fd_close.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
--- ruby-2.3.4/thread.c 2017-03-27 18:54:09.000000000 +0200
|
||||||
|
+++ ruby-2.3.4/thread.c.api_break 2017-06-18 19:25:49.671240689 +0200
|
||||||
|
@@ -2187,6 +2187,12 @@
|
||||||
|
return busy;
|
||||||
|
}
|
||||||
|
|
||||||
|
+void
|
||||||
|
+rb_thread_fd_close(int fd)
|
||||||
|
+{
|
||||||
|
+ while (rb_notify_fd_close(fd));
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
/*
|
||||||
|
* call-seq:
|
||||||
|
* thr.raise
|
346
ruby25.spec
Normal file
346
ruby25.spec
Normal file
@ -0,0 +1,346 @@
|
|||||||
|
%define majorminor %(echo %{version} | cut -d. -f 1-2)
|
||||||
|
%define apiver %(echo %{version} | cut -d. -f 1-2).0
|
||||||
|
|
||||||
|
Name: ruby25
|
||||||
|
Epoch: 1
|
||||||
|
Version: 2.5.3
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: An interpreted scripting language for quick and easy object-oriented programming
|
||||||
|
Group: Applications/Development
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||||
|
URL: http://www.ruby-lang.org
|
||||||
|
Source0: https://cache.ruby-lang.org/pub/ruby/%{majorminor}/ruby-%{version}.tar.xz
|
||||||
|
Patch: ruby-2.3.4-api_break_rb_thread_fd_close.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libffi-devel
|
||||||
|
BuildRequires: libgdbm-devel
|
||||||
|
BuildRequires: libgmp-devel
|
||||||
|
BuildRequires: libncurses-devel
|
||||||
|
BuildRequires: libopenssl-devel
|
||||||
|
BuildRequires: libreadline-devel
|
||||||
|
BuildRequires: libtcl-devel
|
||||||
|
BuildRequires: libtk-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libyaml-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: groff
|
||||||
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Ruby is the interpreted scripting language for quick and easy object-oriented programming.
|
||||||
|
It has many features to process text files and to do system management tasks.
|
||||||
|
It is simple, straight-forward, extensible, and portable.
|
||||||
|
|
||||||
|
%package -n lib%{name}
|
||||||
|
Summary: Ruby shared libraries
|
||||||
|
Group: System/Libraries
|
||||||
|
|
||||||
|
%description -n lib%{name}
|
||||||
|
Ruby is the interpreted scripting language for quick and easy object-oriented programming.
|
||||||
|
It has many features to process text files and to do system management tasks.
|
||||||
|
It is simple, straight-forward, extensible, and portable.
|
||||||
|
|
||||||
|
This package contains Ruby's devel files.
|
||||||
|
|
||||||
|
%package -n lib%{name}-devel
|
||||||
|
Summary: Development files for the powerful language Ruby
|
||||||
|
Group: Development/Libraries
|
||||||
|
Provides: %{name}-devel
|
||||||
|
Obsoletes: %{name}-devel
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n lib%{name}-devel
|
||||||
|
Ruby is the interpreted scripting language for quick and easy object-oriented programming.
|
||||||
|
It has many features to process text files and to do system management tasks.
|
||||||
|
It is simple, straight-forward, extensible, and portable.
|
||||||
|
|
||||||
|
This package contains Ruby's devel files.
|
||||||
|
|
||||||
|
#% debug_package
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n ruby-%{version}
|
||||||
|
#%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
CFLAGS=`echo %{optflags} | sed 's/-fomit-frame-pointer //'`
|
||||||
|
%configure \
|
||||||
|
--disable-rpath \
|
||||||
|
--enable-shared
|
||||||
|
# --with-ruby-version=''
|
||||||
|
|
||||||
|
%make
|
||||||
|
make test
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
# remove unpackaged files
|
||||||
|
rm -fr %{buildroot}%{_docdir}
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/erb
|
||||||
|
%{_bindir}/gem
|
||||||
|
%{_bindir}/irb
|
||||||
|
%{_bindir}/rake
|
||||||
|
%{_bindir}/rdoc
|
||||||
|
%{_bindir}/ri
|
||||||
|
%{_bindir}/ruby
|
||||||
|
%{_mandir}/man1/*.1*
|
||||||
|
%doc COPYING
|
||||||
|
|
||||||
|
%files -n lib%{name}
|
||||||
|
%defattr(-, root, root)
|
||||||
|
%{_libdir}/libruby.so.*
|
||||||
|
%{_libdir}/ruby/gems/%{apiver}/cache
|
||||||
|
%{_libdir}/ruby/gems/%{apiver}/gems
|
||||||
|
%{_libdir}/ruby/gems/%{apiver}/specifications
|
||||||
|
%dir %{_libdir}/ruby/%{apiver}
|
||||||
|
%dir %{_libdir}/ruby/%{apiver}/%{_target_cpu}-linux*
|
||||||
|
%{_libdir}/ruby/%{apiver}/%{_target_cpu}-linux*/cgi
|
||||||
|
%{_libdir}/ruby/%{apiver}/%{_target_cpu}-linux*/digest
|
||||||
|
%{_libdir}/ruby/%{apiver}/%{_target_cpu}-linux*/enc
|
||||||
|
%{_libdir}/ruby/%{apiver}/%{_target_cpu}-linux*/io
|
||||||
|
%{_libdir}/ruby/%{apiver}/%{_target_cpu}-linux*/json
|
||||||
|
%{_libdir}/ruby/%{apiver}/%{_target_cpu}-linux*/racc
|
||||||
|
%{_libdir}/ruby/%{apiver}/%{_target_cpu}-linux*/rbconfig
|
||||||
|
%{_libdir}/ruby/%{apiver}/%{_target_cpu}-linux*/*.rb
|
||||||
|
%{_libdir}/ruby/%{apiver}/%{_target_cpu}-linux*/*.so
|
||||||
|
%{_libdir}/ruby/%{apiver}/*.rb
|
||||||
|
%{_libdir}/ruby/%{apiver}/bigdecimal
|
||||||
|
%{_libdir}/ruby/%{apiver}/cgi
|
||||||
|
%{_libdir}/ruby/%{apiver}/digest
|
||||||
|
%{_libdir}/ruby/%{apiver}/drb
|
||||||
|
%{_libdir}/ruby/%{apiver}/fiddle
|
||||||
|
%{_libdir}/ruby/%{apiver}/forwardable/impl.rb
|
||||||
|
%{_libdir}/ruby/%{apiver}/io
|
||||||
|
%{_libdir}/ruby/%{apiver}/irb
|
||||||
|
%{_libdir}/ruby/%{apiver}/json
|
||||||
|
%{_libdir}/ruby/%{apiver}/matrix
|
||||||
|
%{_libdir}/ruby/%{apiver}/net
|
||||||
|
%{_libdir}/ruby/%{apiver}/openssl
|
||||||
|
%{_libdir}/ruby/%{apiver}/optparse
|
||||||
|
%{_libdir}/ruby/%{apiver}/psych
|
||||||
|
%{_libdir}/ruby/%{apiver}/racc
|
||||||
|
%{_libdir}/ruby/%{apiver}/rdoc
|
||||||
|
%{_libdir}/ruby/%{apiver}/rexml
|
||||||
|
%{_libdir}/ruby/%{apiver}/rinda
|
||||||
|
%{_libdir}/ruby/%{apiver}/ripper
|
||||||
|
%{_libdir}/ruby/%{apiver}/rss
|
||||||
|
%{_libdir}/ruby/%{apiver}/rubygems
|
||||||
|
%{_libdir}/ruby/%{apiver}/shell
|
||||||
|
%{_libdir}/ruby/%{apiver}/syslog
|
||||||
|
%{_libdir}/ruby/%{apiver}/unicode_normalize
|
||||||
|
%{_libdir}/ruby/%{apiver}/uri
|
||||||
|
%{_libdir}/ruby/%{apiver}/webrick
|
||||||
|
%{_libdir}/ruby/%{apiver}/yaml
|
||||||
|
%dir %{_datadir}/ri/%{apiver}
|
||||||
|
%dir %{_datadir}/ri/%{apiver}/system
|
||||||
|
%{_datadir}/ri/%{apiver}/system/*
|
||||||
|
|
||||||
|
%files -n lib%{name}-devel
|
||||||
|
%defattr(-, root, root)
|
||||||
|
%dir %{_includedir}/ruby-%{apiver}
|
||||||
|
%dir %{_includedir}/ruby-%{apiver}/ruby
|
||||||
|
%{_includedir}/ruby-%{apiver}/*-linux*/ruby/config.h
|
||||||
|
%{_includedir}/ruby-%{apiver}/ruby.h
|
||||||
|
%{_includedir}/ruby-%{apiver}/ruby/*.h
|
||||||
|
%dir %{_includedir}/ruby-%{apiver}/ruby/backward
|
||||||
|
%{_includedir}/ruby-%{apiver}/ruby/backward/*.h
|
||||||
|
#%{_libdir}/libruby-static.a
|
||||||
|
%{_libdir}/libruby.so
|
||||||
|
%{_libdir}/pkgconfig/ruby-*.pc
|
||||||
|
#%doc ChangeLog README.*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Jul 01 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 2.5.3-2mamba
|
||||||
|
- legacy package
|
||||||
|
|
||||||
|
* Tue Oct 23 2018 Automatic Build System <autodist@mambasoft.it> 2.5.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Mar 29 2018 Automatic Build System <autodist@mambasoft.it> 2.5.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Feb 12 2018 Automatic Build System <autodist@mambasoft.it> 2.5.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Oct 24 2017 Automatic Build System <autodist@mambasoft.it> 2.4.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Jun 18 2017 Davide Madrisan <davide.madrisan@gmail.com> 2.3.4-1mamba
|
||||||
|
- update to 2.3.4
|
||||||
|
|
||||||
|
* Mon Feb 06 2017 Automatic Build System <autodist@mambasoft.it> 2.4.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Nov 21 2016 Automatic Build System <autodist@mambasoft.it> 2.3.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Nov 15 2016 Automatic Build System <autodist@mambasoft.it> 2.3.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Apr 27 2016 Automatic Build System <autodist@mambasoft.it> 2.3.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Dec 27 2015 Automatic Build System <autodist@mambasoft.it> 2.3.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Dec 16 2015 Automatic Build System <autodist@mambasoft.it> 2.2.4-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Aug 19 2015 Automatic Build System <autodist@mambasoft.it> 2.2.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Apr 16 2015 Automatic Build System <autodist@mambasoft.it> 2.2.2-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Tue Mar 17 2015 Automatic Build System <autodist@mambasoft.it> 2.2.1-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sun Dec 28 2014 Automatic Build System <autodist@mambasoft.it> 2.2.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Nov 14 2014 Automatic Build System <autodist@mambasoft.it> 2.1.5-2mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Nov 14 2014 Automatic Build System <autodist@mambasoft.it> 2.1.5-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Oct 30 2014 Automatic Build System <autodist@mambasoft.it> 2.1.4-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Sep 21 2014 Automatic Build System <autodist@mambasoft.it> 2.1.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Jul 10 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.2-1mamba
|
||||||
|
- update to 2.1.2
|
||||||
|
|
||||||
|
* Wed Jan 15 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.0-1mamba
|
||||||
|
- update to 2.1.0
|
||||||
|
|
||||||
|
* Tue Dec 03 2013 Automatic Build System <autodist@mambasoft.it> 2.0.0_p353-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Aug 30 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.0_p247-2mamba
|
||||||
|
- fix rpm macros file by using RbConfig:: instead of deprecated Config::
|
||||||
|
|
||||||
|
* Sat Jun 29 2013 Automatic Build System <autodist@mambasoft.it> 2.0.0_p247-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Jun 03 2013 Automatic Build System <autodist@mambasoft.it> 2.0.0_p195-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Feb 26 2013 Automatic Build System <autodist@mambasoft.it> 2.0.0_p0-1mamba
|
||||||
|
- update to 2.0.0_p0
|
||||||
|
|
||||||
|
* Sun Feb 24 2013 Automatic Build System <autodist@mambasoft.it> 1.9.3_p392-1mamba
|
||||||
|
- update to 1.9.3_p392
|
||||||
|
|
||||||
|
* Wed Feb 20 2013 Automatic Build System <autodist@mambasoft.it> 1.9.3.p385-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Jan 25 2013 Automatic Build System <autodist@mambasoft.it> 1.9.3.p374-2mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Jan 18 2013 Automatic Build System <autodist@mambasoft.it> 1.9.3.p374-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Nov 10 2012 Automatic Build System <autodist@mambasoft.it> 1.9.3.p327-3mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Nov 10 2012 Automatic Build System <autodist@mambasoft.it> 1.9.3.p327-2mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Nov 10 2012 Automatic Build System <autodist@mambasoft.it> 1.9.3.p327-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Oct 19 2012 Automatic Build System <autodist@mambasoft.it> 1.9.3.p286-1mamba
|
||||||
|
- update to 1.9.3.p286
|
||||||
|
|
||||||
|
* Wed Aug 15 2012 Automatic Build System <autodist@mambasoft.it> 1.9.3.p194-1mamba
|
||||||
|
- update to 1.9.3.p194
|
||||||
|
|
||||||
|
* Mon Nov 14 2011 Automatic Build System <autodist@mambasoft.it> 1.9.3.p0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Jan 08 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.7.p330-1mamba
|
||||||
|
- update to 1.8.7.p330
|
||||||
|
|
||||||
|
* Tue Sep 07 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.7-p302-1mamba
|
||||||
|
- update to 1.8.7-p302
|
||||||
|
- fixed specfile for correct version and bumped up epoch
|
||||||
|
|
||||||
|
* Mon Jun 21 2010 Automatic Build System <autodist@mambasoft.it> 1.9.1.p378-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Fri Feb 05 2010 Davide Madrisan <davide.madrisan@gmail.com> 1.9.1.p376-2mamba
|
||||||
|
- provide an rpm macro file: %{_sysconfdir}/rpm/macros.ruby
|
||||||
|
|
||||||
|
* Tue Dec 08 2009 Automatic Build System <autodist@mambasoft.it> 1.9.1.p376-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Thu Jul 23 2009 Automatic Build System <autodist@mambasoft.it> 1.9.1.p243-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Tue May 12 2009 Automatic Build System <autodist@mambasoft.it> 1.9.1.p129-1mamba
|
||||||
|
- automatic update to 1.9.1.p129 by autodist
|
||||||
|
|
||||||
|
* Sat Jan 31 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.1-1mamba
|
||||||
|
- automatic update to 1.9.1 by autodist
|
||||||
|
|
||||||
|
* Wed Aug 13 2008 gil <puntogil@libero.it> 1.8.7-p72-1mamba
|
||||||
|
- update to 1.8.7-p72
|
||||||
|
- edit configure option added enable-pthread (see specfile)
|
||||||
|
|
||||||
|
* Fri Jul 18 2008 gil <puntogil@libero.it> 1.8.7p22-1mamba
|
||||||
|
- update to 1.8.7p22
|
||||||
|
|
||||||
|
* Tue Jun 17 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.7p17-1mamba
|
||||||
|
- update to 1.8.7p17: add patchlevel to package version
|
||||||
|
|
||||||
|
* Sat Jun 14 2008 Aleph0 <aleph0@openmamba.org> 1.8.7-2mamba
|
||||||
|
- update to patch level 17
|
||||||
|
|
||||||
|
* Wed Jun 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.7-1mamba
|
||||||
|
- update to 1.8.7
|
||||||
|
|
||||||
|
* Fri Mar 07 2008 Aleph0 <aleph0@openmamba.org> 1.8.6-5mamba
|
||||||
|
- update to patch level 114
|
||||||
|
|
||||||
|
* Mon Oct 08 2007 Aleph0 <aleph0@openmamba.org> 1.8.6-4mamba
|
||||||
|
- update to patch level 111
|
||||||
|
|
||||||
|
* Wed Oct 03 2007 Aleph0 <aleph0@openmamba.org> 1.8.6-3mamba
|
||||||
|
- update to patch level 110
|
||||||
|
|
||||||
|
* Mon Jun 11 2007 Aleph0 <aleph0@openmamba.org> 1.8.6-2mamba
|
||||||
|
- update to patch level 36
|
||||||
|
|
||||||
|
* Thu Apr 05 2007 Aleph0 <aleph0@openmamba.org> 1.8.6-1mamba
|
||||||
|
- update to version 1.8.6 by autospec
|
||||||
|
|
||||||
|
* Tue Jan 09 2007 Aleph0 <aleph0@openmamba.org> 1.8.5-1qilnx
|
||||||
|
- update to version 1.8.5-p12 by autospec
|
||||||
|
- removed fix against CVE-2006-3694 (merged upstream)
|
||||||
|
- also fixes CVE-2006-5467, and CVE-2006-6303
|
||||||
|
|
||||||
|
* Fri Jul 28 2006 Davide Madrisan <davide.madrisan@qilinux.it> 1.8.4-2qilnx
|
||||||
|
- security update: CVE-2006-3694, bugzilla 208
|
||||||
|
|
||||||
|
* Fri May 19 2006 Davide Madrisan <davide.madrisan@qilinux.it> 1.8.4-1qilnx
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user