rtl88xxau/rtl88xxau.spec

68 lines
1.8 KiB
RPMSpec

%define gittag %(echo %version | cut -d. -f1-4)
%define gitcommit %(echo %version | cut -d. -f6)
Name: rtl88xxau
Version: 5.6.4.2.20240510.b44d288
Release: 1mamba
Summary: RTL8812AU/21AU and RTL8814AU driver with monitor mode and frame injection
Group: System/Kernel and Hardware
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://github.com/aircrack-ng/rtl8812au
Source: https://github.com/aircrack-ng/rtl8812au.git/v%{gittag}@%{gitcommit}/rtl8812au-%{version}.tar.bz2
License: GPL
## AUTOBUILDREQ-BEGIN
## AUTOBUILDREQ-END
Requires(post): bc
Requires(post): dkms
Requires(post): kernelheaders
%description
RTL8812AU/21AU and RTL8814AU driver with monitor mode and frame injection.
%prep
%setup -q -n rtl8812au-%{version}
sed -i "s|\(PACKAGE_NAME=\).*|\1\"%{name}\"|" dkms.conf
sed -i "s|\(PACKAGE_VERSION=\).*|\1%{version}|" dkms.conf
%build
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
install -d -m0755 %{buildroot}%{_prefix}/src/%{name}-%{version}
cp -a * %{buildroot}%{_prefix}/src/%{name}-%{version}
# Remove unnecessary files for build
rm -r %{buildroot}%{_prefix}/src/%{name}-%{version}/{android,docs,tools}
%check
%make
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%preun
# erase
if [ $1 -eq 0 ]; then
dkms remove -q -m %{name} -v %{version} --all
fi
:
%post
if [ $1 -ge 1 ]; then
dkms add -q -m %{name} -v %{version}
dkms install -q -m %{name} -v %{version} --force
fi
:
%files
%defattr(-,root,root)
%dir %{_prefix}/src/%{name}-%{version}
%{_prefix}/src/%{name}-%{version}/*
%doc LICENSE
%changelog
* Tue Jun 04 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 5.6.4.2.20240510.b44d288-1mamba
- package created using the webbuild interface