automatic version update by autodist [release 1.5.3-1mamba;Tue May 19 2015]
This commit is contained in:
parent
baa3829894
commit
674a92cc2a
17
rrdtool-1.4.8-lua-5.2.patch
Normal file
17
rrdtool-1.4.8-lua-5.2.patch
Normal file
@ -0,0 +1,17 @@
|
||||
diff -up rrdtool-1.4.7/configure.ac.lua-52 rrdtool-1.4.7/configure.ac
|
||||
--- rrdtool-1.4.7/configure.ac.lua-52 2013-05-15 11:35:49.074334072 -0400
|
||||
+++ rrdtool-1.4.7/configure.ac 2013-05-15 11:35:49.077334073 -0400
|
||||
@@ -744,7 +744,12 @@ LUA_EOF
|
||||
LIBS=
|
||||
lua_havelib=no
|
||||
LUA_HAVE_COMPAT51=DONT_HAVE_COMPAT51
|
||||
- AC_SEARCH_LIBS(lua_call, lua$lua_vdot lua$lua_vndot lua,
|
||||
+ if test "$lua_vndot" = "52"; then
|
||||
+ CALL_FUNC=lua_callk
|
||||
+ else
|
||||
+ CALL_FUNC=lua_call
|
||||
+ fi
|
||||
+ AC_SEARCH_LIBS($CALL_FUNC, lua$lua_vdot lua$lua_vndot lua,
|
||||
[AC_SEARCH_LIBS(luaL_register, lua$lua_vdot lua$lua_vndot lua,
|
||||
[lua_havelib=LUA$lua_vndot],
|
||||
[AC_SEARCH_LIBS(luaL_module, lualib$lua_vndot lualib$lua_vdot lualib,
|
46
rrdtool.spec
46
rrdtool.spec
@ -1,8 +1,8 @@
|
||||
%define rrddocdir %{_datadir}/doc/%{name}-%{version}
|
||||
|
||||
Name: rrdtool
|
||||
Version: 1.4.7
|
||||
Release: 2mamba
|
||||
Version: 1.5.3
|
||||
Release: 1mamba
|
||||
Summary: Round Robin Database Tool to store and display time-series data
|
||||
Group: Applications/Databases
|
||||
Vendor: openmamba
|
||||
@ -11,6 +11,7 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://oss.oetiker.ch/rrdtool/
|
||||
Source0: http://oss.oetiker.ch/rrdtool/pub/rrdtool-%{version}.tar.gz
|
||||
Source1: rrdtool-log2rrd.pl
|
||||
Patch0: rrdtool-1.4.8-lua-5.2.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -82,6 +83,18 @@ It stores the data in a very compact way that will not expand over time, and it
|
||||
It can be used either via simple wrapper scripts (from shell or Perl) or via frontends that poll network devices and put a friendly user interface on it.
|
||||
|
||||
This package contains the python RRDtool bindings.
|
||||
%package ruby
|
||||
Summary: Ruby RRDtool bindings
|
||||
Group: Development/Bindings
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description ruby
|
||||
RRD (Round Robin Database) is a system to store and display time-series data (i.e. network bandwidth, machine-room temperature, server load average).
|
||||
It stores the data in a very compact way that will not expand over time, and it presents useful graphs by processing the data to enforce a certain data density.
|
||||
It can be used either via simple wrapper scripts (from shell or Perl) or via frontends that poll network devices and put a friendly user interface on it.
|
||||
|
||||
This package contains the ruby RRDtool bindings.
|
||||
|
||||
|
||||
%package ruby
|
||||
Summary: Ruby RRDtool bindings
|
||||
@ -103,6 +116,7 @@ Requires: %{name}-lua = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
RRD (Round Robin Database) is a system to store and display time-series data (i.e. network bandwidth, machine-room temperature, server load average).
|
||||
|
||||
It stores the data in a very compact way that will not expand over time, and it presents useful graphs by processing the data to enforce a certain data density.
|
||||
It can be used either via simple wrapper scripts (from shell or Perl) or via frontends that poll network devices and put a friendly user interface on it.
|
||||
|
||||
@ -110,16 +124,19 @@ This package allow you to use directly this library.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
#./autogen.sh
|
||||
%configure \
|
||||
--enable-shared \
|
||||
--enable-lua \
|
||||
--enable-perl-site-install \
|
||||
--with-perl-options='INSTALLDIRS="vendor"' \
|
||||
--with-ruby-options='sitedir="%{_libdir}/ruby/site_ruby"'
|
||||
# --with-tcllib=%{_libdir}
|
||||
|
||||
%make -j1
|
||||
%make -j1 LDFLAGS="`pkg-config --libs glib-2.0` -lwrap"
|
||||
|
||||
#cd examples
|
||||
#find . -name "*.pl" -exec perl -e 's;\015;;gi' -p -i \{\} \;
|
||||
@ -130,8 +147,6 @@ This package allow you to use directly this library.
|
||||
|
||||
install -D -m755 %{SOURCE1} %{buildroot}%{_bindir}/log2rrd.pl
|
||||
|
||||
install -m644 {C*,README,TODO} %{buildroot}%{rrddocdir}
|
||||
|
||||
# remove unpackaged files
|
||||
find %{buildroot}%{_prefix}/lib -name perllocal.pod -exec rm -f {} \;
|
||||
find %{buildroot}%{_prefix}/lib -name .packlist -exec rm -f {} \;
|
||||
@ -150,17 +165,19 @@ rm -f %{name}-%{version}-file
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/*
|
||||
%{_libdir}/*.so.*
|
||||
%{_unitdir}/rrdcached.service
|
||||
%{_unitdir}/rrdcached.socket
|
||||
%{_libdir}/rrdtool/ifOctets.tcl
|
||||
%{_libdir}/rrdtool/pkgIndex.tcl
|
||||
%{_libdir}/tclrrd1.5.3.so
|
||||
%dir %{_datadir}/rrdtool
|
||||
#%{_datadir}/rrdtool/ifOctets.tcl
|
||||
#%{_datadir}/rrdtool/pkgIndex.tcl
|
||||
%dir %{_datadir}/rrdtool/examples
|
||||
%{_datadir}/rrdtool/examples/*
|
||||
#%dir %{_datadir}/rrdtool/fonts
|
||||
#%{_datadir}/rrdtool/fonts/DejaVuSansMono-Roman.ttf
|
||||
%dir %{rrddocdir}
|
||||
%{_defaultdocdir}/%{name}-%{version}/C*
|
||||
%{_defaultdocdir}/%{name}-%{version}/README
|
||||
%{_defaultdocdir}/%{name}-%{version}/TODO
|
||||
%{rrddocdir}/html/*
|
||||
%{rrddocdir}/txt/*
|
||||
%{_mandir}/man1/*
|
||||
@ -168,7 +185,6 @@ rm -f %{name}-%{version}-file
|
||||
|
||||
%files lua
|
||||
%defattr(-,root,root)
|
||||
# FIXME: doesn't build with lua 5.2
|
||||
#%{_libdir}/lua/*/rrd.so.*
|
||||
|
||||
%files perl
|
||||
@ -188,17 +204,17 @@ rm -f %{name}-%{version}-file
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/*.a
|
||||
%{_libdir}/*.la
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/lib*.a
|
||||
%{_libdir}/lib*.la
|
||||
%{_libdir}/lib*.so
|
||||
#%{_libdir}/ruby/*/i586-linux/RRD.so
|
||||
%{_libdir}/pkgconfig/librrd.pc
|
||||
%{_includedir}/*.h
|
||||
#%{_libdir}/lua/*/rrd.a
|
||||
#%{_libdir}/lua/*/rrd.la
|
||||
#%{_libdir}/lua/*/rrd.so
|
||||
|
||||
%changelog
|
||||
* Tue May 19 2015 Automatic Build System <autodist@mambasoft.it> 1.5.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Nov 12 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.7-2mamba
|
||||
- perl 5.16 rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user