automatic version update by autodist [release 1.5.3-1mamba;Tue May 19 2015]

This commit is contained in:
Automatic Build System 2024-01-05 17:29:42 +01:00
parent baa3829894
commit 674a92cc2a
2 changed files with 48 additions and 15 deletions

View File

@ -0,0 +1,17 @@
diff -up rrdtool-1.4.7/configure.ac.lua-52 rrdtool-1.4.7/configure.ac
--- rrdtool-1.4.7/configure.ac.lua-52 2013-05-15 11:35:49.074334072 -0400
+++ rrdtool-1.4.7/configure.ac 2013-05-15 11:35:49.077334073 -0400
@@ -744,7 +744,12 @@ LUA_EOF
LIBS=
lua_havelib=no
LUA_HAVE_COMPAT51=DONT_HAVE_COMPAT51
- AC_SEARCH_LIBS(lua_call, lua$lua_vdot lua$lua_vndot lua,
+ if test "$lua_vndot" = "52"; then
+ CALL_FUNC=lua_callk
+ else
+ CALL_FUNC=lua_call
+ fi
+ AC_SEARCH_LIBS($CALL_FUNC, lua$lua_vdot lua$lua_vndot lua,
[AC_SEARCH_LIBS(luaL_register, lua$lua_vdot lua$lua_vndot lua,
[lua_havelib=LUA$lua_vndot],
[AC_SEARCH_LIBS(luaL_module, lualib$lua_vndot lualib$lua_vdot lualib,

View File

@ -1,8 +1,8 @@
%define rrddocdir %{_datadir}/doc/%{name}-%{version} %define rrddocdir %{_datadir}/doc/%{name}-%{version}
Name: rrdtool Name: rrdtool
Version: 1.4.7 Version: 1.5.3
Release: 2mamba Release: 1mamba
Summary: Round Robin Database Tool to store and display time-series data Summary: Round Robin Database Tool to store and display time-series data
Group: Applications/Databases Group: Applications/Databases
Vendor: openmamba Vendor: openmamba
@ -11,6 +11,7 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://oss.oetiker.ch/rrdtool/ URL: http://oss.oetiker.ch/rrdtool/
Source0: http://oss.oetiker.ch/rrdtool/pub/rrdtool-%{version}.tar.gz Source0: http://oss.oetiker.ch/rrdtool/pub/rrdtool-%{version}.tar.gz
Source1: rrdtool-log2rrd.pl Source1: rrdtool-log2rrd.pl
Patch0: rrdtool-1.4.8-lua-5.2.patch
License: GPL License: GPL
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
@ -82,6 +83,18 @@ It stores the data in a very compact way that will not expand over time, and it
It can be used either via simple wrapper scripts (from shell or Perl) or via frontends that poll network devices and put a friendly user interface on it. It can be used either via simple wrapper scripts (from shell or Perl) or via frontends that poll network devices and put a friendly user interface on it.
This package contains the python RRDtool bindings. This package contains the python RRDtool bindings.
%package ruby
Summary: Ruby RRDtool bindings
Group: Development/Bindings
Requires: %{name} = %{version}-%{release}
%description ruby
RRD (Round Robin Database) is a system to store and display time-series data (i.e. network bandwidth, machine-room temperature, server load average).
It stores the data in a very compact way that will not expand over time, and it presents useful graphs by processing the data to enforce a certain data density.
It can be used either via simple wrapper scripts (from shell or Perl) or via frontends that poll network devices and put a friendly user interface on it.
This package contains the ruby RRDtool bindings.
%package ruby %package ruby
Summary: Ruby RRDtool bindings Summary: Ruby RRDtool bindings
@ -103,6 +116,7 @@ Requires: %{name}-lua = %{version}-%{release}
%description devel %description devel
RRD (Round Robin Database) is a system to store and display time-series data (i.e. network bandwidth, machine-room temperature, server load average). RRD (Round Robin Database) is a system to store and display time-series data (i.e. network bandwidth, machine-room temperature, server load average).
It stores the data in a very compact way that will not expand over time, and it presents useful graphs by processing the data to enforce a certain data density. It stores the data in a very compact way that will not expand over time, and it presents useful graphs by processing the data to enforce a certain data density.
It can be used either via simple wrapper scripts (from shell or Perl) or via frontends that poll network devices and put a friendly user interface on it. It can be used either via simple wrapper scripts (from shell or Perl) or via frontends that poll network devices and put a friendly user interface on it.
@ -110,16 +124,19 @@ This package allow you to use directly this library.
%prep %prep
%setup -q %setup -q
%patch0 -p1
%build %build
#./autogen.sh
%configure \ %configure \
--enable-shared \ --enable-shared \
--enable-lua \
--enable-perl-site-install \ --enable-perl-site-install \
--with-perl-options='INSTALLDIRS="vendor"' \ --with-perl-options='INSTALLDIRS="vendor"' \
--with-ruby-options='sitedir="%{_libdir}/ruby/site_ruby"' --with-ruby-options='sitedir="%{_libdir}/ruby/site_ruby"'
# --with-tcllib=%{_libdir} # --with-tcllib=%{_libdir}
%make -j1 %make -j1 LDFLAGS="`pkg-config --libs glib-2.0` -lwrap"
#cd examples #cd examples
#find . -name "*.pl" -exec perl -e 's;\015;;gi' -p -i \{\} \; #find . -name "*.pl" -exec perl -e 's;\015;;gi' -p -i \{\} \;
@ -130,8 +147,6 @@ This package allow you to use directly this library.
install -D -m755 %{SOURCE1} %{buildroot}%{_bindir}/log2rrd.pl install -D -m755 %{SOURCE1} %{buildroot}%{_bindir}/log2rrd.pl
install -m644 {C*,README,TODO} %{buildroot}%{rrddocdir}
# remove unpackaged files # remove unpackaged files
find %{buildroot}%{_prefix}/lib -name perllocal.pod -exec rm -f {} \; find %{buildroot}%{_prefix}/lib -name perllocal.pod -exec rm -f {} \;
find %{buildroot}%{_prefix}/lib -name .packlist -exec rm -f {} \; find %{buildroot}%{_prefix}/lib -name .packlist -exec rm -f {} \;
@ -150,17 +165,19 @@ rm -f %{name}-%{version}-file
%defattr(-,root,root) %defattr(-,root,root)
%{_bindir}/* %{_bindir}/*
%{_libdir}/*.so.* %{_libdir}/*.so.*
%{_unitdir}/rrdcached.service
%{_unitdir}/rrdcached.socket
%{_libdir}/rrdtool/ifOctets.tcl %{_libdir}/rrdtool/ifOctets.tcl
%{_libdir}/rrdtool/pkgIndex.tcl %{_libdir}/rrdtool/pkgIndex.tcl
%{_libdir}/tclrrd1.5.3.so
%dir %{_datadir}/rrdtool %dir %{_datadir}/rrdtool
#%{_datadir}/rrdtool/ifOctets.tcl
#%{_datadir}/rrdtool/pkgIndex.tcl
%dir %{_datadir}/rrdtool/examples %dir %{_datadir}/rrdtool/examples
%{_datadir}/rrdtool/examples/* %{_datadir}/rrdtool/examples/*
#%dir %{_datadir}/rrdtool/fonts #%dir %{_datadir}/rrdtool/fonts
#%{_datadir}/rrdtool/fonts/DejaVuSansMono-Roman.ttf #%{_datadir}/rrdtool/fonts/DejaVuSansMono-Roman.ttf
%dir %{rrddocdir} %dir %{rrddocdir}
%{_defaultdocdir}/%{name}-%{version}/C*
%{_defaultdocdir}/%{name}-%{version}/README
%{_defaultdocdir}/%{name}-%{version}/TODO
%{rrddocdir}/html/* %{rrddocdir}/html/*
%{rrddocdir}/txt/* %{rrddocdir}/txt/*
%{_mandir}/man1/* %{_mandir}/man1/*
@ -168,7 +185,6 @@ rm -f %{name}-%{version}-file
%files lua %files lua
%defattr(-,root,root) %defattr(-,root,root)
# FIXME: doesn't build with lua 5.2
#%{_libdir}/lua/*/rrd.so.* #%{_libdir}/lua/*/rrd.so.*
%files perl %files perl
@ -188,17 +204,17 @@ rm -f %{name}-%{version}-file
%files devel %files devel
%defattr(-,root,root) %defattr(-,root,root)
%{_libdir}/*.a %{_libdir}/lib*.a
%{_libdir}/*.la %{_libdir}/lib*.la
%{_libdir}/*.so %{_libdir}/lib*.so
#%{_libdir}/ruby/*/i586-linux/RRD.so #%{_libdir}/ruby/*/i586-linux/RRD.so
%{_libdir}/pkgconfig/librrd.pc %{_libdir}/pkgconfig/librrd.pc
%{_includedir}/*.h %{_includedir}/*.h
#%{_libdir}/lua/*/rrd.a
#%{_libdir}/lua/*/rrd.la
#%{_libdir}/lua/*/rrd.so
%changelog %changelog
* Tue May 19 2015 Automatic Build System <autodist@mambasoft.it> 1.5.3-1mamba
- automatic version update by autodist
* Mon Nov 12 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.7-2mamba * Mon Nov 12 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.7-2mamba
- perl 5.16 rebuild - perl 5.16 rebuild