rpm/rpm-5.2.1-vendor_openmamba.patch

52 lines
1.9 KiB
Diff

diff -ru rpm-5.2.1.orig//configure.ac rpm-5.2.1/configure.ac
--- rpm-5.2.1.orig//configure.ac 2010-07-28 13:19:12.295008236 +0200
+++ rpm-5.2.1/configure.ac 2010-07-28 13:18:25.877741081 +0200
@@ -1606,7 +1606,7 @@
esac
RPMCANONVENDOR="$target_vendor"
case "${target_vendor}" in
-unknown|pc|ibm|redhat|pld|mandriva|conectiva|lvr|yellowdog|caos|crux|ark)
+unknown|pc|ibm|redhat|pld|mandriva|conectiva|lvr|yellowdog|caos|crux|ark|openmamba)
test -f /etc/redhat-release && RPMCANONVENDOR=redhat
test -f /etc/pld-release && RPMCANONVENDOR=pld
test -f /etc/mandriva-release && RPMCANONVENDOR=mandriva
@@ -1616,6 +1616,7 @@
test -f /etc/caos-release && RPMCANONVENDOR=caos
test -f /usr/bin/crux && RPMCANONVENDOR=crux
test -f /etc/ark-release && RPMCANONVENDOR=ark
+ test -f /etc/openmamba-release && RPMCANONVENDOR=openmamba
;;
esac
RPMCANONOS="$target_os_noversion"
@@ -1913,7 +1914,7 @@
AC_MSG_CHECKING([if building for a specfic vendor])
AC_ARG_WITH(
[vendor],
- AS_HELP_STRING([--with-vendor=VENDOR], [build with a supported vendor's specific set of changes: mandriva, ark, fedora]),
+ AS_HELP_STRING([--with-vendor=VENDOR], [build with a supported vendor's specific set of changes: mandriva, ark, fedora, openmamba]),
[if test ".$withval" != .no; then
case "$withval" in
"mandriva")
@@ -1925,6 +1926,9 @@
"fedora")
AC_DEFINE([RPM_VENDOR_FEDORA], 1, Vendor is Fedora)
;;
+ "openmamba")
+ AC_DEFINE([RPM_VENDOR_OPENMAMBA], 1, Vendor is openmamba)
+ ;;
esac
AC_MSG_RESULT([$withval])
else
--- rpm-5.2.1.orig/config.h.in 2010-05-01 19:03:00.000000000 +0200
+++ rpm-5.2.1/config.h.in 2010-07-28 14:17:07.456750377 +0200
@@ -798,6 +798,9 @@
/* Vendor is Mandriva */
#undef RPM_VENDOR_MANDRIVA
+/* Vendor is openmamba */
+#undef RPM_VENDOR_OPENMAMBA
+
/* The size of `char', as computed by sizeof. */
#undef SIZEOF_CHAR