39 lines
1.5 KiB
Diff
39 lines
1.5 KiB
Diff
diff -Nru rpm-5.2.1.orig/scripts/brp-infodir rpm-5.2.1/scripts/brp-infodir
|
|
--- rpm-5.1.6.orig/scripts/brp-infodir 1970-01-01 01:00:00.000000000 +0100
|
|
+++ rpm-5.1.6/scripts/brp-infodir 2009-01-01 18:09:52.000000000 +0100
|
|
@@ -0,0 +1,12 @@
|
|
+#!/bin/sh
|
|
+
|
|
+# If using normal root, avoid changing anything.
|
|
+if [ -z "$RPM_BUILD_ROOT" -o "$RPM_BUILD_ROOT" = "/" ]; then
|
|
+ exit 0
|
|
+fi
|
|
+
|
|
+# Delete /usr/share/info/dir file
|
|
+if [ -f $RPM_BUILD_ROOT/usr/share/info/dir ]; then
|
|
+ rm -f $RPM_BUILD_ROOT/usr/share/info/dir
|
|
+fi
|
|
+
|
|
diff -ru rpm-5.2.1.orig//scripts/Makefile.in rpm-5.2.1/scripts/Makefile.in
|
|
--- rpm-5.2.1.orig//scripts/Makefile.in 2010-05-01 18:57:12.000000000 +0200
|
|
+++ rpm-5.2.1/scripts/Makefile.in 2010-07-28 19:37:45.796740786 +0200
|
|
@@ -429,7 +429,7 @@
|
|
|
|
EXTRA_DIST = \
|
|
brp-compress brp-python-bytecompile brp-java-gcjcompile \
|
|
- brp-strip brp-strip-comment-note brp-nobuildrootpath \
|
|
+ brp-infodir brp-strip brp-strip-comment-note brp-nobuildrootpath \
|
|
brp-strip-shared brp-strip-static-archive brp-sparc64-linux \
|
|
brp-implant-ident-static brp-java-repack-jars \
|
|
check-files cross-build \
|
|
@@ -460,7 +460,7 @@
|
|
bin_SCRIPTS = gendiff
|
|
pkglib_SCRIPTS = \
|
|
brp-compress brp-python-bytecompile brp-java-gcjcompile \
|
|
- brp-strip brp-strip-comment-note brp-nobuildrootpath \
|
|
+ brp-infodir brp-strip brp-strip-comment-note brp-nobuildrootpath \
|
|
brp-strip-shared brp-strip-static-archive brp-sparc64-linux \
|
|
check-files cross-build executabledeps.sh \
|
|
find-debuginfo.sh find-lang.sh find-prov.pl find-req.pl \
|
|
Solo in rpm-5.2.1/scripts: Makefile.in.orig
|