49 lines
1.9 KiB
Diff
49 lines
1.9 KiB
Diff
diff -Nru rpm-4.4.8.orig/doc/manual/builddependencies rpm-4.4.8/doc/manual/builddependencies
|
|
--- rpm-4.4.8.orig/doc/manual/builddependencies 2005-10-25 23:03:33.000000000 +0200
|
|
+++ rpm-4.4.8/doc/manual/builddependencies 2008-01-16 12:32:49.000000000 +0100
|
|
@@ -29,7 +29,7 @@
|
|
\verbatim
|
|
rpm -U /mnt/rpm/comps/powertools/6.2/i386/InDependence-1.0-3.i386.rpm
|
|
rpm -i /mnt/rpm/comps/dist/6.2/SRPMS/gnorpm-0.9-11.src.rpm
|
|
- cd /usr/src/rpm/SPECS
|
|
+ cd /usr/src/RPM/SPECS
|
|
dep -detail rpmbuild -ba gnorpm.spec >& xxx
|
|
...
|
|
(the build will take longer since both dep and strace are pigs)
|
|
diff -Nru rpm-4.4.8.orig/lib/rpmrc.c rpm-4.4.8/lib/rpmrc.c
|
|
--- rpm-4.4.8.orig/lib/rpmrc.c 2007-02-04 07:14:56.000000000 +0100
|
|
+++ rpm-4.4.8/lib/rpmrc.c 2008-01-16 12:33:36.000000000 +0100
|
|
@@ -585,7 +585,7 @@
|
|
addMacro(NULL, "___build_pre", NULL, ___build_pre, RMIL_DEFAULT);
|
|
|
|
setVarDefault(-1, "_topdir",
|
|
- "/usr/src/rpm", "%{_usr}/src/rpm");
|
|
+ "/usr/src/RPM", "%{_usr}/src/RPM");
|
|
setVarDefault(-1, "_tmppath",
|
|
"/var/tmp", "%{_var}/tmp");
|
|
setVarDefault(-1, "_dbpath",
|
|
diff -Nru rpm-4.4.8.orig/macros.in rpm-4.4.8/macros.in
|
|
--- rpm-4.4.8.orig/macros.in 2007-02-13 15:39:55.000000000 +0100
|
|
+++ rpm-4.4.8/macros.in 2008-01-16 12:34:18.000000000 +0100
|
|
@@ -233,7 +233,7 @@
|
|
%tmpdir %{_tmppath}
|
|
|
|
# Path to top of build area.
|
|
-%_topdir %{_usrsrc}/rpm
|
|
+%_topdir %{_usrsrc}/RPM
|
|
|
|
#==============================================================================
|
|
# ---- Optional rpmrc macros.
|
|
diff -Nru rpm-4.4.8.orig/Makefile.in rpm-4.4.8/Makefile.in
|
|
--- rpm-4.4.8.orig/Makefile.in 2007-02-11 03:34:33.000000000 +0100
|
|
+++ rpm-4.4.8/Makefile.in 2008-01-16 12:34:31.000000000 +0100
|
|
@@ -501,7 +501,7 @@
|
|
rpm2cpio_LDFLAGS = $(myLDFLAGS) $(staticLDFLAGS)
|
|
rpm2cpio_LDADD = $(myLDADD) @LIBMISC@
|
|
CVSTAG = r$(subst .,-,$(VERSION))
|
|
-pkgsrcdir = $(prefix)/src/rpm
|
|
+pkgsrcdir = $(prefix)/src/RPM
|
|
ACLOCAL_AMFLAGS = -I m4
|
|
all: config.h
|
|
$(MAKE) $(AM_MAKEFLAGS) all-recursive
|