x86_64: set libexecdir as libexec64; arm: force armv5t; set default_patch_fuzz to 1 [release 4.14.2.1-11mamba;Wed Jul 24 2019]
This commit is contained in:
parent
042b296690
commit
b3f450637d
16
rpm-4.14.2.1-arm-openamba-force-armv5t.patch
Normal file
16
rpm-4.14.2.1-arm-openamba-force-armv5t.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -Nru rpm-4.14.2.1.orig/rpmrc.in rpm-4.14.2.1/rpmrc.in
|
||||
--- rpm-4.14.2.1.orig/rpmrc.in 2019-07-24 09:26:34.006590165 +0200
|
||||
+++ rpm-4.14.2.1/rpmrc.in 2019-07-24 09:30:47.099602442 +0200
|
||||
@@ -74,10 +74,10 @@
|
||||
optflags: armv5tl -O2 -g -march=armv5t
|
||||
optflags: armv5tel -O2 -g -march=armv5te
|
||||
optflags: armv5tejl -O2 -g -march=armv5te
|
||||
-optflags: armv6l -O2 -g -march=armv6
|
||||
+optflags: armv6l -O2 -g -march=armv5t
|
||||
optflags: armv6hl -O2 -g -march=armv6 -mfloat-abi=hard -mfpu=vfp
|
||||
|
||||
-optflags: armv7l -O2 -g -march=armv7
|
||||
+optflags: armv7l -O2 -g -march=armv5t
|
||||
optflags: armv7hl -O2 -g -march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16
|
||||
optflags: armv7hnl -O2 -g -march=armv7-a -mfloat-abi=hard -mfpu=neon
|
||||
|
12
rpm-4.14.2.1-increase_default_patch_fuzz.patch
Normal file
12
rpm-4.14.2.1-increase_default_patch_fuzz.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru rpm-4.14.2.1.orig/macros.in rpm-4.14.2.1/macros.in
|
||||
--- rpm-4.14.2.1.orig/macros.in 2019-07-24 09:31:50.726857122 +0200
|
||||
+++ rpm-4.14.2.1/macros.in 2019-07-24 09:32:34.504032383 +0200
|
||||
@@ -412,7 +412,7 @@
|
||||
#%vendor
|
||||
|
||||
# Default fuzz level for %patch in spec file.
|
||||
-%_default_patch_fuzz 0
|
||||
+%_default_patch_fuzz 1
|
||||
|
||||
# Default patch flags
|
||||
#%_default_patch_flags -s
|
16
rpm-4.14.2.1-openmamba-buildroot.patch
Normal file
16
rpm-4.14.2.1-openmamba-buildroot.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -Nru rpm-4.14.2.1.orig/macros.in rpm-4.14.2.1/macros.in
|
||||
--- rpm-4.14.2.1.orig/macros.in 2019-07-24 09:51:46.612355870 +0200
|
||||
+++ rpm-4.14.2.1/macros.in 2019-07-24 09:53:58.089565829 +0200
|
||||
@@ -272,10 +272,10 @@
|
||||
%_srcrpmdir %{_topdir}/SRPMS
|
||||
|
||||
# The directory where buildroots will be created.
|
||||
-%_buildrootdir %{_topdir}/BUILDROOT
|
||||
+%_buildrootdir %{_tmppath}
|
||||
|
||||
# Build root path, where %install installs the package during build.
|
||||
-%buildroot %{_buildrootdir}/%{NAME}-%{VERSION}-%{RELEASE}.%{_arch}
|
||||
+%buildroot %{_tmppath}/%{NAME}-%{VERSION}-root
|
||||
|
||||
# Directory where temporaray files can be created.
|
||||
%_tmppath %{_var}/tmp
|
14
rpm-4.14.2.1-remove_macro_expanded_in_comment_warning.patch
Normal file
14
rpm-4.14.2.1-remove_macro_expanded_in_comment_warning.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- rpm-4.14.2.1/build/parseSpec.c.orig 2019-07-22 22:47:42.786822516 +0200
|
||||
+++ rpm-4.14.2.1/build/parseSpec.c 2019-07-22 22:48:49.400147867 +0200
|
||||
@@ -206,11 +206,6 @@
|
||||
bufA++;
|
||||
bufB++;
|
||||
}
|
||||
-
|
||||
- if (*bufA != '\0' || *bufB != '\0')
|
||||
- rpmlog(RPMLOG_WARNING,
|
||||
- _("Macro expanded in comment on line %d: %s\n"),
|
||||
- spec->lineNum, bufA);
|
||||
}
|
||||
|
||||
free(spec->lbuf);
|
22
rpm.spec
22
rpm.spec
@ -2,8 +2,10 @@
|
||||
%define __prefix %{?_prefix}%{!?_prefix:/usr}
|
||||
%ifarch x86_64
|
||||
%{?!_lib: %define _lib lib64}
|
||||
%{?!_libexec: %define _libexec libexec64}
|
||||
%else
|
||||
%{?!_lib: %define _lib lib}
|
||||
%{?!_libexec: %define _libexec libexec}
|
||||
%endif
|
||||
%define __bindir %{__prefix}/bin
|
||||
%define __includedir %{__prefix}/include
|
||||
@ -15,7 +17,7 @@
|
||||
Name: rpm
|
||||
Epoch: 1
|
||||
Version: 4.14.2.1
|
||||
Release: 9mamba
|
||||
Release: 11mamba
|
||||
Summary: The RPM Package Manager (RPM) is a powerful package management system
|
||||
Group: System/Management
|
||||
Vendor: openmamba
|
||||
@ -31,6 +33,10 @@ Patch3: rpm-4.14.2.1-arm-openmamba-arch-support.patch
|
||||
Patch4: rpm-4.14.2.1-i586-openmamba-arch-support.patch
|
||||
Patch5: rpm-4.14.2.1-debuginfo-rename-to-debug.patch
|
||||
Patch6: rpm-4.14.2.1-add-usrlibrpm-macro.patch
|
||||
Patch7: rpm-4.14.2.1-remove_macro_expanded_in_comment_warning.patch
|
||||
Patch8: rpm-4.14.2.1-arm-openamba-force-armv5t.patch
|
||||
Patch9: rpm-4.14.2.1-increase_default_patch_fuzz.patch
|
||||
Patch10: rpm-4.14.2.1-openmamba-buildroot.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -119,6 +125,10 @@ This package should be installed if you want to develop Python programs that wil
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
@ -153,6 +163,10 @@ mkdir -p %{buildroot}%{_usr}/src/RPM/{BUILD,RPMS/{arm,i586,noarch,x86_64},SOURCE
|
||||
# install rpm macros for openmamba
|
||||
install -D -m 644 %{S:2} %{buildroot}%{_sysconfdir}/rpm%{?program_suffix}/macros.openmamba
|
||||
|
||||
%ifarch x86_64
|
||||
sed -i "s|/libexec$|/%{_libexec}|" %{buildroot}%{_prefix}/lib/rpm/platform/x86_64-linux/macros
|
||||
%endif
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
@ -256,6 +270,12 @@ _EOF
|
||||
%{python27_sitearch}/rpm/*
|
||||
|
||||
%changelog
|
||||
* Wed Jul 24 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 4.14.2.1-11mamba
|
||||
- x86_64: set libexecdir as libexec64; arm: force armv5t; set default_patch_fuzz to 1
|
||||
|
||||
* Mon Jul 22 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 4.14.2.1-10mamba
|
||||
- added patch to remove 'Macro expanded in commit...' warnings
|
||||
|
||||
* Sun Jul 21 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 4.14.2.1-9mamba
|
||||
- i586: patch rpmrc to set as default x86 arch; debuginfo: patch macros to rename suffix to debug
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user