find-provides: patch to support parsing of file 5.34 output [release 5.2.1-35mamba;Wed Aug 29 2018]
This commit is contained in:
parent
635a245c61
commit
9dc4f9becf
11
rpm-5.2.1-find-provides-file-5.34.patch
Normal file
11
rpm-5.2.1-find-provides-file-5.34.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- rpm-5.2.1/autodeps/linux.prov.orig 2018-08-29 22:18:06.585306308 +0200
|
||||||
|
+++ rpm-5.2.1/autodeps/linux.prov 2018-08-29 22:19:07.405583776 +0200
|
||||||
|
@@ -9,7 +9,7 @@
|
||||||
|
filelist=`sed "s/['\"]/\\\&/g"`
|
||||||
|
|
||||||
|
solist=$(echo $filelist | grep "\\.so" | grep -v "^/lib/ld.so" | \
|
||||||
|
- xargs file -L 2>/dev/null | grep "ELF.*shared object" | cut -d: -f1)
|
||||||
|
+ xargs file -L 2>/dev/null | grep "ELF.*shared object\|ELF.*LSB pie executable" | cut -d: -f1)
|
||||||
|
pythonlist=
|
||||||
|
tcllist=
|
||||||
|
|
45
rpm-5.2.1-glibc-2.28.patch
Normal file
45
rpm-5.2.1-glibc-2.28.patch
Normal file
@ -0,0 +1,45 @@
|
|||||||
|
diff -ru rpm-5.2.1/rpmio/gzdio.c rpm-5.2.1.orig/rpmio/gzdio.c
|
||||||
|
--- rpm-5.2.1/rpmio/gzdio.c 2009-03-25 21:26:46.000000000 +0100
|
||||||
|
+++ rpm-5.2.1.orig/rpmio/gzdio.c 2018-08-13 12:53:38.122742573 +0200
|
||||||
|
@@ -375,7 +375,7 @@
|
||||||
|
int rc;
|
||||||
|
#if defined(HAVE_GZSEEK)
|
||||||
|
#ifdef USE_COOKIE_SEEK_POINTER
|
||||||
|
- _IO_off64_t p = *pos;
|
||||||
|
+ off64_t p = *pos;
|
||||||
|
#else
|
||||||
|
off_t p = pos;
|
||||||
|
#endif
|
||||||
|
diff -ru rpm-5.2.1/rpmio/rpmio.c rpm-5.2.1.orig/rpmio/rpmio.c
|
||||||
|
--- rpm-5.2.1/rpmio/rpmio.c 2009-11-11 23:27:52.000000000 +0100
|
||||||
|
+++ rpm-5.2.1.orig/rpmio/rpmio.c 2018-08-13 12:56:03.182473172 +0200
|
||||||
|
@@ -451,7 +451,7 @@
|
||||||
|
/*@modifies fileSystem, internalState @*/
|
||||||
|
{
|
||||||
|
#ifdef USE_COOKIE_SEEK_POINTER
|
||||||
|
- _IO_off64_t p = *pos;
|
||||||
|
+ off64_t p = *pos;
|
||||||
|
#else
|
||||||
|
off_t p = pos;
|
||||||
|
#endif
|
||||||
|
@@ -2424,7 +2424,7 @@
|
||||||
|
int Fseek(FD_t fd, _libio_off_t offset, int whence) {
|
||||||
|
fdio_seek_function_t _seek;
|
||||||
|
#ifdef USE_COOKIE_SEEK_POINTER
|
||||||
|
- _IO_off64_t o64 = offset;
|
||||||
|
+ off64_t o64 = offset;
|
||||||
|
_libio_pos_t pos = &o64;
|
||||||
|
#else
|
||||||
|
_libio_pos_t pos = offset;
|
||||||
|
diff -ru rpm-5.2.1/rpmio/rpmio.h rpm-5.2.1.orig/rpmio/rpmio.h
|
||||||
|
--- rpm-5.2.1/rpmio/rpmio.h 2009-03-26 21:09:03.000000000 +0100
|
||||||
|
+++ rpm-5.2.1.orig/rpmio/rpmio.h 2018-08-13 12:53:04.208571677 +0200
|
||||||
|
@@ -26,7 +26,7 @@
|
||||||
|
#if !defined(__LCLINT__) && !defined(__UCLIBC__) && defined(__GLIBC__) && \
|
||||||
|
(__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 2))
|
||||||
|
#define USE_COOKIE_SEEK_POINTER 1
|
||||||
|
-typedef _IO_off64_t _libio_off_t;
|
||||||
|
+typedef off64_t _libio_off_t;
|
||||||
|
typedef _libio_off_t * _libio_pos_t;
|
||||||
|
#else
|
||||||
|
typedef off_t _libio_off_t;
|
22
rpm.spec
22
rpm.spec
@ -33,7 +33,7 @@
|
|||||||
|
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: 5.2.1
|
Version: 5.2.1
|
||||||
Release: 31mamba
|
Release: 35mamba
|
||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Group: System/Management
|
Group: System/Management
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -105,6 +105,8 @@ Patch66: rpm-5.2.1-find_lang_support_localized_qt_and_man_files.patch
|
|||||||
Patch67: rpm-5.2.1-dont-fail-on-postun.patch
|
Patch67: rpm-5.2.1-dont-fail-on-postun.patch
|
||||||
Patch68: rpm-5.2.1-file-5.30.patch
|
Patch68: rpm-5.2.1-file-5.30.patch
|
||||||
Patch69: rpm-5.2.1-rpmdb-yum-disable-assert.patch
|
Patch69: rpm-5.2.1-rpmdb-yum-disable-assert.patch
|
||||||
|
Patch70: rpm-5.2.1-glibc-2.28.patch
|
||||||
|
Patch71: rpm-5.2.1-find-provides-file-5.34.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -313,6 +315,8 @@ This package should be installed if you want to develop Python programs that wil
|
|||||||
%patch67 -p1
|
%patch67 -p1
|
||||||
%patch68 -p1
|
%patch68 -p1
|
||||||
%patch69 -p1
|
%patch69 -p1
|
||||||
|
%patch70 -p1
|
||||||
|
%patch71 -p1
|
||||||
|
|
||||||
mkdir platform-macros
|
mkdir platform-macros
|
||||||
cd platform-macros
|
cd platform-macros
|
||||||
@ -365,8 +369,8 @@ CC=%{_target_platform}-gcc \
|
|||||||
--with-lua \
|
--with-lua \
|
||||||
--with-sqlite3 \
|
--with-sqlite3 \
|
||||||
--with-libelf \
|
--with-libelf \
|
||||||
--with-file \
|
--with-file=external \
|
||||||
--with-bzip2 \
|
--with-bzip2=external \
|
||||||
--with-xz=external \
|
--with-xz=external \
|
||||||
--with-vendor=openmamba \
|
--with-vendor=openmamba \
|
||||||
%if %{with_apidocs}
|
%if %{with_apidocs}
|
||||||
@ -634,6 +638,18 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Aug 29 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 5.2.1-35mamba
|
||||||
|
- find-provides: patch to support parsing of file 5.34 output
|
||||||
|
|
||||||
|
* Tue Aug 28 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 5.2.1-34mamba
|
||||||
|
- rebuilt with bzip2 external
|
||||||
|
|
||||||
|
* Tue Aug 28 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 5.2.1-33mamba
|
||||||
|
- rebuild using external file (libmagic)
|
||||||
|
|
||||||
|
* Mon Aug 13 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 5.2.1-32mamba
|
||||||
|
- patched to build against glibc 2.28
|
||||||
|
|
||||||
* Sat Aug 26 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 5.2.1-31mamba
|
* Sat Aug 26 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 5.2.1-31mamba
|
||||||
- added a patch to remove an assert and fix package installation with yum
|
- added a patch to remove an assert and fix package installation with yum
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user