fix shebank in pythondistdeps.py to use python3 instead of python [release 4.16.1.2-3mamba;Sun Mar 07 2021]
This commit is contained in:
parent
5cfbd87e9c
commit
8df5e00eea
@ -1,6 +1,6 @@
|
||||
--- rpm-4.14.2.1/rpmrc.in.orig 2019-07-14 20:06:54.441795887 +0200
|
||||
+++ rpm-4.14.2.1/rpmrc.in 2019-07-14 20:24:51.384981318 +0200
|
||||
@@ -206,15 +206,16 @@
|
||||
--- rpm-4.16.1.2.orig/rpmrc.in 2020-05-28 12:04:25.075136894 +0200
|
||||
+++ rpm-4.16.1.2/rpmrc.in 2021-03-06 20:47:36.966105227 +0100
|
||||
@@ -209,15 +209,16 @@
|
||||
arch_canon: mips64: mips64 11
|
||||
arch_canon: mips64el: mips64el 11
|
||||
|
||||
@ -24,18 +24,18 @@
|
||||
+arch_canon: armv7l: arm 12
|
||||
arch_canon: armv7hl: armv7hl 12
|
||||
arch_canon: armv7hnl: armv7hnl 12
|
||||
|
||||
@@ -456,7 +457,8 @@
|
||||
arch_canon: armv8l: armv8l 12
|
||||
@@ -464,7 +465,8 @@
|
||||
arch_compat: armv5tl: armv4tl
|
||||
arch_compat: armv4tl: armv4l
|
||||
arch_compat: armv4l: armv3l
|
||||
-arch_compat: armv3l: noarch
|
||||
+arch_compat: armv3l: arm
|
||||
+arch_compat: arm: noarch
|
||||
arch_compat: armv8hl: armv7hl
|
||||
arch_compat: armv7hnl: armv7hl
|
||||
arch_compat: armv7hl: armv6hl
|
||||
arch_compat: armv6hl: noarch
|
||||
@@ -585,7 +587,8 @@
|
||||
@@ -595,7 +597,8 @@
|
||||
buildarch_compat: armv5tl: armv4tl
|
||||
buildarch_compat: armv4tl: armv4l
|
||||
buildarch_compat: armv4l: armv3l
|
||||
@ -43,5 +43,5 @@
|
||||
+buildarch_compat: armv3l: arm
|
||||
+buildarch_compat: arm: noarch
|
||||
|
||||
buildarch_compat: armv7hnl: armv7hl
|
||||
buildarch_compat: armv7hl: armv6hl
|
||||
buildarch_compat: armv8hcnl: armv8hnl
|
||||
buildarch_compat: armv8hnl: armv8hl
|
77
rpm.spec
77
rpm.spec
@ -1,6 +1,6 @@
|
||||
#% define program_suffix 4
|
||||
%define __prefix %{?_prefix}%{!?_prefix:/usr}
|
||||
%ifarch x86_64
|
||||
%ifarch x86_64 aarch64
|
||||
%{?!_lib: %define _lib lib64}
|
||||
%{?!_libexec: %define _libexec libexec64}
|
||||
%else
|
||||
@ -16,8 +16,8 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: rpm
|
||||
Epoch: 1
|
||||
Version: 4.14.3
|
||||
Release: 2mamba
|
||||
Version: 4.16.1.2
|
||||
Release: 3mamba
|
||||
Summary: The RPM Package Manager (RPM) is a powerful package management system
|
||||
Group: System/Management
|
||||
Vendor: openmamba
|
||||
@ -29,7 +29,7 @@ Source2: rpm4-macros_openmamba
|
||||
Patch0: rpm-4.14.2.1-fix-rebuilddb-from-rpm-5.2.patch
|
||||
Patch1: rpm-4.14.2.1-fix-rebuilddb-from-rpm-5.2-better.patch
|
||||
Patch2: rpm-4.14.2.1-fix-missing-translations-from-rpm4-segfault.patch
|
||||
Patch3: rpm-4.14.2.1-arm-openmamba-arch-support.patch
|
||||
Patch3: rpm-4.16.1.2-arm-openmamba-arch-support.patch
|
||||
Patch4: rpm-4.14.2.1-i586-openmamba-arch-support.patch
|
||||
Patch5: rpm-4.14.2.1-debuginfo-rename-to-debug.patch
|
||||
Patch6: rpm-4.14.2.1-add-usrlibrpm-macro.patch
|
||||
@ -42,35 +42,40 @@ Patch12: rpm-4.14.2.1-find-lang-qt-fix.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libacl-devel
|
||||
BuildRequires: libarchive-devel
|
||||
BuildRequires: libattr-devel
|
||||
BuildRequires: libaudit-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcap-ng-devel
|
||||
BuildRequires: libdb53-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libdw-devel
|
||||
BuildRequires: libelf-devel
|
||||
BuildRequires: liblmdb-devel
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: libgomp-devel
|
||||
BuildRequires: libgpg-error-devel
|
||||
BuildRequires: liblua-devel
|
||||
BuildRequires: liblz4-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: liblzo-devel
|
||||
BuildRequires: libmagic-devel
|
||||
BuildRequires: libnettle-devel
|
||||
BuildRequires: libnss-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpopt-devel
|
||||
BuildRequires: libpython3-devel
|
||||
BuildRequires: libpython27-devel
|
||||
BuildRequires: libreadline-devel
|
||||
BuildRequires: libsqlite-devel
|
||||
BuildRequires: libsystemd-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: libzstd-devel
|
||||
BuildRequires: python3
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: setup >= 1.2.0
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: rpm-build
|
||||
Obsoletes: rpm-build
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Obsoletes: rpm-build < 1:4.16.1.2
|
||||
|
||||
%description
|
||||
The RPM Package Manager (RPM) is a powerful package management system capable of building computer software from source into easily distributable packages installing, updating and uninstalling packaged software querying detailed information about the packaged software, whether installed or not verifying integrity of packaged software and resulting software installation.
|
||||
@ -98,28 +103,18 @@ Summary: Development files for %{name}
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: pkg-config
|
||||
Provides: rpm-devel
|
||||
Obsoletes: rpm-devel
|
||||
Obsoletes: rpm-devel < 1:4.16.1.2
|
||||
|
||||
%description -n lib%{name}-devel
|
||||
This package contains libraries and header files for developing applications that use %{name}.
|
||||
|
||||
%package -n python-rpm
|
||||
Summary: Python bindings for apps which will manipulate RPM packages
|
||||
Group: Development/Libraries/Python
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: python27
|
||||
Provides: python-rpm4
|
||||
Obsoletes: python-rpm4
|
||||
|
||||
%description -n python-rpm
|
||||
The rpm-python package contains a module which permits applications written in the Python programming language to use the interface supplied by RPM (RPM Package Manager) libraries.
|
||||
This package should be installed if you want to develop Python programs that will manipulate RPM packages and databases.
|
||||
|
||||
%package -n python-rpm-py3
|
||||
Summary: Python bindings for apps which will manipulate RPM packages
|
||||
Group: Development/Libraries/Python
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: python3
|
||||
Obsoletes: python-rpm < 1:4.16.1.2
|
||||
Obsoletes: python-rpm4 < 1:4.16.1.2
|
||||
|
||||
%description -n python-rpm-py3
|
||||
The rpm-python package contains a module which permits applications written in the Python programming language to use the interface supplied by RPM (RPM Package Manager) libraries.
|
||||
@ -144,9 +139,9 @@ This package should be installed if you want to develop Python programs that wil
|
||||
%patch11 -p1
|
||||
%patch12 -p1
|
||||
|
||||
sed -i "s,| arm-\* |,| aarch64-\* | arm-\* |," config.sub
|
||||
sed -i "s|/usr/bin/python$|%{__python3}|" scripts/pythondistdeps.py
|
||||
|
||||
cp -a python python27
|
||||
./autogen.sh --noconfigure
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
@ -170,27 +165,14 @@ cp -a python python27
|
||||
|
||||
%make
|
||||
|
||||
# Build python 2.7 legacy
|
||||
cd python27
|
||||
cp ../python/Makefile .
|
||||
sed -i "s|%{python3_inc}|%{python_inc}|" Makefile
|
||||
sed -i "s|%{python3_sitearch}|%{python_sitearch}|" Makefile
|
||||
sed -i "s|%{python3_sitelib}|%{python_sitelib}|" Makefile
|
||||
sed -i "s|python%{python3_version}[m]*|python%{python_version}|" Makefile
|
||||
sed -i "s|%{__python3}|%{__python}|" Makefile
|
||||
|
||||
%make PYTHON_VERSION=2.7
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C python27 PYTHON_VERSION=2.7
|
||||
|
||||
%makeinstall
|
||||
|
||||
%find_lang rpm --with-man --all-name || touch rpm.lang
|
||||
|
||||
# create system-wide build directories
|
||||
mkdir -p %{buildroot}%{_usr}/src/RPM/{BUILD,RPMS/{arm,i586,noarch,x86_64},SOURCES,SPECS,SRPMS}
|
||||
mkdir -p %{buildroot}%{_usr}/src/RPM/{BUILD,RPMS/{aarch64,arm,i586,noarch,x86_64},SOURCES,SPECS,SRPMS}
|
||||
|
||||
# install rpm macros for openmamba
|
||||
install -D -m 644 %{S:2} %{buildroot}%{_sysconfdir}/rpm%{?program_suffix}/macros.openmamba
|
||||
@ -264,8 +246,8 @@ _EOF
|
||||
%attr(775,root,packager) /usr/src/RPM/RPMS/*
|
||||
%{_mandir}/man1/gendiff.1*
|
||||
%{_mandir}/man8/rpm-misc.8*
|
||||
%{_mandir}/man8/rpm-plugin-systemd-inhibit.8*
|
||||
%{_mandir}/man8/rpm.8*
|
||||
%{_mandir}/man8/rpm2archive.8*
|
||||
%{_mandir}/man8/rpm2cpio.8*
|
||||
%{_mandir}/man8/rpmbuild.8*
|
||||
%{_mandir}/man8/rpmdb.8*
|
||||
@ -274,6 +256,7 @@ _EOF
|
||||
%{_mandir}/man8/rpmkeys.8*
|
||||
%{_mandir}/man8/rpmsign.8*
|
||||
%{_mandir}/man8/rpmspec.8*
|
||||
%{_mandir}/man8/rpm-plugin*.8*
|
||||
%doc COPYING CREDITS
|
||||
|
||||
%files -n lib%{name}
|
||||
@ -300,17 +283,21 @@ _EOF
|
||||
%{_libdir}/pkgconfig/rpm.pc
|
||||
%doc ChangeLog README
|
||||
|
||||
%files -n python-rpm
|
||||
%defattr(-,root,root)
|
||||
%dir %{python_sitearch}/rpm
|
||||
%{python_sitearch}/rpm/*
|
||||
|
||||
%files -n python-rpm-py3
|
||||
%defattr(-,root,root)
|
||||
%dir %{python3_sitearch}/rpm
|
||||
%{python3_sitearch}/rpm/*
|
||||
|
||||
%changelog
|
||||
* Sun Mar 07 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 4.16.1.2-3mamba
|
||||
- fix shebank in pythondistdeps.py to use python3 instead of python
|
||||
|
||||
* Sun Mar 07 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 4.16.1.2-2mamba
|
||||
- python-rpm-py3: fix obsolete for python-rpm and python-rpm4 (add epoch)
|
||||
|
||||
* Sat Mar 06 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 4.16.1.2-1mamba
|
||||
- update to 4.16.1.2
|
||||
|
||||
* Fri Aug 14 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 4.14.3-2mamba
|
||||
- preserve legacy python-rpm (python 2.7) and add python-rpm-py3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user