patches: pythondistdeps: use normal deps instead of rich deps; rpmrc: armv7l: set march=armv7-a [release 4.16.1.3-2mamba;Sun Apr 18 2021]
This commit is contained in:
parent
71acf3f861
commit
77b62dbd50
@ -1,5 +1,14 @@
|
||||
--- rpm-4.16.1.2.orig/rpmrc.in 2020-05-28 12:04:25.075136894 +0200
|
||||
+++ rpm-4.16.1.2/rpmrc.in 2021-03-06 20:47:36.966105227 +0100
|
||||
--- rpm-4.16.1.3/rpmrc.in.orig 2021-04-18 13:54:39.393090505 +0200
|
||||
+++ rpm-4.16.1.3/rpmrc.in 2021-04-18 13:55:13.930721298 +0200
|
||||
@@ -77,7 +77,7 @@
|
||||
optflags: armv6l -O2 -g -march=armv6
|
||||
optflags: armv6hl -O2 -g -march=armv6 -mfloat-abi=hard -mfpu=vfp
|
||||
|
||||
-optflags: armv7l -O2 -g -march=armv7
|
||||
+optflags: armv7l -O2 -g -march=armv7-a
|
||||
optflags: armv7hl -O2 -g -march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16
|
||||
optflags: armv7hnl -O2 -g -march=armv7-a -mfloat-abi=hard -mfpu=neon
|
||||
optflags: armv8l -O2 -g -march=armv8-a
|
||||
@@ -209,15 +209,16 @@
|
||||
arch_canon: mips64: mips64 11
|
||||
arch_canon: mips64el: mips64el 11
|
13
rpm-4.16.1.3-pythondistdeps-no-richdeps.patch
Normal file
13
rpm-4.16.1.3-pythondistdeps-no-richdeps.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- rpm-4.16.1.3/scripts/pythondistdeps.py.orig 2021-04-18 13:15:35.419281754 +0200
|
||||
+++ rpm-4.16.1.3/scripts/pythondistdeps.py 2021-04-18 13:15:42.040402573 +0200
|
||||
@@ -420,7 +420,9 @@
|
||||
print(spec_list[0])
|
||||
else:
|
||||
# Sort spec_list so that the results can be tested easily
|
||||
- print('({})'.format(' with '.join(sorted(spec_list))))
|
||||
+ #print('({})'.format(' with '.join(sorted(spec_list))))
|
||||
+ for spec_req in spec_list:
|
||||
+ print(spec_req)
|
||||
else:
|
||||
# Print out unversioned provides, requires, recommends, conflicts
|
||||
print(name)
|
9
rpm.spec
9
rpm.spec
@ -17,7 +17,7 @@
|
||||
Name: rpm
|
||||
Epoch: 1
|
||||
Version: 4.16.1.3
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: The RPM Package Manager (RPM) is a powerful package management system
|
||||
Group: System/Management
|
||||
Vendor: openmamba
|
||||
@ -29,7 +29,7 @@ Source2: rpm4-macros_openmamba
|
||||
Patch0: rpm-4.14.2.1-fix-rebuilddb-from-rpm-5.2.patch
|
||||
Patch1: rpm-4.14.2.1-fix-rebuilddb-from-rpm-5.2-better.patch
|
||||
Patch2: rpm-4.14.2.1-fix-missing-translations-from-rpm4-segfault.patch
|
||||
Patch3: rpm-4.16.1.2-arm-openmamba-arch-support.patch
|
||||
Patch3: rpm-4.16.1.3-arm-openmamba-arch-support.patch
|
||||
Patch4: rpm-4.14.2.1-i586-openmamba-arch-support.patch
|
||||
Patch5: rpm-4.14.2.1-debuginfo-rename-to-debug.patch
|
||||
Patch6: rpm-4.14.2.1-add-usrlibrpm-macro.patch
|
||||
@ -39,6 +39,7 @@ Patch9: rpm-4.14.2.1-increase_default_patch_fuzz.patch
|
||||
Patch10: rpm-4.14.2.1-openmamba-buildroot.patch
|
||||
Patch11: rpm-4.14.2.1-target-platform-gnu.patch
|
||||
Patch12: rpm-4.14.2.1-find-lang-qt-fix.patch
|
||||
Patch13: rpm-4.16.1.3-pythondistdeps-no-richdeps.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -138,6 +139,7 @@ This package should be installed if you want to develop Python programs that wil
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
%patch12 -p1
|
||||
%patch13 -p1
|
||||
|
||||
sed -i "s|/usr/bin/python$|%{__python3}|" scripts/pythondistdeps.py
|
||||
|
||||
@ -289,6 +291,9 @@ _EOF
|
||||
%{python3_sitearch}/rpm/*
|
||||
|
||||
%changelog
|
||||
* Sun Apr 18 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 4.16.1.3-2mamba
|
||||
- patches: pythondistdeps: use normal deps instead of rich deps; rpmrc: armv7l: set march=armv7-a
|
||||
|
||||
* Tue Mar 23 2021 Automatic Build System <autodist@mambasoft.it> 4.16.1.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user