provide rpc user and group [release 1.2.7-2mamba;Sat Jul 27 2024]
This commit is contained in:
parent
485557545e
commit
742e2b0173
@ -1,26 +0,0 @@
|
|||||||
commit b3b031b07cc5909aaf964f9d4cf46f6097769320
|
|
||||||
Author: Steve Dickson <steved@redhat.com>
|
|
||||||
Date: Wed Aug 21 14:40:22 2013 -0400
|
|
||||||
|
|
||||||
rpcbind: rpcuser not being set in Makefile.am
|
|
||||||
|
|
||||||
Commit 8d7a0708 cause a regression where the rpcuser id was not
|
|
||||||
being set, which in turn cause rpcbind to immediately exit.
|
|
||||||
This patch removes the extra ',' that was in the AC_ARG_WITH
|
|
||||||
statement in the configure.ac file.
|
|
||||||
|
|
||||||
Signed-off-by: Steve Dickson <steved@redhat.com>
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 2b67720..1cf42d3 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -23,7 +23,7 @@ AC_ARG_WITH([statedir],
|
|
||||||
AC_SUBST([statedir], [$with_statedir])
|
|
||||||
|
|
||||||
AC_ARG_WITH([rpcuser],
|
|
||||||
- AS_HELP_STRING([--with-rpcuser=ARG], [use ARG for RPC @<:@default=root@:>@]),
|
|
||||||
+ AS_HELP_STRING([--with-rpcuser=ARG], [use ARG for RPC @<:@default=root@:>@])
|
|
||||||
,, [with_rpcuser=root])
|
|
||||||
AC_SUBST([rpcuser], [$with_rpcuser])
|
|
||||||
|
|
26
rpcbind.spec
26
rpcbind.spec
@ -1,20 +1,19 @@
|
|||||||
%define groupid 59
|
%define groupid 59
|
||||||
%define userid 59
|
%define userid 59
|
||||||
Name: rpcbind
|
Name: rpcbind
|
||||||
Version: 1.2.6
|
Version: 1.2.7
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: A replacement for portmap required for import or export of NFS shared directories
|
Summary: A replacement for portmap required for import or export of NFS shared directories
|
||||||
Group: System/Servers
|
Group: System/Servers
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://rpcbind.sourceforge.net/
|
URL: https://sourceforge.net/projects/rpcbind/
|
||||||
Source: http://downloads.sourceforge.net/rpcbind/rpcbind-%{version}.tar.bz2
|
Source: http://downloads.sourceforge.net/rpcbind/rpcbind-%{version}.tar.bz2
|
||||||
Source1: rpcbind.service
|
Source1: rpcbind.service
|
||||||
Source2: rpcbind.socket
|
Source2: rpcbind.socket
|
||||||
Source3: rpcbind.sysconfig
|
Source3: rpcbind.sysconfig
|
||||||
Patch0: rpcbind-0.2.1-run.patch
|
Patch0: rpcbind-0.2.1-run.patch
|
||||||
Patch1: rpcbind-0.2.1-rpcuser.patch
|
|
||||||
Patch2: rpcbind-0.2.3-services-sunrpc.patch
|
Patch2: rpcbind-0.2.3-services-sunrpc.patch
|
||||||
License: BSD
|
License: BSD
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
@ -25,7 +24,9 @@ BuildRequires: libwrap-devel
|
|||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libtirpc-devel >= 0.2.5-3mamba
|
BuildRequires: libtirpc-devel >= 0.2.5-3mamba
|
||||||
Provides: portmap
|
Provides: portmap
|
||||||
Obsoletes: portmap
|
Obsoletes: portmap < 1.2.7
|
||||||
|
Provides: user(rpc)
|
||||||
|
Provides: group(rpc)
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The rpcbind program is a replacement for portmap. It is required for import or export of Network File System (NFS) shared directories.
|
The rpcbind program is a replacement for portmap. It is required for import or export of Network File System (NFS) shared directories.
|
||||||
@ -34,9 +35,8 @@ The rpcbind program is a replacement for portmap. It is required for import or e
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch 0 -p1
|
||||||
#%patch1 -p1
|
%patch 2 -p1
|
||||||
%patch2 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf -fisv
|
autoreconf -fisv
|
||||||
@ -53,9 +53,6 @@ autoreconf -fisv
|
|||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall
|
%makeinstall
|
||||||
|
|
||||||
#install -D -m0644 %{SOURCE1} %{buildroot}%{_unitdir}/rpcbind.service
|
|
||||||
#install -D -m0644 %{SOURCE2} %{buildroot}%{_unitdir}/rpcbind.socket
|
|
||||||
#install -D -m0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/sysconfig/rpcbind
|
|
||||||
install -d %{buildroot}/var/lib/rpcbind
|
install -d %{buildroot}/var/lib/rpcbind
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
@ -86,7 +83,6 @@ fi
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
#%config(noreplace) %{_sysconfdir}/sysconfig/rpcbind
|
|
||||||
%{_sbindir}/rpcbind
|
%{_sbindir}/rpcbind
|
||||||
%{_bindir}/rpcinfo
|
%{_bindir}/rpcinfo
|
||||||
%{_unitdir}/rpcbind.service
|
%{_unitdir}/rpcbind.service
|
||||||
@ -97,6 +93,12 @@ fi
|
|||||||
%doc AUTHORS COPYING
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jul 27 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.7-2mamba
|
||||||
|
- provide rpc user and group
|
||||||
|
|
||||||
|
* Sat Jul 27 2024 Automatic Build System <autodist@openmamba.org> 1.2.7-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Wed May 12 2021 Automatic Build System <autodist@mambasoft.it> 1.2.6-1mamba
|
* Wed May 12 2021 Automatic Build System <autodist@mambasoft.it> 1.2.6-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user