automatic version update by autodist [release 3.11-1mamba;Sun Aug 19 2012]
This commit is contained in:
parent
079f9069c3
commit
2caddf87b8
@ -1,2 +1,6 @@
|
|||||||
# rp-pppoe
|
# rp-pppoe
|
||||||
|
|
||||||
|
PPPoE (Point-to-Point Protocol over Ethernet) is a protocol used by many ADSL Internet Service Providers.
|
||||||
|
Roaring Penguin has a free client for Linux, NetBSD and Solaris systems to connect to PPPoE service providers.
|
||||||
|
If you have a DSL "modem" and your provider uses PPPoE, you need a PPPoE client.
|
||||||
|
|
||||||
|
19
rp-pppoe-3.8-allow_root_use.patch
Normal file
19
rp-pppoe-3.8-allow_root_use.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
diff -Nru rp-pppoe-3.8.orig/gui/wrapper.c rp-pppoe-3.8/gui/wrapper.c
|
||||||
|
--- rp-pppoe-3.8.orig/gui/wrapper.c 2006-04-02 16:29:41.000000000 +0200
|
||||||
|
+++ rp-pppoe-3.8/gui/wrapper.c 2007-10-04 19:28:57.000000000 +0200
|
||||||
|
@@ -73,7 +73,6 @@
|
||||||
|
}
|
||||||
|
if (buf.st_mode & (S_IWGRP | S_IWOTH)) {
|
||||||
|
fprintf(stderr, "SECURITY ALERT: Root directory (/) writable by group or other\n");
|
||||||
|
- return 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
/* Check each component */
|
||||||
|
@@ -98,7 +97,6 @@
|
||||||
|
if (buf.st_mode & (S_IWGRP | S_IWOTH)) {
|
||||||
|
fprintf(stderr, "SECURITY ALERT: '%s' writable by group or other\n",
|
||||||
|
path);
|
||||||
|
- return 0;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
return 1;
|
12
rp-pppoe-3.8-conf.patch
Normal file
12
rp-pppoe-3.8-conf.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Nru rp-pppoe-3.8.orig/configs/pppoe.conf rp-pppoe-3.8/configs/pppoe.conf
|
||||||
|
--- rp-pppoe-3.8.orig/configs/pppoe.conf 2006-04-02 16:29:41.000000000 +0200
|
||||||
|
+++ rp-pppoe-3.8/configs/pppoe.conf 2007-10-04 20:37:15.000000000 +0200
|
||||||
|
@@ -21,7 +21,7 @@
|
||||||
|
# When you configure a variable, DO NOT leave spaces around the "=" sign.
|
||||||
|
|
||||||
|
# Ethernet card connected to DSL modem
|
||||||
|
-ETH=eth1
|
||||||
|
+ETH=eth0
|
||||||
|
|
||||||
|
# PPPoE user name. You may have to supply "@provider.com" Sympatico
|
||||||
|
# users in Canada do need to include "@sympatico.ca"
|
20
rp-pppoe-3.8-ppp_enable_logfile.patch
Normal file
20
rp-pppoe-3.8-ppp_enable_logfile.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
diff -Nru rp-pppoe-3.8.orig/scripts/pppoe-connect.in rp-pppoe-3.8/scripts/pppoe-connect.in
|
||||||
|
--- rp-pppoe-3.8.orig/scripts/pppoe-connect.in 2007-10-30 02:39:56.000000000 +0100
|
||||||
|
+++ rp-pppoe-3.8/scripts/pppoe-connect.in 2007-10-30 03:05:43.000000000 +0100
|
||||||
|
@@ -214,8 +214,15 @@
|
||||||
|
DEFAULTROUTE=""
|
||||||
|
fi
|
||||||
|
|
||||||
|
+
|
||||||
|
+if test "$LOGFILE" != "" ; then
|
||||||
|
+ LOGFILE="logfile $LOGFILE"
|
||||||
|
+else
|
||||||
|
+ LOGFILE="logfile /var/log/pppd.log"
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
# Standard PPP options we always use
|
||||||
|
-PPP_STD_OPTIONS="$PLUGIN_OPTS noipdefault noauth default-asyncmap $DEFAULTROUTE hide-password nodetach $PEERDNS mtu 1492 mru 1492 noaccomp nodeflate nopcomp novj novjccomp user $USER lcp-echo-interval $LCP_INTERVAL lcp-echo-failure $LCP_FAILURE $PPPD_EXTRA"
|
||||||
|
+PPP_STD_OPTIONS="$PLUGIN_OPTS noipdefault noauth default-asyncmap $DEFAULTROUTE hide-password nodetach $PEERDNS mtu 1492 mru 1492 noaccomp nodeflate nopcomp novj novjccomp user $USER lcp-echo-interval $LCP_INTERVAL lcp-echo-failure $LCP_FAILURE $PPPD_EXTRA $LOGFILE"
|
||||||
|
|
||||||
|
# Jigger DNS if required...
|
||||||
|
if test "$DNSTYPE" = "SPECIFY" ; then
|
56
rp-pppoe-3.8-scripts.patch
Normal file
56
rp-pppoe-3.8-scripts.patch
Normal file
@ -0,0 +1,56 @@
|
|||||||
|
diff -ru rp-pppoe-3.8.orig/scripts/pppoe-connect.in rp-pppoe-3.8/scripts/pppoe-connect.in
|
||||||
|
--- rp-pppoe-3.8.orig/scripts/pppoe-connect.in 2007-11-03 16:28:27.000000000 +0100
|
||||||
|
+++ rp-pppoe-3.8/scripts/pppoe-connect.in 2007-11-03 16:44:08.000000000 +0100
|
||||||
|
@@ -174,7 +174,6 @@
|
||||||
|
PEERDNS=""
|
||||||
|
fi
|
||||||
|
|
||||||
|
-
|
||||||
|
# Backward config file compatibility
|
||||||
|
if test "$DEMAND" = "" ; then
|
||||||
|
DEMAND=no
|
||||||
|
@@ -209,6 +208,7 @@
|
||||||
|
|
||||||
|
if test "$DEFAULTROUTE" != "no" ; then
|
||||||
|
DEFAULTROUTE="defaultroute"
|
||||||
|
+ route del default dev $ETH
|
||||||
|
else
|
||||||
|
DEFAULTROUTE=""
|
||||||
|
fi
|
||||||
|
@@ -224,11 +224,7 @@
|
||||||
|
PPP_STD_OPTIONS="$PLUGIN_OPTS noipdefault noauth default-asyncmap $DEFAULTROUTE hide-password nodetach $PEERDNS mtu 1492 mru 1492 noaccomp nodeflate nopcomp novj novjccomp user $USER lcp-echo-interval $LCP_INTERVAL lcp-echo-failure $LCP_FAILURE $PPPD_EXTRA $LOGFILE"
|
||||||
|
|
||||||
|
# Jigger DNS if required...
|
||||||
|
-if test "$DNSTYPE" = "SERVER" ; then
|
||||||
|
- # Sorry, dude...
|
||||||
|
- rm -f /etc/resolv.conf
|
||||||
|
- ln -s /etc/ppp/resolv.conf /etc/resolv.conf
|
||||||
|
-elif test "$DNSTYPE" = "SPECIFY" ; then
|
||||||
|
+if test "$DNSTYPE" = "SPECIFY" ; then
|
||||||
|
# Sorry, dude...
|
||||||
|
rm -f /etc/resolv.conf
|
||||||
|
echo "nameserver $DNS1" > /etc/resolv.conf
|
||||||
|
@@ -237,6 +233,10 @@
|
||||||
|
fi
|
||||||
|
fi
|
||||||
|
|
||||||
|
+# Disable conflicting dhcp client active on the ETH interface
|
||||||
|
+[ -e /var/run/dhclient.$ETH.pid ] && \
|
||||||
|
+kill -9 `cat /var/run/dhclient.$ETH.pid`
|
||||||
|
+
|
||||||
|
# PPPoE invocation
|
||||||
|
PPPOE_CMD="$PPPOE -p $PPPOE_PIDFILE -I $ETH -T $PPPOE_TIMEOUT -U $PPPOE_SYNC $CLAMPMSS $ACNAME $SERVICENAMEOPT $PPPOE_EXTRA"
|
||||||
|
if test "$DEBUG" != "" ; then
|
||||||
|
Only in rp-pppoe-3.8.orig/scripts: pppoe-connect.in~
|
||||||
|
diff -ru rp-pppoe-3.8.orig/scripts/pppoe-stop.in rp-pppoe-3.8/scripts/pppoe-stop.in
|
||||||
|
--- rp-pppoe-3.8.orig/scripts/pppoe-stop.in 2006-04-02 16:29:42.000000000 +0200
|
||||||
|
+++ rp-pppoe-3.8/scripts/pppoe-stop.in 2007-11-03 16:42:32.000000000 +0100
|
||||||
|
@@ -65,7 +65,7 @@
|
||||||
|
PPPD_PID=`cat "$PPPD_PIDFILE"`
|
||||||
|
$LOGGER -p daemon.notice "Killing pppd"
|
||||||
|
echo "Killing pppd ($PPPD_PID)"
|
||||||
|
- kill $PPPD_PID > /dev/null 2>&1 || exit 1
|
||||||
|
+ kill -9 $PPPD_PID > /dev/null 2>&1 || exit 1
|
||||||
|
fi
|
||||||
|
|
||||||
|
# Kill pppoe-start
|
16
rp-pppoe.desktop
Normal file
16
rp-pppoe.desktop
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
[Desktop Entry]
|
||||||
|
Encoding=UTF-8
|
||||||
|
Name=TkPPPoE
|
||||||
|
GenericName=Start/Stop ADSL PPPoE connections
|
||||||
|
GenericName[de]=Einwahl ins Internet über ADSL PPPoE
|
||||||
|
GenericName[es]=Herramienta de conexión ADSL PPPoE a Internet
|
||||||
|
GenericName[fr]=Connexion internet par ADSL PPPoE
|
||||||
|
GenericName[it]=Strumento per la connessione ADSL PPPoE ad Internet
|
||||||
|
Exec=kdesu tkpppoe
|
||||||
|
Terminal=false
|
||||||
|
Type=Application
|
||||||
|
Terminal=false
|
||||||
|
Icon=kppp
|
||||||
|
X-KDE-StartupNotify=true
|
||||||
|
Categories=X-ADSL
|
||||||
|
|
139
rp-pppoe.spec
Normal file
139
rp-pppoe.spec
Normal file
@ -0,0 +1,139 @@
|
|||||||
|
Name: rp-pppoe
|
||||||
|
Version: 3.11
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Roaring Penguins' implementation of Point-to-Point Protocol over Ethernet
|
||||||
|
Group: Applications/Networking
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.roaringpenguin.com/pppoe
|
||||||
|
Source0: http://www.roaringpenguin.com/files/download/rp-pppoe-%{version}.tar.gz
|
||||||
|
Source1: %{name}.desktop
|
||||||
|
Patch0: %{name}-3.8-scripts.patch
|
||||||
|
Patch1: %{name}-3.8-allow_root_use.patch
|
||||||
|
Patch2: %{name}-3.8-conf.patch
|
||||||
|
Patch3: %{name}-3.8-ppp_enable_logfile.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
Requires: ppp >= 2.4.3-3
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
PPPoE (Point-to-Point Protocol over Ethernet) is a protocol used by many ADSL Internet Service Providers.
|
||||||
|
Roaring Penguin has a free client for Linux, NetBSD and Solaris systems to connect to PPPoE service providers.
|
||||||
|
If you have a DSL "modem" and your provider uses PPPoE, you need a PPPoE client.
|
||||||
|
|
||||||
|
%package gui
|
||||||
|
Summary: Tk PPP Over Ethernet Client (xDSL support)
|
||||||
|
Group: Graphical Desktop/Applications/Networking
|
||||||
|
Requires: /usr/bin/wish
|
||||||
|
Requires: %{name} = %{version}
|
||||||
|
|
||||||
|
%description gui
|
||||||
|
This is a graphical wrapper around the rp-pppoe PPPoE client.
|
||||||
|
PPPoE is a protocol used by many DSL Internet Service Providers.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
#%patch3 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
cd src
|
||||||
|
./configure --mandir=%{_mandir}
|
||||||
|
%make \
|
||||||
|
docdir=%{_datadir}/doc/rp-pppoe \
|
||||||
|
PPPD_PATH=%{_sbindir}/pppd
|
||||||
|
cd ..
|
||||||
|
|
||||||
|
%make -C gui \
|
||||||
|
docdir=%{_datadir}/doc/%{name}-%{version} \
|
||||||
|
PPPD_PATH=%{_sbindir}/pppd
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%makeinstall -C src \
|
||||||
|
docdir=%{_datadir}/doc/%{name}-%{version}
|
||||||
|
|
||||||
|
%makeinstall -C gui
|
||||||
|
|
||||||
|
# install entry in KDE menu
|
||||||
|
install -D -m644 %{S:1} \
|
||||||
|
%{buildroot}/usr/share/applications/tkpppoe.desktop
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_sbindir}/*
|
||||||
|
%dir %{_datadir}/doc/%{name}-%{version}
|
||||||
|
%{_datadir}/doc/%{name}-%{version}/*
|
||||||
|
#%{_initrddir}/adsl
|
||||||
|
%config(noreplace) %{_sysconfdir}/ppp/*
|
||||||
|
%{_mandir}/man1/pppoe-wrapper.*
|
||||||
|
%{_mandir}/man8/*
|
||||||
|
%{_mandir}/man5/*
|
||||||
|
|
||||||
|
%files gui
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/tkpppoe
|
||||||
|
%dir %{_datadir}/tkpppoe
|
||||||
|
%{_datadir}/tkpppoe/*
|
||||||
|
%{_datadir}/applications/tkpppoe.desktop
|
||||||
|
%{_mandir}/man1/tkpppoe.*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Aug 19 2012 Automatic Build System <autodist@mambasoft.it> 3.11-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Jan 09 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 3.10-3mamba
|
||||||
|
- don't own /etc/ppp
|
||||||
|
|
||||||
|
* Sat Mar 27 2010 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 3.10-2mamba
|
||||||
|
- fixed the path of pppd
|
||||||
|
|
||||||
|
* Thu Sep 25 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.10-1mamba
|
||||||
|
- automatic update to 3.10 by autodist
|
||||||
|
|
||||||
|
* Sat Nov 03 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 3.8-4mamba
|
||||||
|
- pppoe-connect: disable dhcp client running on ethernet interface before connecting
|
||||||
|
|
||||||
|
* Tue Oct 30 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 3.8-3mamba
|
||||||
|
- pppoe-connect: add logfile option (/var/log/pppd.log) to pppd
|
||||||
|
|
||||||
|
* Thu Oct 04 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 3.8-2mamba
|
||||||
|
- re-added scripts patch for openmamba
|
||||||
|
- source0 link fixed
|
||||||
|
- set eth0 as the default interface
|
||||||
|
|
||||||
|
* Tue Aug 28 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 3.8-1mamba
|
||||||
|
- update to 3.8
|
||||||
|
|
||||||
|
* Tue Jun 06 2006 Massimo Pintore <massimo.pintore@qilinux.it> 3.5-7qilnx
|
||||||
|
- updated tkpppoe.desktop file
|
||||||
|
|
||||||
|
* Tue Feb 07 2006 Davide Madrisan <davide.madrisan@qilinux.it> 3.5-6qilnx
|
||||||
|
- fixed package groups
|
||||||
|
- desktop file translated in french, german and spanish
|
||||||
|
|
||||||
|
* Thu Nov 03 2005 Davide Madrisan <davide.madrisan@qilinux.it> 3.5-5qilnx
|
||||||
|
- wish (libtk) required by %{name} gui
|
||||||
|
- specfile updates
|
||||||
|
|
||||||
|
* Mon Dec 20 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 3.5-4qilnx
|
||||||
|
- fixes for integration with ppp 2.4.2-5qilnx
|
||||||
|
|
||||||
|
* Tue Mar 30 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 3.5-3qilnx
|
||||||
|
- removed tk requirement of the gui
|
||||||
|
|
||||||
|
* Thu Mar 25 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 3.5-2qilnx
|
||||||
|
- rebuild with pppd path pointing to /usr/sbin/pppd instead of /usr/bin/pppd
|
||||||
|
|
||||||
|
* Thu Jun 19 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 3.5-1qilnx
|
||||||
|
- first build of rp-pppoe
|
Loading…
Reference in New Issue
Block a user