automatic version update by autodist [release 1.0.0-1mamba;Tue Apr 08 2014]
This commit is contained in:
parent
433bca6f9c
commit
7eea70193e
@ -1,2 +1,4 @@
|
||||
# roundcubemail
|
||||
|
||||
Roundcube webmail is a browser-based multilingual IMAP client with an application-like user interface. It provides full functionality you expect from an e-mail client, including MIME support, address book, folder manipulation, message searching and spell checking.
|
||||
|
||||
|
12
roundcubemail-0.8.5-php-no_strict.patch
Normal file
12
roundcubemail-0.8.5-php-no_strict.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru roundcubemail-0.8.5-dep.orig/installer/index.php roundcubemail-0.8.5-dep/installer/index.php
|
||||
--- roundcubemail-0.8.5-dep.orig/installer/index.php 2013-01-25 18:02:23.000000000 +0100
|
||||
+++ roundcubemail-0.8.5-dep/installer/index.php 2013-02-20 19:05:01.286229100 +0100
|
||||
@@ -39,7 +39,7 @@
|
||||
|
||||
*/
|
||||
|
||||
-ini_set('error_reporting', E_ALL&~E_NOTICE);
|
||||
+ini_set('error_reporting', E_ALL&~ (E_NOTICE | E_STRICT));
|
||||
ini_set('display_errors', 1);
|
||||
|
||||
define('INSTALL_PATH', realpath(dirname(__FILE__) . '/../').'/');
|
144
roundcubemail.spec
Normal file
144
roundcubemail.spec
Normal file
@ -0,0 +1,144 @@
|
||||
%define serverdir %(apxs -q htdocsdir 2>/dev/null)
|
||||
# To create a customized installation:
|
||||
# autospec -u roundcubemail -a5
|
||||
# -d "installdir=%serverdir/../www.example.com,
|
||||
# sitename=example,
|
||||
# adminmail=webmaster@example.com"
|
||||
|
||||
%if "%{?installdir}" == ""
|
||||
%define installdir %{serverdir}/roundcubemail
|
||||
%endif
|
||||
|
||||
%if "%{?sitename}" != ""
|
||||
%if "%{?servername}" == ""
|
||||
%define servername %(basename %installdir 2>/dev/null)
|
||||
%endif
|
||||
%define serverlogdir %(apxs -q logfiledir 2>/dev/null)
|
||||
%else
|
||||
%if "%{?aliasdir}" == ""
|
||||
%define aliasdir /roundcubemail
|
||||
%endif
|
||||
%endif
|
||||
|
||||
Name: %{?sitename:%sitename-website-}roundcubemail
|
||||
Version: 1.0.0
|
||||
Release: 1mamba
|
||||
Summary: A browser-based multilingual IMAP client with an application-like user interface
|
||||
Group: Applications/Web
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://roundcube.net/
|
||||
Source: http://downloads.sourceforge.net/project/roundcubemail/roundcubemail-dependent/%{version}/roundcubemail-%{version}-dep.tar.gz
|
||||
Patch0: roundcubemail-0.8.5-php-no_strict.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: pear-MDB2
|
||||
Requires: pear-MDB2_Driver_mysql
|
||||
Requires: pear-Mail_Mime
|
||||
Requires: pear-Net_Socket
|
||||
Requires: pear-Net_SMTP
|
||||
Requires: pear-Net_IDNA2
|
||||
BuildArch: noarch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Roundcube webmail is a browser-based multilingual IMAP client with an application-like user interface. It provides full functionality you expect from an e-mail client, including MIME support, address book, folder manipulation, message searching and spell checking.
|
||||
|
||||
%prep
|
||||
%setup -q -n roundcubemail-%{version}-dep
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
install -d %{buildroot}%{installdir}
|
||||
cp -a * %{buildroot}%{installdir}
|
||||
cp .htaccess %{buildroot}%{installdir}
|
||||
|
||||
install -d %{buildroot}%{_sysconfdir}/httpd/httpd.d
|
||||
%if "%{?sitename}" != ""
|
||||
cat > %{buildroot}%{_sysconfdir}/httpd/httpd.d/%{servername}.conf << EOF
|
||||
%else
|
||||
cat > %{buildroot}%{_sysconfdir}/httpd/httpd.d/%{name}.conf << EOF
|
||||
%endif
|
||||
%if "%{?sitename}" == ""
|
||||
%if "%(dirname %installdir)" != "%{serverdir}"
|
||||
Alias %{aliasdir} %{installdir}
|
||||
|
||||
%endif
|
||||
%endif
|
||||
<Directory %{installdir}>
|
||||
AllowOverride All
|
||||
RewriteEngine On
|
||||
Order allow,deny
|
||||
Allow from All
|
||||
</Directory>
|
||||
%if "%{?sitename}" != ""
|
||||
%if "%(dirname %installdir)" != "%{serverdir}"
|
||||
|
||||
<VirtualHost *:80>
|
||||
%{?adminmail:ServerAdmin %adminmail}
|
||||
DocumentRoot %{installdir}
|
||||
ServerName %{servername}
|
||||
ErrorLog %{serverlogdir}/%{servername}-error_log
|
||||
CustomLog %{serverlogdir}/%{servername}-access_log common
|
||||
</VirtualHost>
|
||||
%endif
|
||||
%endif
|
||||
EOF
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post
|
||||
if [ $1 -ge 1 ]; then
|
||||
[ -e %{_localstatedir}/lock/subsys/httpd ] && service httpd reload || :
|
||||
fi
|
||||
:
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%if "%{?sitename}" != ""
|
||||
%config(noreplace) %{_sysconfdir}/httpd/httpd.d/%{servername}.conf
|
||||
%else
|
||||
%config(noreplace) %{_sysconfdir}/httpd/httpd.d/%{name}.conf
|
||||
%endif
|
||||
%dir %{installdir}
|
||||
%{installdir}/.htaccess
|
||||
%{installdir}/*
|
||||
%attr(0755,apache,nobody) %{installdir}/temp
|
||||
%attr(0755,apache,nobody) %{installdir}/logs
|
||||
%doc LICENSE
|
||||
## note: eventually add the remaining documents (if any)
|
||||
# %doc README.md
|
||||
|
||||
%changelog
|
||||
* Tue Apr 08 2014 Automatic Build System <autodist@mambasoft.it> 1.0.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Oct 22 2013 Automatic Build System <autodist@mambasoft.it> 0.9.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Sep 07 2013 Automatic Build System <autodist@mambasoft.it> 0.9.4-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Aug 22 2013 Automatic Build System <autodist@mambasoft.it> 0.9.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Jun 17 2013 Automatic Build System <autodist@mambasoft.it> 0.9.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon May 20 2013 Automatic Build System <autodist@mambasoft.it> 0.9.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Apr 23 2013 Automatic Build System <autodist@mambasoft.it> 0.9.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Apr 01 2013 Automatic Build System <autodist@mambasoft.it> 0.8.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Feb 20 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.5-1mamba
|
||||
- package created by silvan using the webbuild interface
|
Loading…
Reference in New Issue
Block a user