automatic version update by autodist [release 14.02-1mamba;Sun Mar 09 2014]
This commit is contained in:
parent
74e9422810
commit
5c67a690ac
@ -1,2 +1,4 @@
|
||||
# rosegarden
|
||||
|
||||
A professional audio and MIDI sequencer, score editor and general-purpose music composition and editing environment.
|
||||
|
||||
|
9
rosegarden-10.04-desktop_it.patch
Normal file
9
rosegarden-10.04-desktop_it.patch
Normal file
@ -0,0 +1,9 @@
|
||||
diff -Nru rosegarden-10.04.orig//data/desktop/rosegarden.desktop rosegarden-10.04/data/desktop/rosegarden.desktop
|
||||
--- rosegarden-10.04.orig//data/desktop/rosegarden.desktop 2010-04-22 22:44:09.000000000 +0200
|
||||
+++ rosegarden-10.04/data/desktop/rosegarden.desktop 2010-04-24 17:13:08.156900643 +0200
|
||||
@@ -12,3 +12,5 @@
|
||||
Name=Rosegarden
|
||||
Name[de]=Rosegarden
|
||||
Name[es]=Rosegarden
|
||||
+GenericName=MIDI and Audio Sequencer and Editor
|
||||
+GenericName[it]=Sequencer MIDI e audio ed editor di partiture musicali
|
11
rosegarden-gcc4.patch
Normal file
11
rosegarden-gcc4.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- rosegarden-4-1.0.orig/base/Colour.C 2005-11-09 14:49:19.000000000 +0100
|
||||
+++ rosegarden-4-1.0/base/Colour.C 2005-11-09 14:51:03.000000000 +0100
|
||||
@@ -163,7 +163,7 @@
|
||||
// Generic Colour routines:
|
||||
|
||||
Colour
|
||||
-Rosegarden::getCombinationColour(const Colour &input1, const Colour &input2)
|
||||
+getCombinationColour(const Colour &input1, const Colour &input2)
|
||||
{
|
||||
Colour ret((input1.getRed()+input2.getRed())/2,
|
||||
(input1.getGreen()+input2.getGreen())/2,
|
11
rosegarden-qcanvasgroupableitem.patch
Normal file
11
rosegarden-qcanvasgroupableitem.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- rosegarden-4-1.0.orig/gui/qcanvasgroupableitem.h 2005-11-09 14:49:19.000000000 +0100
|
||||
+++ rosegarden-4-1.0/gui/qcanvasgroupableitem.h 2005-11-09 15:59:21.000000000 +0100
|
||||
@@ -24,6 +24,8 @@
|
||||
|
||||
#include <qcanvas.h>
|
||||
|
||||
+class QCanvasItemGroup;
|
||||
+
|
||||
/**
|
||||
* This class is meant to be inherited by QCanvasItem children to make
|
||||
* them groupable.
|
12
rosegarden-segmenttool.patch
Normal file
12
rosegarden-segmenttool.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- rosegarden-4-1.0.orig/gui/segmenttool.h 2005-11-09 14:49:19.000000000 +0100
|
||||
+++ rosegarden-4-1.0/gui/segmenttool.h 2005-11-09 16:00:10.000000000 +0100
|
||||
@@ -44,7 +44,8 @@
|
||||
//////////////////////////////////////////////////////////////////////
|
||||
// Segment Tools
|
||||
//////////////////////////////////////////////////////////////////////
|
||||
-
|
||||
+class SegmentToolBox;
|
||||
+class SegmentSelector;
|
||||
// Allow the tools to share the Selector tool's selection
|
||||
// through these.
|
||||
//
|
11
rosegarden-transport_ui.patch
Normal file
11
rosegarden-transport_ui.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- rosegarden-4-1.0.orig/gui/rosegardentransport.ui 2005-11-09 14:49:19.000000000 +0100
|
||||
+++ rosegarden-4-1.0/gui/rosegardentransport.ui 2005-11-09 16:00:59.000000000 +0100
|
||||
@@ -4308,8 +4308,4 @@
|
||||
<tabstop>FfwdEndButton</tabstop>
|
||||
</tabstops>
|
||||
<layoutdefaults spacing="6" margin="11"/>
|
||||
-<includehints>
|
||||
- <includehint>rosegardenlabel.h</includehint>
|
||||
- <includehint>rosegardenlabel.h</includehint>
|
||||
-</includehints>
|
||||
</UI>
|
138
rosegarden.spec
Normal file
138
rosegarden.spec
Normal file
@ -0,0 +1,138 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: rosegarden
|
||||
Version: 14.02
|
||||
Release: 1mamba
|
||||
Summary: A professional audio and MIDI sequencer, score editor and more
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.rosegardenmusic.com
|
||||
Source: http://downloads.sourceforge.net/project/rosegarden/rosegarden/%{majver}/rosegarden-%{version}.tar.bz2
|
||||
Patch1: %{name}-10.04-desktop_it.patch
|
||||
Patch2: %{name}-gcc4.patch
|
||||
Patch3: %{name}-qcanvasgroupableitem.patch
|
||||
Patch4: %{name}-segmenttool.patch
|
||||
Patch5: %{name}-transport_ui.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libfftw-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libjack-devel
|
||||
BuildRequires: liblo-devel
|
||||
BuildRequires: liblrdf-devel
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libsamplerate-devel
|
||||
BuildRequires: libsndfile-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: lilypond
|
||||
BuildRequires: lirc-devel
|
||||
BuildRequires: perl-XML-Twig
|
||||
BuildRequires: xterm
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: scons
|
||||
BuildRequires: ladspa-devel
|
||||
BuildRequires: dssi-devel
|
||||
BuildRequires: librdf-devel
|
||||
#librasqal-devel >= 0.9.6
|
||||
BuildRequires: libxml2-utils
|
||||
BuildRequires: lirc-devel
|
||||
BuildRequires: libraptor-devel
|
||||
Requires: lilypond
|
||||
Requires: perl-XML-Twig
|
||||
Requires: xterm
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
|
||||
|
||||
%description
|
||||
A professional audio and MIDI sequencer, score editor and general-purpose music composition and editing environment.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch1 -p1
|
||||
|
||||
%build
|
||||
export QTDIR=%{_prefix}
|
||||
%configure
|
||||
#cmake . -DCMAKE_INSTALL_PREFIX=`kde-config --prefix`
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall
|
||||
|
||||
#%{find_lang} %{name}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc AUTHORS COPYING README
|
||||
%{_bindir}/rosegarden*
|
||||
%{_datadir}/appdata/rosegarden.appdata.xml
|
||||
%{_datadir}/applications/rosegarden.desktop
|
||||
%{_datadir}/icons/hicolor/*/*/rosegarden.*
|
||||
%{_datadir}/icons/hicolor/*/*/audio-x-rosegarden-*.png
|
||||
%{_datadir}/mime/packages/rosegarden.xml
|
||||
|
||||
%changelog
|
||||
* Sun Mar 09 2014 Automatic Build System <autodist@mambasoft.it> 14.02-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Nov 19 2013 Automatic Build System <autodist@mambasoft.it> 13.10-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Jul 23 2013 Automatic Build System <autodist@mambasoft.it> 13.06-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Apr 10 2013 Automatic Build System <autodist@mambasoft.it> 13.04-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Mar 01 2013 Automatic Build System <autodist@mambasoft.it> 13.02-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Jan 21 2013 Automatic Build System <autodist@mambasoft.it> 12.12.25-1mamba
|
||||
- update to 12.12.25
|
||||
|
||||
* Mon Aug 08 2011 Automatic Build System <autodist@mambasoft.it> 11.06-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Mar 07 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 11.02-1mamba
|
||||
- update to 11.02
|
||||
|
||||
* Sat Apr 24 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 10.04-1mamba
|
||||
- update to 10.04
|
||||
|
||||
* Fri Jul 10 2009 Automatic Build System <autodist@mambasoft.it> 1.7.3-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Wed Feb 18 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.7.3-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Nov 06 2008 gil <puntogil@libero.it> 1.7.2-1mamba
|
||||
- update to 1.7.2
|
||||
|
||||
* Thu Nov 06 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.7.0-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Sep 24 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.1-3mamba
|
||||
- added requirement for xterm, needed for lilypond support
|
||||
|
||||
* Sat Sep 22 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.1-2mamba
|
||||
- added requirement for perl-XML-Twig
|
||||
|
||||
* Sat Sep 15 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.1-1mamba
|
||||
- update to 1.5.1
|
||||
|
||||
* Fri May 26 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.3-1qilnx
|
||||
- update to version 1.2.3 by autospec
|
||||
|
||||
* Wed Nov 09 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 1.0-2qilnx
|
||||
- added patch for desktop file italian translation and for gcc4
|
||||
|
||||
* Sat Feb 19 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user