update to 0.4.0 [release 0.4.0-1mamba;Fri May 21 2021]
This commit is contained in:
parent
645388fef1
commit
c2b548471b
11
recordmydesktop-0.4.0-python3.patch
Normal file
11
recordmydesktop-0.4.0-python3.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- recordmydesktop-0.4.0/qt-recordmydesktop/configure.ac.orig 2021-07-25 15:04:17.237562817 +0200
|
||||
+++ recordmydesktop-0.4.0/qt-recordmydesktop/configure.ac 2021-07-25 15:04:29.884795133 +0200
|
||||
@@ -43,7 +43,7 @@
|
||||
|
||||
export PYTHONPATH=$PYTHONPATH
|
||||
|
||||
-export PYQT4_VERSION=`python -c 'import PyQt4; from PyQt4 import QtCore; print QtCore.PYQT_VERSION_STR' 2>>/dev/null `
|
||||
+export PYQT4_VERSION=`python3 -c 'import PyQt4; from PyQt4 import QtCore; print(QtCore.PYQT_VERSION_STR)' 2>>/dev/null `
|
||||
if test x$PYQT4_VERSION == x; then
|
||||
AC_MSG_ERROR(You need PyQt4>=4.1 installed to procceed);
|
||||
fi
|
@ -1,56 +1,98 @@
|
||||
Name: recordmydesktop
|
||||
Version: 0.3.8.1
|
||||
Release: 2mamba
|
||||
Version: 0.4.0
|
||||
Release: 1mamba
|
||||
Summary: Desktop session recorder with audio and video
|
||||
Group: Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Fabio Giani <fabio.giani@email.it>
|
||||
URL: http://recordmydesktop.iovar.org/
|
||||
Source: http://downloads.sourceforge.net/recordmydesktop/recordmydesktop-%{version}.tar.gz
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://enselic.github.io/recordmydesktop/
|
||||
Source: https://github.com/Enselic/recordmydesktop.git/v%{version}/recordmydesktop-%{version}.tar.bz2
|
||||
Patch0: recordmydesktop-0.4.0-python3.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libogg-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libtheora-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXdamage-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXfixes-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libjack-devel
|
||||
BuildRequires: libogg-devel
|
||||
BuildRequires: libpopt-devel
|
||||
BuildRequires: libtheora-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libjack-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
recordMyDesktop is a desktop session recorder for linux that attempts to be easy to use, yet also effective at it's primary task.
|
||||
|
||||
%package -n qt-recordmydesktop
|
||||
Summary: Desktop session recorder with audio and video (Qt frontend)
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description -n qt-recordmydesktop
|
||||
Desktop session recorder with audio and video (Qt frontend).
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
cd recordmydesktop
|
||||
./autogen.sh
|
||||
|
||||
cd ../qt-recordmydesktop
|
||||
sh ./autogen.sh
|
||||
|
||||
%build
|
||||
cd recordmydesktop
|
||||
%configure \
|
||||
--enable-jack=yes
|
||||
%make
|
||||
|
||||
cd ../qt-recordmydesktop
|
||||
%configure \
|
||||
PYTHON=%{__python3}
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
%makeinstall -C recordmydesktop
|
||||
%makeinstall -C qt-recordmydesktop
|
||||
|
||||
%find_lang qt-recordmydesktop --all-name
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_mandir}/man1/recordmydesktop.1.gz
|
||||
%{_bindir}/recordmydesktop
|
||||
%doc AUTHORS COPYING ChangeLog NEWS README TODO
|
||||
%{_mandir}/man1/recordmydesktop.1*
|
||||
%doc recordmydesktop/AUTHORS recordmydesktop/COPYING
|
||||
|
||||
%files -n qt-recordmydesktop -f qt-recordmydesktop.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/qt-recordMyDesktop
|
||||
%{_datadir}/applications/qt-recordmydesktop.desktop
|
||||
%dir %{python3_sitelib}/qt_recordMyDesktop
|
||||
%{python3_sitelib}/qt_recordMyDesktop/*
|
||||
%{_datadir}/pixmaps/media-*.svg
|
||||
%{_datadir}/pixmaps/qt-recordmydesktop.png
|
||||
%doc qt-recordmydesktop/AUTHORS qt-recordmydesktop/COPYING
|
||||
|
||||
%changelog
|
||||
* Fri May 21 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.0-1mamba
|
||||
- update to 0.4.0
|
||||
|
||||
* Thu Jul 11 2013 Automatic Build System <autodist@mambasoft.it> 0.3.8.1-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user