update site and download urls

installl shared library in correct package [release 3.6-2mamba;Sat Jul 21 2012]
This commit is contained in:
Silvan Calarco 2024-01-05 17:23:19 +01:00
parent 5bc6e04de7
commit 8956b2e026
3 changed files with 134 additions and 0 deletions

View File

@ -1,2 +1,8 @@
# recode
The recode program has the purpose of converting files between various character sets and usages. When exact transliterations are not possible, as it is often the case, the program may get rid of the offending characters or fall back on approximations.
Let us coin the term charset to represent, without distinction, a character set "per se" or a particular usage of a character set. This program recognizes or produces around 150 such charsets. Since it can convert each charset to almost any other one, many thousands of different conversions are possible.
This tool pays special attention to superimposition of diacritics for French representation. This orientation is mostly historical, it does not impair the usefulness, generality or extensibility of the program.

View File

@ -0,0 +1,11 @@
--- src/recodext.h.orig 2008-01-16 13:15:39.000000000 +0100
+++ src/recodext.h 2008-01-16 13:16:47.000000000 +0100
@@ -218,7 +218,7 @@
enum recode_symbol_type type : 3;
/* Non zero if this one should be ignored. */
- bool ignore : 2;
+ bool ignore : 1;
};
struct recode_surface_list

117
recode.spec Normal file
View File

@ -0,0 +1,117 @@
Name: recode
Version: 3.6
Release: 2mamba
Summary: A program that has the purpose of converting files between various character sets and usages.
Group: System/Tools
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://recode.progiciels-bpi.ca/index.html
Source: https://github.com/pinard/Recode/tarball/v%{version}/recode-%{version}.tar.gz
Patch0: %{name}-3.6-bool-bitfield.patch
License: GPL
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
PreReq: %{__install_info}
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
## AUTOBUILDREQ-END
Requires(post): %{__install_info}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
The recode program has the purpose of converting files between various character sets and usages. When exact transliterations are not possible, as it is often the case, the program may get rid of the offending characters or fall back on approximations.
Let us coin the term charset to represent, without distinction, a character set "per se" or a particular usage of a character set. This program recognizes or produces around 150 such charsets. Since it can convert each charset to almost any other one, many thousands of different conversions are possible.
This tool pays special attention to superimposition of diacritics for French representation. This orientation is mostly historical, it does not impair the usefulness, generality or extensibility of the program.
%package -n lib%{name}
Summary: A library that has the purpose of converting files between various character sets and usages.
Group: System/Libraries
%description -n lib%{name}
The recode library has the purpose of converting files between various character sets and usages. When exact transliterations are not possible, as it is often the case, the program may get rid of the offending characters or fall back on approximations.
Let us coin the term charset to represent, without distinction, a character set "per se" or a particular usage of a character set. This program recognizes or produces around 150 such charsets. Since it can convert each charset to almost any other one, many thousands of different conversions are possible.
This tool pays special attention to superimposition of diacritics for French representation. This orientation is mostly historical, it does not impair the usefulness, generality or extensibility of the program.
%package -n lib%{name}-devel
Summary: Devel package for %{name}
Group: Development/Libraries
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n lib%{name}-devel
The recode program has the purpose of converting files between various character sets and usages. When exact transliterations are not possible, as it is often the case, the program may get rid of the offending characters or fall back on approximations.
Let us coin the term charset to represent, without distinction, a character set "per se" or a particular usage of a character set. This program recognizes or produces around 150 such charsets. Since it can convert each charset to almost any other one, many thousands of different conversions are possible.
This tool pays special attention to superimposition of diacritics for French representation. This orientation is mostly historical, it does not impair the usefulness, generality or extensibility of the program.
This package contains static libraries and header files need for development.
%prep
%setup -q
%patch0 -p0
%build
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%find_lang recode
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post
%install_info recode.info-2
%install_info recode.info-7
%install_info recode.info-4
%install_info recode.info-5
%install_info recode.info-3
%install_info recode.info-6
%install_info recode.info-1
%install_info recode.info
%preun
%uninstall_info recode.info-2
%uninstall_info recode.info-7
%uninstall_info recode.info-4
%uninstall_info recode.info-5
%uninstall_info recode.info-3
%uninstall_info recode.info-6
%uninstall_info recode.info-1
%uninstall_info recode.info
%files -f recode.lang
%defattr(-,root,root)
%{_bindir}/recode
%{_infodir}/recode.info-1.gz
%{_infodir}/recode.info-2.gz
%{_infodir}/recode.info-3.gz
%{_infodir}/recode.info-4.gz
%{_infodir}/recode.info-5.gz
%{_infodir}/recode.info-6.gz
%{_infodir}/recode.info-7.gz
%{_infodir}/recode.info.gz
%{_mandir}/man1/recode.1.gz
%files -n lib%{name}
%defattr(-,root,root)
%{_libdir}/librecode.so.*
%doc AUTHORS COPYING
%files -n lib%{name}-devel
%defattr(-,root,root)
%dir %{_includedir}
%{_includedir}/*.h
%{_libdir}/librecode.a
%{_libdir}/librecode.la
%{_libdir}/librecode.so
%doc NEWS README THANKS TODO ChangeLog
%changelog
* Sat Jul 21 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 3.6-2mamba
- update site and download urls
- installl shared library in correct package
* Tue Sep 22 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 3.6-1mamba
- package created by autospec