automatic version update by autodist [release 1.8.1-1mamba;Wed Nov 20 2013]

This commit is contained in:
Automatic Build System 2024-01-05 17:22:24 +01:00
parent 1c6e0edce6
commit b2e4e0907c
4 changed files with 140 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# rdesktop
rdesktop is an open source client for Windows NT Terminal Server, capable of natively speaking its Remote Desktop Protocol (RDP) in order to present the user's NT desktop.
Unlike Citrix ICA, no server extensions are required.

View File

@ -0,0 +1,20 @@
--- rdesktop-1.7.1/rdesktop.c 2011-11-25 11:03:03.000000000 +0100
+++ rdesktop-1.7.1/rdesktop.c.fix 2012-08-26 20:46:11.000000000 +0200
@@ -1574,7 +1574,7 @@
if (home == NULL)
return -1;
- snprintf((char*)hi, 16, g_hostname);
+ snprintf((char*)hi, 16, "%s", g_hostname);
sec_hash_sha1_16(ho, hi, g_static_rdesktop_salt_16);
sec_hash_to_string(hash, 40, ho, 22);
@@ -1624,7 +1624,7 @@
return;
}
- snprintf((char*)hi,16,g_hostname);
+ snprintf((char*)hi,16,"%s",g_hostname);
sec_hash_sha1_16(ho, hi, g_static_rdesktop_salt_16);
sec_hash_to_string(hash, 40, ho, 20);

View File

@ -0,0 +1,19 @@
diff -Nru rdesktop-1.8.0.orig/rdpsnd_libao.c rdesktop-1.8.0/rdpsnd_libao.c
--- rdesktop-1.8.0.orig/rdpsnd_libao.c 2013-06-20 14:56:16.000000000 +0200
+++ rdesktop-1.8.0/rdpsnd_libao.c 2013-08-10 11:09:23.771448960 +0200
@@ -77,6 +77,7 @@
format.channels = 2;
format.rate = 44100;
format.byte_format = AO_FMT_NATIVE;
+ format.matrix = NULL;
o_device = ao_open_live(default_driver, &format, NULL);
if (o_device == NULL)
@@ -115,6 +116,7 @@
format.channels = pwfx->nChannels;
format.rate = 44100;
format.byte_format = AO_FMT_NATIVE;
+ format.matrix = NULL;
if (o_device != NULL)
ao_close(o_device);

98
rdesktop.spec Normal file
View File

@ -0,0 +1,98 @@
Name: rdesktop
Version: 1.8.1
Release: 1mamba
Summary: rdesktop is an open source client for Windows NT Terminal Server
Group: Applications/Networking
Vendor: openmamba
Distribution: openmamba
Packager: Davide Madrisan <davide.madrisan@gmail.com>
URL: http://www.rdesktop.org/
Source: http://downloads.sourceforge.net/sourceforge/rdesktop/rdesktop-%{version}.tar.gz
Patch0: %{name}-1.8.0-libao_segfault.patch
Patch1: %{name}-1.7.1-snprintf-format-fix.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libao-devel
BuildRequires: libopenssl-devel
BuildRequires: libX11-devel
BuildRequires: libXrandr-devel
## AUTOBUILDREQ-END
BuildRequires: libXrender-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
rdesktop is an open source client for Windows NT Terminal Server, capable of natively speaking its Remote Desktop Protocol (RDP) in order to present the user's NT desktop.
Unlike Citrix ICA, no server extensions are required.
%prep
%setup -q
%patch0 -p1
#%patch1 -p1
chmod 644 COPYING
chmod 644 doc/*
%build
%configure \
--with-openssl=%{_prefix} \
--with-sound=libao \
--with-ipv6
# --with-libvncserver
%make
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall STRIP=/bin/true
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%files
%defattr(-,root,root)
%{_bindir}/rdesktop
%dir %{_datadir}/rdesktop
%{_datadir}/rdesktop/keymaps/*
%{_mandir}/man1/*
%doc COPYING README doc/AUTHORS doc/HACKING doc/TODO doc/*.txt
%changelog
* Wed Nov 20 2013 Automatic Build System <autodist@mambasoft.it> 1.8.1-1mamba
- automatic version update by autodist
* Sat Aug 10 2013 Automatic Build System <autodist@mambasoft.it> 1.8.0-1mamba
- automatic version update by autodist
* Sun Aug 26 2012 Davide Madrisan <davide.madrisan@gmail.com> 1.7.1-3mamba
- patch libao output driver to fix segfault
- security patch: add missing format string to snprintf's
* Fri Aug 17 2012 Davide Madrisan <davide.madrisan@gmail.com> 1.7.1-2mamba
- configure: remove the unrecognized option '--with-libao'
* Tue Apr 24 2012 Automatic Build System <autodist@mambasoft.it> 1.7.1-1mamba
- automatic version update by autodist
* Wed Apr 27 2011 Automatic Build System <autodist@mambasoft.it> 1.7.0-1mamba
- automatic update by autodist
* Sat May 29 2010 Automatic Build System <autodist@mambasoft.it> 1.6.0-2mamba
- automatic rebuild by autodist
* Thu Oct 02 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.0-1mamba
- automatic update by autodist
* Tue Jul 10 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.0-1mamba
- update to 1.5.0
* Thu May 26 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.4.1-1qilnx
- update to version 1.4.1 by autospec
* Wed Feb 09 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.3.1-1qilnx
- update to version 1.3.1 by autospec
* Mon Jan 12 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.0-1qilnx
- new version build
* Thu Oct 16 2003 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.0-1qilnx
- first build