automatic version update by autodist

added patch to fix libpng1.5 compatibility issue [release 2.0-1mamba;Mon Jun 03 2013]
This commit is contained in:
Automatic Build System 2024-01-05 17:22:04 +01:00
parent 2107cff10e
commit 4cc4e012ea
3 changed files with 152 additions and 0 deletions

View File

@ -1,2 +1,6 @@
# rawstudio # rawstudio
Rawstudio is a highly specialized application for processing RAW images from digital cameras. It is not a fully featured image editing application.
The RAW format is often recommended to get the best quality out of digital camera images. The format is specific to cameras and cannot be read by most image editing applications.
Rawstudio makes it possible to read and manipulate RAW images, experiment with the controls to see how they affect the image, and finally export into JPEG, PNG or TIF format images from most digital cameras.

View File

@ -0,0 +1,43 @@
diff -u -aur rawstudio-2.0/plugins/load-gdk/exiv2-colorspace.cpp rawstudio-2.0.new/plugins/load-gdk/exiv2-colorspace.cpp
--- rawstudio-2.0/plugins/load-gdk/exiv2-colorspace.cpp 2011-02-23 23:35:18.000000000 +0100
+++ rawstudio-2.0.new/plugins/load-gdk/exiv2-colorspace.cpp 2012-02-28 11:19:29.600026282 +0100
@@ -125,11 +125,17 @@
int compression_type;
/* Extract embedded ICC profile */
- if (info_ptr->valid & PNG_INFO_iCCP)
+ if (png_get_valid(png_ptr, info_ptr, TRUE) & PNG_INFO_iCCP)
{
+#if PNG_LIBPNG_VER_SONUM >=15
+ png_uint_32 retval = png_get_iCCP (png_ptr, info_ptr,
+ (png_charpp) &icc_profile_title, &compression_type,
+ (png_byte**) &icc_profile, (png_uint_32*) &icc_profile_size);
+#else
png_uint_32 retval = png_get_iCCP (png_ptr, info_ptr,
(png_charpp) &icc_profile_title, &compression_type,
(png_charpp) &icc_profile, (png_uint_32*) &icc_profile_size);
+#endif
if (retval != 0)
{
RSIccProfile *icc = rs_icc_profile_new_from_memory((gchar*)icc_profile, icc_profile_size, TRUE);
diff -u -aur rawstudio-2.0/plugins/output-pngfile/output-pngfile.c rawstudio-2.0.new/plugins/output-pngfile/output-pngfile.c
--- rawstudio-2.0/plugins/output-pngfile/output-pngfile.c 2011-03-26 02:52:29.000000000 +0100
+++ rawstudio-2.0.new/plugins/output-pngfile/output-pngfile.c 2012-02-28 11:31:50.392934364 +0100
@@ -23,6 +23,7 @@
#include <gettext.h>
#include "config.h"
#include <png.h>
+#include <zlib.h>
#define RS_TYPE_PNGFILE (rs_pngfile_type)
#define RS_PNGFILE(obj) (G_TYPE_CHECK_INSTANCE_CAST ((obj), RS_TYPE_PNGFILE, RSPngfile))
@@ -197,8 +198,7 @@
const RSIccProfile *profile = rs_color_space_get_icc_profile(pngfile->color_space, pngfile->save16bit);
rs_icc_profile_get_data(profile, &data, &data_length);
- // FIXME: Insert correct profile name
- png_set_iCCP(png_ptr, info_ptr, "Profile name", PNG_COMPRESSION_TYPE_BASE, data, data_length);
+ png_set_iCCP(png_ptr, info_ptr, (png_charp)rs_color_space_get_name(pngfile->color_space), PNG_COMPRESSION_TYPE_BASE, (png_charp)data, data_length);
if (pngfile->save16bit)
png_set_gAMA(png_ptr, info_ptr, 1.0);
}

105
rawstudio.spec Normal file
View File

@ -0,0 +1,105 @@
Name: rawstudio
Version: 2.0
Release: 1mamba
Summary: Read, manipulate and convert digital camera raw images
Group: Graphical Desktop/Applications/Graphics
Vendor: openmamba
Distribution: openmamba
Packager: Fabio Giani <fabio.giani@gmail.com>
URL: http://rawstudio.org
Source: http://www.rawstudio.org/files/release/rawstudio-%{version}.tar.gz
Patch1: rawstudio-2.0-libpng-1.5.patch
License: GPL
BuildRequires: libgtk-devel
BuildRequires: libxml2-devel
BuildRequires: GConf-devel
BuildRequires: libdbus-devel
BuildRequires: liblcms-devel
BuildRequires: libjpeg-devel
BuildRequires: libtiff-devel
BuildRequires: libexiv2-devel
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Rawstudio is a highly specialized application for processing RAW images from digital cameras. It is not a fully featured image editing application.
The RAW format is often recommended to get the best quality out of digital camera images. The format is specific to cameras and cannot be read by most image editing applications.
Rawstudio makes it possible to read and manipulate RAW images, experiment with the controls to see how they affect the image, and finally export into JPEG, PNG or TIF format images from most digital cameras.
%package -n lib%{name}
Group: System/Libraries
Summary: Shared libraries for %{name}
%description -n lib%{name}
This package contains shared libraries for %{name}.
%package -n lib%{name}-devel
Group: Development/Libraries
Summary: Development files for %{name}
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires: pkg-config
%description -n lib%{name}-devel
This package contains development files for lib%{name}.
%prep
%setup -q
# workaround for libtool build error
mkdir librawstudio/lib
%patch1 -p1
%build
%configure
%make LIBS="`pkg-config --libs gthread-2.0`"
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall DESTDIR=$RPM_BUILD_ROOT
# Fix desktop file warning
# Note: the Encoding tag seems to be deprecated in desktop entry specs v1.0
# so this has probably to go away in the future
echo "Encoding=UTF-8" >> %{buildroot}%{_datadir}/applications/rawstudio.desktop
%find_lang %{name}
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -f %{name}.lang
%defattr(-,root,root)
%{_bindir}/rawstudio
%{_datadir}/pixmaps/rawstudio
%{_datadir}/applications/rawstudio.desktop
%{_datadir}/icons/rawstudio.png
%files -n lib%{name}
%defattr(-,root,root)
%dir %{_datadir}/rawspeed
%{_datadir}/rawspeed/cameras.xml
%dir %{_datadir}/rawstudio
%{_datadir}/rawstudio/*
%{_libdir}/librawstudio-2.0.so.*
%doc AUTHORS COPYING
#NEWS README TODO
%files -n lib%{name}-devel
%defattr(-,root,root)
%dir %{_includedir}/rawstudio-2.0
%{_includedir}/rawstudio-2.0/*.h
%{_libdir}/librawstudio-2.0.a
%{_libdir}/librawstudio-2.0.la
%{_libdir}/librawstudio-2.0.so
%{_libdir}/pkgconfig/rawstudio-2.0.pc
%changelog
* Mon Jun 03 2013 Automatic Build System <autodist@mambasoft.it> 2.0-1mamba
- automatic version update by autodist
- added patch to fix libpng1.5 compatibility issue
* Mon Apr 13 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2-1mamba
- automatic update by autodist
* Sun Feb 01 2009 Fabio Giani <fabio.giani@gmail.com> 1.1-1mamba
- package created by autospec