automatic rebuild by autodist [release 2.1-3mamba;Mon Aug 19 2013]
This commit is contained in:
parent
4c027515ad
commit
c06e651320
@ -1,2 +1,5 @@
|
||||
# rats
|
||||
|
||||
RATS, the Rough Auditing Tool for Security, is a security auditing utility for C, C++, Python, Perl and PHP code. RATS scans source code, finding potentially dangerous function calls.
|
||||
The goal of this project is not to definitively find bugs, but to provide a reasonable starting point for performing manual security audits.
|
||||
|
||||
|
38
rats-2.1-Makefile.patch
Normal file
38
rats-2.1-Makefile.patch
Normal file
@ -0,0 +1,38 @@
|
||||
--- rats-2.1/Makefile.in 2002-08-21 22:48:56.000000000 +0200
|
||||
+++ rats-2.1/Makefile-fix.in 2005-03-25 09:12:33.000000000 +0100
|
||||
@@ -16,6 +16,8 @@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||
|
||||
+DESTDIR=
|
||||
+
|
||||
CFLAGS = -Wall -g @CFLAGS@ @DEFS@ -DDATADIR=\"$(SHAREDIR)\"
|
||||
LDFLAGS = -Wall -g @LDFLAGS@
|
||||
LEXFLAGS = -F -8
|
||||
@@ -48,14 +50,18 @@
|
||||
$(LEX) $(LEXFLAGS) -Pyyphp php-lex.l
|
||||
|
||||
install: $(BIN)
|
||||
- ./mkinstalldirs $(BINDIR) $(LIBDIR) $(MANDIR) $(MANDIR)/man1 $(SHAREDIR)
|
||||
- $(INSTALL_PROGRAM) $(BIN) $(BINDIR)
|
||||
- $(INSTALL_DATA) rats-python.xml $(SHAREDIR)
|
||||
- $(INSTALL_DATA) rats-c.xml $(SHAREDIR)
|
||||
- $(INSTALL_DATA) rats-perl.xml $(SHAREDIR)
|
||||
- $(INSTALL_DATA) rats-php.xml $(SHAREDIR)
|
||||
- $(INSTALL_DATA) rats-openssl.xml $(SHAREDIR)
|
||||
- $(INSTALL_DATA) rats.1 $(MANDIR)/man1
|
||||
+ ./mkinstalldirs $(DESTDIR)$(BINDIR) \
|
||||
+ $(DESTDIR)$(LIBDIR) \
|
||||
+ $(DESTDIR)$(MANDIR) \
|
||||
+ $(DESTDIR)$(MANDIR)/man1 \
|
||||
+ $(DESTDIR)$(SHAREDIR)
|
||||
+ $(INSTALL_PROGRAM) $(BIN) $(DESTDIR)$(BINDIR)
|
||||
+ $(INSTALL_DATA) rats-python.xml $(DESTDIR)$(SHAREDIR)
|
||||
+ $(INSTALL_DATA) rats-c.xml $(DESTDIR)$(SHAREDIR)
|
||||
+ $(INSTALL_DATA) rats-perl.xml $(DESTDIR)$(SHAREDIR)
|
||||
+ $(INSTALL_DATA) rats-php.xml $(DESTDIR)$(SHAREDIR)
|
||||
+ $(INSTALL_DATA) rats-openssl.xml $(DESTDIR)$(SHAREDIR)
|
||||
+ $(INSTALL_DATA) rats.1 $(DESTDIR)$(MANDIR)/man1
|
||||
|
||||
clean:
|
||||
rm -f $(OBJ) *~ $(BIN) core
|
59
rats.spec
Normal file
59
rats.spec
Normal file
@ -0,0 +1,59 @@
|
||||
Name: rats
|
||||
Version: 2.1
|
||||
Release: 3mamba
|
||||
Summary: A security auditing utility for C, C++, Python, Perl and PHP code
|
||||
Group: Applications/Security
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Aleph0 <aleph0@openmamba.org>
|
||||
URL: http://www.fortify.com/security-resources/rats.jsp
|
||||
Source: http://www.fortify.com/servlet/downloads/public/%{name}-%{version}.tar.gz
|
||||
Patch: %{name}-2.1-Makefile.patch
|
||||
License: GPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libexpat-devel
|
||||
## AUTOBUILDREQ-END
|
||||
|
||||
# FIXME: "checking for xmlparse.h... no"
|
||||
|
||||
%description
|
||||
RATS, the Rough Auditing Tool for Security, is a security auditing utility for C, C++, Python, Perl and PHP code. RATS scans source code, finding potentially dangerous function calls.
|
||||
The goal of this project is not to definitively find bugs, but to provide a reasonable starting point for performing manual security audits.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/rats
|
||||
%{_datadir}/rats-c.xml
|
||||
%{_datadir}/rats-openssl.xml
|
||||
%{_datadir}/rats-perl.xml
|
||||
%{_datadir}/rats-php.xml
|
||||
%{_datadir}/rats-python.xml
|
||||
%{_mandir}/man1/rats.*
|
||||
%doc COPYING README README.win32
|
||||
|
||||
%changelog
|
||||
* Mon Aug 19 2013 Automatic Build System <autodist@mambasoft.it> 2.1-3mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Thu Jun 19 2008 Tiziana Ferro <tiziana.ferro@email.it> 2.1-2mamba
|
||||
- update buildrequirements, Vendor, Distribution, mantainer, Url and Source path
|
||||
|
||||
* Fri Mar 25 2005 Davide Madrisan <davide.madrisan@qilinux.it> 2.1-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user