added patch for gcc 14 [release 1.1.0-2mamba;Sun May 26 2024]

This commit is contained in:
Silvan Calarco 2024-05-27 11:25:57 +02:00
parent c6d52575fa
commit 5aceadbc76
2 changed files with 30 additions and 1 deletions

View File

@ -0,0 +1,22 @@
From 3b2441b87f99ab65f37b141a7b548ebadb607b96 Mon Sep 17 00:00:00 2001
From: Janusz Chorko <janusz.chorko@apdu.pl>
Date: Fri, 26 Aug 2016 21:17:38 +0200
Subject: [PATCH] Removed non-compiling assignment operator. Fixed #718
---
include/rapidjson/document.h | 2 --
1 file changed, 2 deletions(-)
diff --git a/include/rapidjson/document.h b/include/rapidjson/document.h
index e3e20dfbd..b0f1f70be 100644
--- a/include/rapidjson/document.h
+++ b/include/rapidjson/document.h
@@ -316,8 +316,6 @@ struct GenericStringRef {
GenericStringRef(const GenericStringRef& rhs) : s(rhs.s), length(rhs.length) {}
- GenericStringRef& operator=(const GenericStringRef& rhs) { s = rhs.s; length = rhs.length; }
-
//! implicit conversion to plain CharType pointer
operator const Ch *() const { return s; }

View File

@ -1,6 +1,6 @@
Name: rapidjson
Version: 1.1.0
Release: 1mamba
Release: 2mamba
Summary: A fast JSON parser/generator for C++ with both SAX/DOM style API
Group: System/Libraries
Vendor: openmamba
@ -10,6 +10,7 @@ URL: https://github.com/Tencent/rapidjson
Source: https://github.com/Tencent/rapidjson.git/v%{version}/rapidjson-%{version}.tar.bz2
Patch0: rapidjson-1.1.0-gcc-10.2.0.patch
Patch1: rapidjson-1.1.0-do_not_include_gtest_src_dir.patch
Patch2: rapidjson-1.1.0-gcc-14.patch
License: MIT
## AUTOBUILDREQ-BEGIN
## AUTOBUILDREQ-END
@ -31,6 +32,7 @@ This package contains header files for developing applications that use %{name}.
%setup -q
%patch0 -p1
%patch1 -p1
%patch 2 -p1 -b .gcc-14
# From Fedora
# Remove bundled code
@ -51,6 +53,7 @@ find . -type f -name CMakeLists.txt -print0 | \
%build
%cmake -d build \
-DDOC_INSTALL_DIR=%{_docdir}/%{name} \
-DRAPIDJSON_BUILD_CXX11:BOOL=OFF \
-DGTESTSRC_FOUND=TRUE \
-DGTEST_SOURCE_DIR=.
@ -67,6 +70,7 @@ find . -type f -name CMakeLists.txt -print0 | \
%defattr(-,root,root)
%dir %{_includedir}/rapidjson
%{_includedir}/rapidjson/*.h
%{_includedir}/rapidjson/document.h.gcc-14
%dir %{_includedir}/rapidjson/error
%{_includedir}/rapidjson/error/*.h
%dir %{_includedir}/rapidjson/internal
@ -80,5 +84,8 @@ find . -type f -name CMakeLists.txt -print0 | \
%{_docdir}/%{name}/*
%changelog
* Sun May 26 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.0-2mamba
- added patch for gcc 14
* Mon Mar 15 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.0-1mamba
- package created using the webbuild interface