package created using the webbuild interface [release 0.6.1-1mamba;Sun Apr 12 2015]
This commit is contained in:
parent
4725b1fa4e
commit
75889b7eb1
@ -1,2 +1,4 @@
|
||||
# rakarrack
|
||||
|
||||
Rakarrack is a richly featured multi-effects processor emulating a guitar effects pedalboard. Effects include compressor, expander, noise gate, graphic equalizer, parametric equalizer, exciter, shuffle, convolotron, valve, flanger, dual flange, chorus, musicaldelay, arpie, echo with reverse playback, musical delay, reverb, digital phaser, analogic phaser, synthfilter, varyband, ring, wah-wah, alien-wah, mutromojo, harmonizer, looper and four flexible distortion modules including sub-octave modulation and dirty octave up. Most of the effects engine is built from modules found in the excellent software synthesizer ZynAddSubFX. Presets and user interface are optimized for guitar, but Rakarrack processes signals in stereo while it does not apply internal band-limiting filtering, and thus is well suited to all musical instruments and vocals. Rakarrack is designed for Linux distributions with Jack Audio Connection Kit.
|
||||
|
||||
|
24
rakarrack-0.6.1-libfltk-1.3.3.patch
Normal file
24
rakarrack-0.6.1-libfltk-1.3.3.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -ru rakarrack-0.6.1.orig/src/global.h rakarrack-0.6.1/src/global.h
|
||||
--- rakarrack-0.6.1.orig/src/global.h 2010-10-01 03:44:53.000000000 +0200
|
||||
+++ rakarrack-0.6.1/src/global.h 2015-04-12 13:54:00.020406050 +0200
|
||||
@@ -99,7 +99,7 @@
|
||||
#include <X11/xpm.h>
|
||||
#include <jack/jack.h>
|
||||
#include <jack/midiport.h>
|
||||
-#include <Fl/Fl_Preferences.H>
|
||||
+#include <FL/Fl_Preferences.H>
|
||||
#include "FPreset.h"
|
||||
#include "Reverb.h"
|
||||
#include "Chorus.h"
|
||||
diff -ru rakarrack-0.6.1.orig/src/process.C rakarrack-0.6.1/src/process.C
|
||||
--- rakarrack-0.6.1.orig/src/process.C 2010-10-01 03:45:12.000000000 +0200
|
||||
+++ rakarrack-0.6.1/src/process.C 2015-04-12 13:53:43.106404450 +0200
|
||||
@@ -28,7 +28,7 @@
|
||||
#include <fcntl.h>
|
||||
#include <sys/types.h>
|
||||
#include <unistd.h>
|
||||
-#include <Fl/Fl_Preferences.H>
|
||||
+#include <FL/Fl_Preferences.H>
|
||||
#include "global.h"
|
||||
|
||||
int Pexitprogram, preset;
|
76
rakarrack.spec
Normal file
76
rakarrack.spec
Normal file
@ -0,0 +1,76 @@
|
||||
Name: rakarrack
|
||||
Version: 0.6.1
|
||||
Release: 1mamba
|
||||
Summary: A richly featured multi-effects processor emulating a guitar effects pedalboard
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://rakarrack.sourceforge.net
|
||||
Source: http://downloads.sourceforge.net/project/rakarrack/rakarrack/rakarrack-%{version}/rakarrack-%{version}.tar.bz2
|
||||
Patch0: rakarrack-0.6.1-libfltk-1.3.3.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXcursor-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXfixes-devel
|
||||
BuildRequires: libXft-devel
|
||||
BuildRequires: libXinerama-devel
|
||||
BuildRequires: libXpm-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libfltk-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libjack-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libsamplerate-devel
|
||||
BuildRequires: libsndfile-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Rakarrack is a richly featured multi-effects processor emulating a guitar effects pedalboard. Effects include compressor, expander, noise gate, graphic equalizer, parametric equalizer, exciter, shuffle, convolotron, valve, flanger, dual flange, chorus, musicaldelay, arpie, echo with reverse playback, musical delay, reverb, digital phaser, analogic phaser, synthfilter, varyband, ring, wah-wah, alien-wah, mutromojo, harmonizer, looper and four flexible distortion modules including sub-octave modulation and dirty octave up. Most of the effects engine is built from modules found in the excellent software synthesizer ZynAddSubFX. Presets and user interface are optimized for guitar, but Rakarrack processes signals in stereo while it does not apply internal band-limiting filtering, and thus is well suited to all musical instruments and vocals. Rakarrack is designed for Linux distributions with Jack Audio Connection Kit.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/rakarrack
|
||||
%{_bindir}/rakconvert
|
||||
%{_bindir}/rakgit2new
|
||||
%{_bindir}/rakverb
|
||||
%{_bindir}/rakverb2
|
||||
%{_datadir}/applications/rakarrack.desktop
|
||||
%{_datadir}/pixmaps/icono_rakarrack_*.png
|
||||
%dir %{_datadir}/rakarrack/
|
||||
%{_datadir}/rakarrack/*
|
||||
%dir %{_datadir}/doc/rakarrack
|
||||
%{_datadir}/doc/rakarrack/*
|
||||
%{_mandir}/man1/rakarrack.1*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%changelog
|
||||
* Sun Apr 12 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.1-1mamba
|
||||
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user